Image-stitching and virtual tour solutions My account Updates
It is currently Thu Jul 24, 2014 7:33 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: Tue Oct 26, 2010 7:52 am 
Offline
Member

Joined: Tue Nov 06, 2007 1:49 pm
Posts: 68
I have imported my tour project from beta 1, getting a bunch of error messages and no hotspots working when generating the tour in beta 2. First I also got error messages in the app for missing the mobile template, but it worked after I changed the html template to "generic". Do I need to start all over again with the tour? It´s a quite complex project, so hopefully not.

The hotspots are links between VR images + flv video spots.

See image for error messages.




Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 26, 2010 8:16 am 
Offline
Administrator
User avatar

Joined: Mon Jan 05, 2009 1:57 pm
Posts: 341
I don't reproduce the errors of the player. Can you send me a simple project which has this problem.
(apt file must be sufficient I will replace used pictures)


Last edited by renan on Tue Oct 26, 2010 8:18 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 26, 2010 10:30 am 
Offline
Administrator
User avatar

Joined: Mon Jan 05, 2009 1:57 pm
Posts: 341
It's finally the generic HTML template which is not good.

issue 362 open

To temporally fix this, remove the '0' present in the XML file referenced in the generated HTML file.

In pro version, you can also modify or add a new HTML template (with the menu "Edit -> Open templates directory") with code :

Code:
<html>
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
    <title>Virtual Tour generated by Autopano Tour</title>
    <meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"/>
    <meta name="apple-mobile-web-app-capable" content="yes"/>
</head>
<body>
    <script src="swfobject/swfkrpano.js"></script>
   
    <h1>Project : $(PROJECTNAME)</h1>
    <div id="panoDIV" style="height:100%;">
        <script>
        embedpano({target:"panoDIV",swf:"$(SWF)",width:"100%",height:"100%",allowFullScreen:"true"});
        </script>
        <noscript>
            <div id="tour">
                <object width="100%" height="100%">
                    <embed src="$(SWF)" width="100%" height="100%" allowFullScreen="true">
                    </embed>
                </object>
            </div>
        </noscript>
    </div>
</body>
</html>


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 8:42 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
renan wrote:
To temporally fix this, remove the '0' present in the XML file referenced in the generated HTML file.

"referenced in the generated HTML file" sound good - what does it mean in usual speech?

Do you mean to generate a tour and remove a "0" in the xml of the generated tour?
Which "0" is it? Where do i find it? Does it laughs at me and shouts "here i am, stupid" when i open the xml?

best, Klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 8:57 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13568
Location: Isleham, Cambridgeshire, UK.
Klaus,

Why not make a permanent fix and add a new HTML template (or replace the Generic HTML template) with the code Renan provided:
http://www.autopano.net/forum/p71382-2010-10-26-10-30-26#p71382

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 8:58 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
Do i ask too much wanting an explanation which i can understand without being a programmer?

klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 8:59 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
mediavets wrote:
Klaus,

Why not make a permanent fix and add a new HTML template (or replace the Generic HTML template) with the code Renan provided:
http://www.autopano.net/forum/p71382-2010-10-26-10-30-26#p71382

Andrew - i really would like to do that . . BUT HOW??
I´, trying for half an hour now . . . .

Which Template folder must i use? The one in "Kolor" or the one in "Templates" ???
Which file must i edit?



_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Last edited by klausesser on Fri Nov 05, 2010 9:03 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 10:02 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13568
Location: Isleham, Cambridgeshire, UK.
The file I've marked - generic.html - is the one to replace (make a back up) with the modified code.



_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Last edited by mediavets on Fri Nov 05, 2010 10:03 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 10:27 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
Thank you, Andrew!

You mean: i´ll have to paste Renan´s code completely here and overwrite the existing code copletely?

best, Klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 11:02 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13568
Location: Isleham, Cambridgeshire, UK.
klausesser wrote:
Thank you, Andrew!

You mean: i´ll have to paste Renan´s code completely here and overwrite the existing code copletely?

best, Klaus

Yes, copy-n-paste Renan's code to make a new file - replace the file generic.html with this new file.

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 11:18 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
Thanks, man!!

best, Klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 11:45 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13568
Location: Isleham, Cambridgeshire, UK.
klausesser wrote:
Thanks, man!!

best, Klaus

And did that solve the problem?

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 11:53 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
mediavets wrote:
klausesser wrote:
Thanks, man!!

best, Klaus

And did that solve the problem?

Not really: when i open it on my iPod a "click" on a hotspot doesnt lead to the next node - as expected - but it goes back to the start-position of the initial node.
So i can´t go from room to room.
Of course i linked the hotspots in PTP like always - but i´ll try "go to pano-view" instead of "go to spot-view".
The simulation in Safari works! here i can move from room to room - but only when i start the .swf and not the html.
On iPod/phone/pad starting the .swf fails of course.

best, Klaus

P.S. doesn´t help. No way to go to another node. The hotspot "refers" to the node i´m already in.

You may check it here:

http://www.klausesser.de/Pad.html (or .swf)

Besides: VERY strange size on iPod/phone . . .

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Last edited by klausesser on Sat Nov 06, 2010 12:09 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 9:59 am 
Offline
Administrator
User avatar

Joined: Wed Sep 29, 2010 9:00 am
Posts: 197
Location: Francin
Template used in http://www.klausesser.de/Pad.html is buggy. You have to take Renan's version to make this working.
Why it doesn't work on mobile is due to <noscript> tag of html code that is not fixed in your version.

_________________
--
Yann G.
www.kolor.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group