Page 1 of 1

[APP 2.5B1 - OSX 10.5.8] - Save as TIFF color space problem?

PostPosted: Sat Oct 16, 2010 3:46 am
by Bmachine
Hello. Even though I have been using APP for a long time, I just started to use beta 2.5. Overall I like it quite a bit.

I did run into one problem though. I render a simple cylindrical pano with 8 images. Save as 8bit jpg. Everything works great.

Now I re-render the same exact one but save as 16bit Tiff. APP seems to do the job fine but no other software can open the file. Photoshop says "Cannot open because the TIFF uses unsupported color space." I looked in the mini log in the Render queue gui and it says there that the color space is LDR. I've never heard of LDR being a color space but in any case, why is it set to LDR by default? I tried to find where to change that but I can't find it anywhere.

In any case, I would think that a more portable color space should be the default.

How can I fix this?

Thank you

Bo Struye

P.S. I really hope this is not addressed elsewhere already.... I did a search and nothing came up... :(

PostPosted: Sat Oct 16, 2010 7:34 am
by hermer-blr
LDR stands for Low Dynamic Range (by reference to HDR, High dynamic Range). So, having processed your images as LDR is fine.

The general problem I have had with APP is that my panos cannot open with Nikon capture NX2 (I do not use Photoshop); the reason is that the panos are generated with an alpha channel that the Nikon software is unable to read.

As I own Photomatix, I open the rendered panorama with Photomatix and save it as a new file and my problem is resolved !

Maybe, there is a rendering option in Autopano with "no alpha channel". Try this...

PostPosted: Sat Oct 16, 2010 8:59 am
by mediavets
hermer-blr wrote:Maybe, there is a rendering option in Autopano with "no alpha channel". Try this...

There is in V 2.5:

PostPosted: Sat Oct 16, 2010 5:21 pm
by Bmachine
Thanks guys.

Yes, I am aware of what LDR means but, as far as I know, that has nothing to do with color space. That's why I am puzzled.

I use Photomatix also and it will open any pano saved as jpg but not saved as tiff, presumably because of this weird color space issue.

I would imagine that other people are saving as tiff, right? Is anyone else having the same problem?

I should also note that this worked fine in 2.0.9.

Thank you.

PostPosted: Sat Oct 16, 2010 8:16 pm
by Judy-A
Bmachine wrote:Now I re-render the same exact one but save as 16bit Tiff. APP seems to do the job fine but no other software can open the file. Photoshop says "Cannot open because the TIFF uses unsupported color space."

I can't reproduce this problem. All of the 16-bit TIFF images I've rendered (from APG 2.5B1 Mac) open just fine in Photoshop CS4 and Photomatix Pro 4.0.

Are you sure you didn't try to save as PSB and get a PSD instead? Those PSD files from APG 2.5B1 Mac won't open. (Confirmed issue #169)

I really doubt that the color profile is the issue in your files not opening. Photoshop can handle all kinds of color profiles. Depending on how you have your Photoshop Color Settings set up, it may ask you how to handle mismatched profiles.

You can't always trust error messages. There may be some other kind of file corruption happening on your machine.


APG 2.5.0 Beta 1
Mac Pro Quad Core Intel Xeon
Mac OS 10.6.4

PostPosted: Sat Oct 16, 2010 8:59 pm
by Bmachine
Thanks Judy.

Yes I'm sure I didnt try to save as PSB or D. If I did, I don't think I would get a message saying "Cannot open because the TIFF uses blah blah".

But it's good to hear that it works on your end. That means that it is something on my side then. I'll have to dig further.

Thanks for your help.


PostPosted: Sat Oct 16, 2010 9:33 pm
by Judy-A
There might be a difference between the APP and APG betas. I'm using APG.

When software encounters a problem it sends back an error code number which gets translated into plain language for the user.

If the Photoshop starts reading the file header, and it sees garbled code of any kind when it gets to data that should be a color profile, it may give you this message. It may be that the rest of the document is also corrupt. Is the file size comparable to a similar file rendered from APP 2.0.9?

Do you use Adobe Bridge? Can you view the images there, and if you can, what do you see in the Metadata tab>File Properties>Color Profile?

What version of Photoshop are you using?


PostPosted: Sun Oct 17, 2010 12:15 am
by Bmachine
OK, this is getting stranger by the minute.
I decided to do a simple test case with 3 images that I could run in both versions. So I first tried in 2.0.9.
Jpeg works just fine. Opens in PS no problems.
Tiff renders fine. BUT... lo and behold, it does not open in PS either!!! SO actually when I said earlier that this worked in 2.0.9, I was mistaken. What happened was that I always generate a PSD file from APP. But this time I wanted to go directly to Photomatix so I decided to write a TIFF instead of PSD. I happened to be in 2.5B1 at the time and when I noticed that it would not open in PS (with that "Unsupported color space" error), I mistakenly assumed it was an issue with the beta. But it turns out that the same problem exists with 2.0.9. I just rarely use the TIFF output and that is why I did not see it before.
I thought it might be the compression option that APP gives you for TIFF but I chose "None" just to be safe.
I'd love to send you the 3 test images to see if anyone else can reproduce this. Is there an official method for doing this?
In the meantime, Judy, what file format do you use to go from APP to Photomatix? I need a 16 bit one so PM can do the best job possible.
Thank you.

PS I am using PM Pro 4.0 and PS CS3.
PPS In Bridge, I do not see any color space info under File Properties. Only the usual file sizes and types, etc...

PostPosted: Sun Oct 17, 2010 4:08 am
by Judy-A
You may have an issue with different preferences versions causing problems for each other. Alexandre mentioned somewhere that this might be an issue with the beta on Macs.

Try deleting all of your Kolor plist files.
1. First quit all versions of APP.
2. Have your registration key numbers on hand.
3. Go to [user]/Library/Preferences and search for 'kolor'.
4. Remove those files.
5. Launch only the APP version you want to test (presumably the beta).
6. You will be asked to register. Register and reset preferences.
7. Quit (to save newly set prefs.)
8. Relaunch.
9. Create a new project and test the same image files again.

If you put the images in a zip archive and upload them to a web site somewhere, I'll be happy to download and test them on my machine.


APG 2.5.0 Beta 1
Mac Pro Quad Core Intel Xeon
Mac OS 10.6.4

PostPosted: Sun Oct 17, 2010 5:05 am
by Bmachine
Thanks for your efforts Judy. I just did that whole process but it did not make any difference.

So after that I decided to try with some other source images. I rarely use jpegs as source but in this case, I had to in order to test a number of panos before committing too much time to them. So I used a set of images from a year ago. And sure enough, it worked! APP generated a pano in TIFF format and PS and PM were happy to open it.

So what was the difference between the old set of images and the new ones? The cameras were different (Nikon D40 and D90) but these are popular cameras so surely someone would have noticed this before. But, perhaps more importantly... the conversion software! The older images were NEF exported as jpegs by iPhoto. The new ones were NEF exported as jpegs by Aperture. And those are the ones that end up causing the problem. What's weird is that the problem only shows up way downstream AFTER APP successfully generated a pano out of them. Huh??? If there was a problem with the jpegs, why does APP not complain? And why does it save a pano as jpeg without any problem?

To test the theory, I re exported the same pics as TIFF from Aperture and then did the pano in APP. That worked just fine even when saved as TIFF.

Bottom line is: Photos exported by Aperture in jpeg format cause a problem with APP panos exported as TIFF. It manifests itself as "unsupported color space" in Photoshop.

Go figure...