Autopano Tour 1.0.9 and 1.1.0 beta 11 crashing when browsing for files  

This forum is fully dedicated to Autopano Tour. Bug report as well as feature discussion.
no avatar
gdavidson
Member
 
Posts: 29
Joined: Sat Nov 20, 2010 12:56 pm

Autopano Tour 1.0.9 and 1.1.0 beta 11 crashing when browsing for files

by gdavidson » Sat Nov 20, 2010 1:26 pm

Hi!

Having recently moved to a new computer using Windows 7 64 bit, I am unable to use Autopano Tour version as supplied by default in Autopano Giga 2.0.9 nor the current 64 bit 1.1.0 beta 11. Any time I try to add a panorama, I get briefly an error - image attached, and the application closes.

After some research I have discovered that when opening any window in Auto Pano Tour that allows you to browse the hard drive, the application will crash with that error any time if finds a folder with an image in it!

This also happens when I try to browse to my licence files, so I cannot even register the program.

I have tried starting the computer in safe mode but the problem is the same.

If anyone can help me with this I would be grateful.

Thank you!

--
Graeme


Last edited by gdavidson on Sat Nov 20, 2010 1:27 pm, edited 1 time in total.

no avatar
gdavidson
Member
 
Posts: 29
Joined: Sat Nov 20, 2010 12:56 pm

by gdavidson » Sat Nov 20, 2010 1:45 pm

Okay - this gets technical!

After further research using Process Explorer I have traced the issue to what I suspect to be the FastPictureViewer codec pack I use in order to see nikon .nef thumbnails in windows 7 64 bit.

I found when opening a browser window in AutoPano Tour, the explorer.exe process would be using the libiomp5md.dll library. This then revealed the GUID below which belongs to FastPictureViewer

C:\Windows\WICCodecs\{A6D092A4-081A-4F0E-9356-DA167E87D922}\Raster Formats\JPEG\Amd64\libiomp5md.dll

It would appear that there may be an incompatibility between AutoPano Tour and FastPicture viewer.... argh!

The error suggests that both apps are trying to initialize the same libraries and that this doesn't work out.

I'm between a rock and a hard place - I really need my thumbnails and I would like to use AutoPano Tour.

Hope the above info can lead to a workaround/solution.

Thanks!

no avatar
ThomasK
Member
 
Posts: 28
Joined: Tue Apr 04, 2006 10:46 am

by ThomasK » Sat Nov 20, 2010 2:23 pm

You could use Autoruns to disable the FastPictureViewer at the startup of Windows:
http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx

no avatar
mediavets
Moderator
 
Posts: 14287
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

by mediavets » Sat Nov 20, 2010 2:24 pm

Welcome to the forum...

Some comments:

1. Did you try Panotour which will be replacing Autopano Tour?
http://www.kolor.com/v3/index.php/en/component/content/article/25

2. AFAIK you cannot import NEF images into Autopano Tour or Panotour so can you not just place the pano images in an acceptable format in another folder (where there are no NEF images) before importing them to Autopano Tour or Panotour?
Last edited by mediavets on Sat Nov 20, 2010 2:26 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
gdavidson
Member
 
Posts: 29
Joined: Sat Nov 20, 2010 12:56 pm

by gdavidson » Sat Nov 20, 2010 2:45 pm

Thak you for the suggestion ThomasK. I had already tried that but soon realised that it was Codecs that were to blame which, sadly, are unaffected by disabling startup programs.

Thank you, Mediavets, for the suggestions too. I will download Panotour to see if that works. You are correct about NEF files not being supported but I discovered FastPictureViewer codecs appeared to kick in even when there were no NEF files present. I recall that it has a faster JPEG rendering engine in place of Win 7's so I think the library file gets initialised even when there are no NEF files present.

I'll give Panotour a go - fingers crossed!

Thanks!

--
Graeme

no avatar
gdavidson
Member
 
Posts: 29
Joined: Sat Nov 20, 2010 12:56 pm

by gdavidson » Sat Nov 20, 2010 3:21 pm

Sadly, I have to report that Panotour also crashes in exactly the same manner.

I'm out of ideas for now - Panotour would crash whenever I browsed through a folder path that had a jpeg anywhere on the way.

Autopano Giga 2.5 B2 is absolutely fine in this respect.

--
Graeme

User avatar
ygilquin
Kolor Team
 
Posts: 200
Joined: Wed Sep 29, 2010 9:00 am
Location: Francin

by ygilquin » Mon Nov 22, 2010 2:20 pm

Can you please provide the url where you got the FastPictureViewer codec pack ? Then we will open an issue and investigate.
--
Yann G.
www.kolor.com

no avatar
gdavidson
Member
 
Posts: 29
Joined: Sat Nov 20, 2010 12:56 pm

by gdavidson » Mon Nov 22, 2010 9:12 pm

Thank you Yann for investigating this for me - I really appreciate it.

I am using the 64bit version of FastPictureViewer from http://www.fastpictureviewer.com/downloads/

I believe the download version works for a few weeks without needing to be purchased.

Just to give you more information, I can make use of Panotour and Autopano Tour if I drag the files into the app instead of trying to browse to them in the usual manner. Saving can be hazardous if the destination folder has jpegs in it - the app will crash, sometimes not immediately but after several seconds , as if it were taking time to find the jpegs before giving the error.

My impression is that the error is only produced when using an open/save window which happens to have jpegs in the folder.

If you need any further information, let me know.

Thanks again.

--
Graeme
Last edited by gdavidson on Mon Nov 22, 2010 10:03 pm, edited 1 time in total.

no avatar
ThomasK
Member
 
Posts: 28
Joined: Tue Apr 04, 2006 10:46 am

by ThomasK » Tue Nov 23, 2010 7:26 am

Try to rename libiomp5mt.dll in something like libiomp5mt.dll_bak
http://software.intel.com/en-us/articles/opm-abort-initializing-libguide40dll/

User avatar
ygilquin
Kolor Team
 
Posts: 200
Joined: Wed Sep 29, 2010 9:00 am
Location: Francin

by ygilquin » Mon Nov 29, 2010 2:50 pm

Issue 449 open.
--
Yann G.
www.kolor.com


Return to Archive

Who is online

Users browsing this forum: No registered users and 1 guest