AttributeError while trying to start after installation on N810  

Everything you need to motorize your head
no avatar
hoehguensch
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Wed Jan 27, 2010 9:09 pm
Location: Mainz (Germany)
Info

AttributeError while trying to start after installation on N810

by hoehguensch » Wed Jan 27, 2010 9:32 pm

Hello to everybody,
I'm new member of the Merlin/Orion-Papywizard users. I just tried to install papaywizard on my Nokia N810.
I did it step by step like described in the "Papywizard V2 Installation Guide" (Install Papywizard v2 on Nokia N8x0).

After all I tried to start papywizard from the Extra Menu - but nothing happened.
After that I tried to start papywizard from the xTerminal. There I get the following Error:

Traceback (most recent call last):
File "<string>", line 1, in <module>
File "usr/lib/python2.5/site-packages/papywizard/scripts/main.py", line 56, in <module>
from papywizard.common.loggingServices import Logger
File "usr/lib/python2.5/site-packages/papywizard/common/loggingServices.py", line 71, in <module>
class LoggerObject(QtCore.QObject):
AttributeError: 'module' object has no attribute 'QObject'

I don't know what went wrong. Is there anybody out there who could help me please?

Thanks in advance!!!

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Wed Jan 27, 2010 9:58 pm

Welcome on board Daniel,

looks like something went wrong installing PyQt.
Check installed programs with program manager.
Paul

close, but no cigar ... ... ...

no avatar
hoehguensch
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Wed Jan 27, 2010 9:09 pm
Location: Mainz (Germany)
Info

by hoehguensch » Wed Jan 27, 2010 10:13 pm

Hello Paul,
in the list of installed programms I can't find PyQt.

The following things are in the list:
---------------------------------
godmode
maemo-python-device-env
(map)
(OS2008 Feature upgrade)
papywizard
(tutorial-home-applet)

When I try the following: apt-get install python2.5-qt4-core python2.5-qt4-gui
I get the mesage that the newest Version is already installed

Is there an other PyQt I have to install?

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 29, 2010 5:23 pm

Qt libs are not listed in the application manager because they are not applications, but just libs (I think this is a mistake to hide libs, but...).

I don't understand why you get this error. Could you try:

$ apt-cache show python2.5-qt4-core

and have a look at the package version?
Frédéric

no avatar
hoehguensch
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Wed Jan 27, 2010 9:09 pm
Location: Mainz (Germany)
Info

by hoehguensch » Fri Jan 29, 2010 7:01 pm

Hello,

here's what the command shows:

/home/user # apt-cache show python2.5-qt4-core
Package: python2.5-qt4-core
Priority: extra
Section: libs
Installed-Size: 1616
Maintainer: Attila Csipa <maemo@csipa.in.rs>
Architecture: armel
Source: python-qt4
Version: 4.6.2-maemo20091218.1
Depends: libc6 (>= 2.5.0-1), libgcc1 (>= 1:3.4.4), libqtcore4 (>= 4.5.0), libstdc++6 (>= 3.4.4), libx11-6, libxext6, libqt4-maemo5-core | libqt4-core (>= 4.5.0), python2.5-qt4-common (= 4.6.2-maemo20091218.1)
Filename: pool/diablo/free/p/python-qt4/python2.5-qt4-core_4.6.2-maemo20091218.1_armel.deb
Size: 471254
MD5sum: 77bd4cf08b65614f11b68e986eae60af
SHA1: 97c8cf50d8c8a105464234a12b6e2b69d2cb6a5a
SHA256: 32f7101758be5dff14b1a62f64e0b7930b4e68c25f262c5e35fc234d062d79ce
Description: Python bindings for Qt4 Core components.
This package contains the python extensions and modules.

Package: python2.5-qt4-core
Priority: extra
Section: libs
Installed-Size: 1668
Maintainer: Attila Csipa <maemo@csipa.in.rs>
Architecture: armel
Source: python-qt4
Version: 4.6.2-maemo20091123.2
Depends: libc6 (>= 2.5.0-1), libgcc1 (>= 1:3.4.4), libqtcore4 (>= 4.5.0), libstdc++6 (>= 3.4.4), libx11-6, libxext6, libqt4-maemo5-core | libqt4-core (>= 4.5.0), python2.5-qt4-common (= 4.6.2-maemo20091123.2)
Filename: pool/diablo/free/p/python-qt4/python2.5-qt4-core_4.6.2-maemo20091123.2_armel.deb
Size: 489746
MD5sum: 3d1bfa7bd9761811c2706284fa8cb192
SHA1: cfc5084780339265df5dc0d02863278e9b27b9f6
SHA256: a8f0e05b7ad5aa66be6014a49611387873f1e9978fba8d994e89f00ae56481be
Description: Python bindings for Qt4 Core components.
This package contains the python extensions and modules.

Package: python2.5-qt4-core
Priority: extra
Section: libs
Installed-Size: 1656
Maintainer: Renato Filho <renato.filho@openbossa.org>
Architecture: armel
Source: python-qt4
Version: 4.4.3-maemo10
Depends: libc6 (>= 2.5.0-1), libgcc1 (>= 1:3.4.4), libqtcore4 (>= 4.5.0), libstdc++6 (>= 3.4.4), libx11-6, libxext6, libqtcore4 (>= 4.4.1), python2.5-qt4-common (= 4.4.3-maemo10)
Filename: pool/diablo/free/p/python-qt4/python2.5-qt4-core_4.4.3-maemo10_armel.deb
Size: 484568
MD5sum: 4441920165990eead4d4c7669313869f
SHA1: c3547299818f44fa37a415bd64801761eedf3daa
SHA256: 78521977c251733712edaf5caa8fd45ac71baf7414376154802f62177e9b7c1c
Description: Python bindings for Qt4 Core components.
This package contains the python extensions and modules.

Package: python2.5-qt4-core
Priority: extra
Section: libs
Installed-Size: 1696
Maintainer: Renato Filho <renato.filho@openbossa.org>
Architecture: armel
Source: python-qt4
Version: 4.4.3-maemo9
Depends: libc6 (>= 2.5.0-1), libgcc1 (>= 1:3.4.4), libqtcore4 (>= 4.4.0), libstdc++6 (>= 3.4.4), libx11-6, libxext6, libqtcore4 (>= 4.4.1), python2.5-qt4-common (= 4.4.3-maemo9)
Filename: pool/diablo/free/p/python-qt4/python2.5-qt4-core_4.4.3-maemo9_armel.deb
Size: 496058
MD5sum: 215b35514a21a4faa4299fb4b466223f
SHA1: 47b08cecde23fb5d93ebc063e78ce9f5d7a42ebd
SHA256: 800f3ef4a417a895a047cdcc2fd01d83d49f1bd01cf70815d3a14d7fdaeab265
Description: Python bindings for Qt4 Core components.
This package contains the python extensions and modules.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 29, 2010 7:32 pm

I have to dig this!
Frédéric

no avatar
120to120
Member
 
Posts: 144
Likes: 0 post
Liked in: 0 post
Joined: Thu Mar 12, 2009 8:32 pm
Info

by 120to120 » Fri Jan 29, 2010 11:36 pm

Hallo hoehguensch,
hab am Nokia810 stabile PW 1.6.1 installiert, là¤uft super!

pn schon gelesen?

jozef
(*Merlin/Orion_BT - teleskop-austria.*); FTDI USB-TTL cable; Macbook (Intel) OS X10.5.6 / ext. Bluetooth Dongle_VIVANCO_B1002270209 / PW 2.1.20; Go-To / TA *Nokia N810 / PW 2.1.20 * Sony F717 / Sony R1 ; JJC SR-828; 15m Mast;

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sat Jan 30, 2010 12:28 am

Fréderic,
For your information ...

I have the same problem with the last version of PPW:
"Erreur: Dépendance non satisfaite : python2.5-qt4-core" (Ubuntu)

I have reinstalled the previous version !
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
120to120
Member
 
Posts: 144
Likes: 0 post
Liked in: 0 post
Joined: Thu Mar 12, 2009 8:32 pm
Info

by 120to120 » Sat Jan 30, 2010 9:21 am

Hallo claudevh,

Fréderic,
For your information ...

I have the same problem with the last version of PPW:
"Erreur: Dépendance non satisfaite : python2.5-qt4-core" (Ubuntu)

I have reinstalled the previous version ! -------PW xxxx?????

Thanks for Info.
Jozef
Last edited by 120to120 on Sat Jan 30, 2010 9:22 am, edited 1 time in total.
(*Merlin/Orion_BT - teleskop-austria.*); FTDI USB-TTL cable; Macbook (Intel) OS X10.5.6 / ext. Bluetooth Dongle_VIVANCO_B1002270209 / PW 2.1.20; Go-To / TA *Nokia N810 / PW 2.1.20 * Sony F717 / Sony R1 ; JJC SR-828; 15m Mast;

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Jan 30, 2010 9:33 am

Claude, the debian package is specific to maemo; you can't use it on ubuntu.
Frédéric

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sat Jan 30, 2010 10:21 am

OK Frederic !!!

Thanks ...:rolleyes:

Yes, I am "ZERO" in Linux ! I must continue to learn, maybe isn't to late ! ;)

For guy's like me, who are Linux beginners, is that not possile to get also a package like for Windows, Mac and Maemo ? :/
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Jan 30, 2010 11:04 am

Yes, I will try to do that. Good idea!
Frédéric

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sat Jan 30, 2010 11:26 am

Fine Fréderic ! ..... "big kiss !!!" for the next "New-Year" ;)

This will be really helpfull in the search of "The Graal" for new linux platforms ... :)
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sun Jan 31, 2010 12:09 pm

Ok, debian/ubuntu users, could you try to install this package:

http://www.gbiloba.org/download/tmp/papywizard_2.1.14-1_all.deb

if you encounter some problems, please give me the result of the following command:

$ apt-cache search qt4 | grep python
Frédéric

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sun Jan 31, 2010 12:52 pm

Hello Fred,

Fail on Ubuntu (Acer Aspire one "Netbook") ! :/

Erreur: Architecture incorrecte

claude@claude-laptop:~$ apt-cache search qt4 | grep python
python-qscintilla2 - Python bindings for QScintilla 2
python-qt4-phonon - Python bindings for Phonon
python-qt4-phonon-dbg - Python bindings for Phonon (debug extensions)
python-qt4-sql - Python bindings for PyQt4's SQL module
python-qt4-sql-dbg - Python bindings for PyQt4's SQL module (debug extension)
python-qt4 - Liaisons Python pour Qt4
python-qt4-dbg - Liaisons Python pour Qt4 (extensions de débogage)
python-qt4-dbus - gestion DBus pour PyQt4
python-qt4-dbus-dbg - DBus Support for PyQt4 (debug extensions)
python-qt4-dev - Fichiers de développement pour PyQt4
python-qt4-doc - Documentation et exemples pour PyQt4
python-avc - live connection among widgets and application variables
python-qt4-gl - Python bindings for Qt4's OpenGL module
python-qt4-gl-dbg - Python bindings for Qt4's OpenGL module (debug extension)
python-qwt3d-doc - Documentation for the Python-qwt3d library
python-qwt3d-qt4 - Python bindings of the QwtPlot3D library
python-qwt5-qt4 - Python version of the Qwt5 technical widget library
claude@claude-laptop:~$

Fréderic,
Voilà  ce que j'obtiens
Last edited by claudevh on Sun Jan 31, 2010 12:53 pm, edited 1 time in total.
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sun Jan 31, 2010 1:32 pm

Try this new version:

http://www.gbiloba.org/download/tmp/papywizard_2.1.14-2_all.deb

it should work on all archs...

Edit: I just fixed the link (19h00)
Last edited by fma38 on Sun Jan 31, 2010 7:00 pm, edited 1 time in total.
Frédéric

no avatar
hoehguensch
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Wed Jan 27, 2010 9:09 pm
Location: Mainz (Germany)
Info

by hoehguensch » Sun Jan 31, 2010 10:02 pm

Hello,
many thanks to all spending their time to solve the problem!!!
I just tried to install the new Version but now - while installing qt4 I get the message that python2.5-qt4-core can't be installed because of dependencies to python2.5-qt4-common (= 4.7-maemo3)
and the message E: damaged packets

I don't know what's the reason for that - I flashed my Nokia new three times now but every time the installation didn't succeed.
Some days ago the installation went through without errors - is there something wrong with my Nokia?

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sun Jan 31, 2010 11:07 pm

There is probably a problem in the packages... Wait a few days to see if the problem is still here (don't forget to refresh the list of packages from the manager).
Frédéric


Who is online

Users browsing this forum: No registered users and 1 guest