Trouble with new Merlin with BT + N800 - Please HELP!  

Everything you need to motorize your head
User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

Trouble with new Merlin with BT + N800 - Please HELP!

by FelixAutopano » Fri Oct 23, 2009 9:23 pm

I've just bought the Merlin head with the Ursaminor BT interface v2 (all from http://www.teleskop-austria.at). I have troubles with connection together with N800. On my N800 I have the latest firmware and Papywizard correctly installed.
I successfully paired the devices together. In PW after Hardware-Connect the BT icon on N800 turns Blue and LED on the BT interface is still on. But the error "Can't connect to hardware Axis 1 can't send command" occurs.
What should I do? Is somwhere a detailed manual how to connect these devices together?
On the http://www.autopano.net/forum/p34944-2008-12-18-10-45-36 is some info about the Baudrate, but I think it is the problem with the Tronisoft module - not with Ursaminor.
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Oct 23, 2009 9:53 pm

Yes, Ursa Minor interface should work out-of-the-box. The problem is elsewhere.

What version of Papywizard are your running? 2.1.11? Could you post the log (menu Help -> View log, save it on your external memory card, and transfert it to your PC using the USB connection)?

Could you also try this release:

http://www.papywizard.org/static/download/papywizard_2.1.12-1_all.deb
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Sun Oct 25, 2009 10:40 am

I think, this is the needed piece of code:
Code: Select all
2009-10-25 10:55:18,973::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 176, in _sendCmd
    c = self._driver.read(1)
  File "/usr/lib/python2.5/site-packages/papywizard/hardware/bluetoothDriver.py", line 110, in read
    data = self._sock.recv(size)
  File "<string>", line 5, in recv
BluetoothError: timed out
2009-10-25 10:55:19,010::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 1 can't sent command 'L1'. Retrying...
2009-10-25 10:55:19,041::Main::EXCEPTION::PluginsConnector.connectPlugins()
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/papywizard/plugins/pluginsConnector.py", line 126, in start
    plugin.init()
  File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 521, in init
    self._initMerlinOrion()
  File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 207, in _initMerlinOrion
    self._sendCmd("L")
  File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 193, in _sendCmd
    raise HardwareError("%s axis %d can't send command '%s'" % (NAME, AXIS_TABLE[self.capacity], cmd))
HardwareError: Merlin-Orion axis 1 can't send command 'L1'
2009-10-25 10:55:19,083::Main::ERROR::Connection failed to start
2009-10-25 10:55:24,864::Main::DEBUG::MainController.__onActionHardwareConnectToggled(False)
2009-10-25 10:55:24,901::Main::DEBUG::PluginsConnector.start(): 'yawAxis' stop connection
2009-10-25 10:55:24,940::Main::DEBUG::PluginsConnector.start(): 'pitchAxis' stop connection
2009-10-25 10:55:24,980::Main::DEBUG::PluginsConnector.start(): 'shutter' stop connection

When not: http://www.usti-nl.cz/papywizard.log

Thanks
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sun Oct 25, 2009 11:13 am

Does the head work fine with the original controller?
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Sun Oct 25, 2009 11:15 am

Yes it does!
I've tried it also from my PC with BT dongle without success - in this case I think this is the problem of the BT dongle - it is very very old.
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sun Oct 25, 2009 11:33 am

Can you pair the device on your PC?
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Sun Oct 25, 2009 11:36 am

Yes, but once from 10 attempts. The PW on PC after Hardware-Connect hangs.
The God is Out There

User avatar
gkaefer
Member
 
Posts: 3549
Likes: 0 post
Liked in: 15 posts
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg
Info

by gkaefer » Sun Oct 25, 2009 5:39 pm

is the hand controller additionally plugged in?
if so - unplug it. it comes to problems if both are connected...
lg
Georg
Last edited by gkaefer on Sun Oct 25, 2009 5:39 pm, edited 1 time in total.

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Sun Oct 25, 2009 6:06 pm

No it isn't!
Always the same error. :(
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Mon Oct 26, 2009 8:26 am

There might be a problem with the BT interface.
Frédéric

no avatar
Briger
Member
 
Posts: 64
Likes: 0 post
Liked in: 0 post
Joined: Mon May 04, 2009 4:42 pm
Location: Switzerland
Info

by Briger » Mon Oct 26, 2009 4:19 pm

i have the same Problem.

2009-10-23 15:01:42,750::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 191, in _sendCmd
c = self._driver.read(1)
File "/usr/lib/python2.5/site-packages/papywizard/hardware/bluetoothDriver.py", line 104, in read
data = self._sock.recv(size)
File "<string>", line 5, in recv
BluetoothError: timed out
2009-10-23 15:01:42,773::Main::WARNING::MerlinOrionHardware._sendCmd(): axis 1 can't sent command 'L1'. Retrying...
2009-10-23 15:01:43,821::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 191, in _sendCmd
c = self._driver.read(1)
File "/usr/lib/python2.5/site-packages/papywizard/hardware/bluetoothDriver.py", line 104, in read
data = self._sock.recv(size)
File "<string>", line 5, in recv
BluetoothError: timed out
2009-10-23 15:01:43,858::Main::WARNING::MerlinOrionHardware._sendCmd(): axis 1 can't sent command 'L1'. Retrying...
2009-10-23 15:01:43,871::Main::EXCEPTION::PluginsConnector.connectPlugins()
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/papywizard/plugins/pluginsConnector.py", line 126, in start
plugin.init()
File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 530, in init
self._initMerlinOrion()
File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 222, in _initMerlinOrion
self._sendCmd("L")
File "/usr/lib/python2.5/site-packages/papywizard/plugins/merlinOrionPlugins.py", line 208, in _sendCmd
raise HardwareError("MerlinOrion axis %d can't send command '%s'" % (NUM_AXIS[self.capacity], cmd))
HardwareError: MerlinOrion axis 1 can't send command 'L1'
2009-10-23 15:01:43,887::Main::ERROR::Connection failed to start
2009-10-23 15:01:46,014::Main::DEBUG::MainController.__onActionHardwareConnectToggled(False)
2009-10-23 15:01:46,067::Main::DEBUG::PluginsConnector.start(): 'yawAxis' stop connection
2009-10-23 15:01:46,081::Main::DEBUG::PluginsConnector.start(): 'pitchAxis' stop connection
2009-10-23 15:01:46,096::Main::DEBUG::PluginsConnector.start(): 'shutter' stop connection

I try to use the Testprogram from www.ursaminor.hu and i become only a Error: Cannot connect to telescope mount.

The BT-Dongle or the Merlin mount make the Problem not Papywizard.

Over 10 Weeks for delivery of the Mount and now this. :-(
D800, D300, D80, Seitz Roundshot VR2, Nodal Ninja5 RD16, Nikkor 10,5, Nikkor 24-70, Nikkor 70-200, Sigma 150-500, Nikkor 105VR, ....

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 4:24 pm

I've tried it again from PC with the new BT dongle and without success. With ursaminor test software I have the same error as Briger (Pairing between PC and BT interface is OK).
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Mon Oct 26, 2009 4:25 pm

Could you try to pair it from your OS bluetooth tool, then check what virtual com port it provides, and give that port number to Papywizard, using the serial driver? Remember to enter the full string (like 'COM4'), or the int value minus 1 (com4 -> 3).

Does it work better?
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 4:31 pm

Code: Select all
2009-10-26 16:29:42,842::MainThread::INFO::Connecting to real hardware...
2009-10-26 16:29:45,296::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last):  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmdIOError: Timeout while reading on serial bus
2009-10-26 16:29:45,296::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 16:29:45,530::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last):  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmdIOError: Timeout while reading on serial bus
2009-10-26 16:29:45,530::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 16:29:45,765::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last):  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmdIOError: Timeout while reading on serial bus
2009-10-26 16:29:45,765::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 16:29:45,765::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()Traceback (most recent call last):  File "papywizard\model\shooting.pyo", line 378, in switchToRealHardware  File "papywizard\hardware\head.pyo", line 90, in init  File "papywizard\hardware\axis.pyo", line 252, in init  File "papywizard\hardware\axis.pyo", line 243, in _sendCmdHardwareError: Axis 1 can't send command
2009-10-26 16:29:45,858::MainThread::ERROR::Can't connect to hardwareAxis 1 can't send command
2009-10-26 16:29:47,108::MainThread::INFO::Go to simulation mode

I think that the BT interface is somehow broken.
The God is Out There

no avatar
Briger
Member
 
Posts: 64
Likes: 0 post
Liked in: 0 post
Joined: Mon May 04, 2009 4:42 pm
Location: Switzerland
Info

by Briger » Mon Oct 26, 2009 5:16 pm

With PC and Bluethoot Dongle the same Problem. Try to Switch to Serial and again the same Problem.

I think its better for all other Users here not order this 2 Devices at the moment. Its not works.

Patrick
D800, D300, D80, Seitz Roundshot VR2, Nodal Ninja5 RD16, Nikkor 10,5, Nikkor 24-70, Nikkor 70-200, Sigma 150-500, Nikkor 105VR, ....

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Mon Oct 26, 2009 5:45 pm

Hi FelixAutopano and Briger,

Could-you both 2 give us some info's:

- Merlin GoTo or Non GoTo ?
- Ursaminor BT Module Version 1 or Version 2
- Type of PC mainly Windows version or other ?(detail please !)
- Bluetooth "Stack" installed (Have a look in the "control panel" / "programs' ---> Bluetooth) (exemple herafter the BT stack is WIDCOMM)
- the Papywizard "exact version"

We will see what whe can do for you ....


:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 6:09 pm

I have mont-fot-mff-tr from http://www.teleskop-austria.at/prod.php?lng=de&tid=8#foto-mottri-nn - exactly this http://www.lookaround.nl/images/net/MERLIN_MULTI/image_016.html.
Ursaminor BT Module Version 2
N800 with latest Maemo OS2008 and PC with Win XP SP3
BT "Stack" is Windows Default
PW on N800 ver. 2.1.12-1 and on Win XP ver. 2.0.0.
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Mon Oct 26, 2009 6:15 pm

FexlixAutopano, where do the last logs you sent come from? It slooks like an old Papywizard version...
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 6:23 pm

First log is from PW on N800 and the second one is from PW on Win XP
The God is Out There

no avatar
Briger
Member
 
Posts: 64
Likes: 0 post
Liked in: 0 post
Joined: Mon May 04, 2009 4:42 pm
Location: Switzerland
Info

by Briger » Mon Oct 26, 2009 6:27 pm

Merlin Non Goto the new delivery from TA
Nokia N810 OS 2008 5.2008.43-7
Papywizard V2.1.10
BT Interface Ursaminor V1

PC Windows Vista
Bluethoot Dongle
Bluethoot Stack Windows
Papwizard V 2.1.10

On both Nokia andf PC the same Problem.
D800, D300, D80, Seitz Roundshot VR2, Nodal Ninja5 RD16, Nikkor 10,5, Nikkor 24-70, Nikkor 70-200, Sigma 150-500, Nikkor 105VR, ....

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Mon Oct 26, 2009 6:27 pm

Ok, but your XP test is not made with the latest release...
Frédéric

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 7:02 pm

It is made with stable version 2.0.0.
When I install lastest dev version I cannot run PW (config file error). Then when I copy common folder to view/ui it runs. But on BT connection PW hangs. And on serial connection with error.
Code: Select all
2009-10-26 18:53:16,217::MainThread::INFO::Connecting to real hardware...
2009-10-26 18:53:20,233::Dummy-4::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:20,233::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:20,467::Dummy-4::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:20,467::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:20,703::Dummy-4::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:20,703::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:20,703::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()
Traceback (most recent call last):
  File "papywizard\model\shooting.pyo", line 378, in switchToRealHardware
  File "papywizard\hardware\head.pyo", line 90, in init
  File "papywizard\hardware\axis.pyo", line 252, in init
  File "papywizard\hardware\axis.pyo", line 243, in _sendCmd
HardwareError: Axis 1 can't send command
2009-10-26 18:53:20,750::MainThread::ERROR::Can't connect to hardware
Axis 1 can't send command
2009-10-26 18:53:22,453::MainThread::INFO::Go to simulation mode
2009-10-26 18:53:22,687::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:22,687::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:22,921::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:22,921::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:23,155::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
  File "papywizard\hardware\axis.pyo", line 236, in _sendCmd
  File "papywizard\hardware\serialDriver.pyo", line 114, in sendCmd
IOError: Timeout while reading on serial bus
2009-10-26 18:53:23,155::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-10-26 18:53:23,155::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()
Traceback (most recent call last):
  File "papywizard\model\shooting.pyo", line 391, in switchToSimulatedHardware
  File "papywizard\hardware\head.pyo", line 106, in shutdown
  File "papywizard\hardware\axis.pyo", line 372, in stop
  File "papywizard\hardware\axis.pyo", line 243, in _sendCmd
HardwareError: Axis 1 can't send command
The God is Out There

no avatar
Briger
Member
 
Posts: 64
Likes: 0 post
Liked in: 0 post
Joined: Mon May 04, 2009 4:42 pm
Location: Switzerland
Info

by Briger » Mon Oct 26, 2009 7:09 pm

I have try with the last Version of Papywizard and the result is the same.

Here Copy of the try with Serial connection:

2009-10-26 19:07:15,250::Main::DEBUG::PluginsConnector.start(): 'pitchAxis' establish connection
2009-10-26 19:07:15,250::Main::DEBUG::PluginsConnector.start(): 'pitchAxis' init
2009-10-26 19:07:16,282::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:16,282::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 2 can't sent command 'L2'. Retrying...
2009-10-26 19:07:17,318::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:17,318::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 2 can't sent command 'L2'. Retrying...
2009-10-26 19:07:18,361::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:18,361::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 2 can't sent command 'L2'. Retrying...
2009-10-26 19:07:18,361::Main::EXCEPTION::PluginsConnector.connectPlugins()
Traceback (most recent call last):
File "papywizard\plugins\pluginsConnector.pyo", line 108, in start
File "papywizard\plugins\merlinOrionPlugins.pyo", line 339, in init
File "papywizard\plugins\merlinOrionPlugins.pyo", line 207, in _initMerlinOrion
File "papywizard\plugins\merlinOrionPlugins.pyo", line 193, in _sendCmd
HardwareError: Merlin-Orion axis 2 can't send command 'L2'
2009-10-26 19:07:18,361::Main::DEBUG::PluginsConnector.start(): 'shutter' establish connection
2009-10-26 19:07:18,361::Main::DEBUG::PluginsConnector.start(): 'shutter' init
2009-10-26 19:07:19,411::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:19,411::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 1 can't sent command 'L1'. Retrying...
2009-10-26 19:07:20,463::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:20,463::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 1 can't sent command 'L1'. Retrying...
2009-10-26 19:07:21,506::Main::EXCEPTION::MerlinOrionHardware._sendCmd
Traceback (most recent call last):
File "papywizard\plugins\merlinOrionPlugins.pyo", line 176, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 115, in read
IOError: Timeout while reading on serial bus (size=1, data='')
2009-10-26 19:07:21,506::Main::WARNING::MerlinOrionHardware._sendCmd(): Merlin-Orion axis 1 can't sent command 'L1'. Retrying...
2009-10-26 19:07:21,506::Main::EXCEPTION::PluginsConnector.connectPlugins()
Traceback (most recent call last):
File "papywizard\plugins\pluginsConnector.pyo", line 126, in start
File "papywizard\plugins\merlinOrionPlugins.pyo", line 521, in init
File "papywizard\plugins\merlinOrionPlugins.pyo", line 207, in _initMerlinOrion
File "papywizard\plugins\merlinOrionPlugins.pyo", line 193, in _sendCmd
HardwareError: Merlin-Orion axis 1 can't send command 'L1'
2009-10-26 19:07:21,507::Main::ERROR::Connection failed to start

2009-10-26 19:07:32,951::Main::DEBUG::MainController.__onActionHardwareConnectToggled(False)
2009-10-26 19:07:32,951::Main::DEBUG::PluginsConnector.start(): 'yawAxis' stop connection
2009-10-26 19:07:32,951::Main::DEBUG::PluginsConnector.start(): 'pitchAxis' stop connection
2009-10-26 19:07:32,953::Main::DEBUG::PluginsConnector.start(): 'shutter' stop connection
D800, D300, D80, Seitz Roundshot VR2, Nodal Ninja5 RD16, Nikkor 10,5, Nikkor 24-70, Nikkor 70-200, Sigma 150-500, Nikkor 105VR, ....

User avatar
FelixAutopano
Member
 
Topic author
Posts: 50
Likes: 0 post
Liked in: 0 post
Joined: Sat Sep 26, 2009 11:06 am
Location: Czech Republic
Info

by FelixAutopano » Mon Oct 26, 2009 7:47 pm

Other problem is that when I turn ON Merlin - the BT interface doesn't start. I must disconnect it and connect again. Then the LED on BT interface starts blinking. The connector sure isn't made for daily connecting and disconnecting.
I think I'm in sh.. with this ####. But why me? :mad:
The God is Out There

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Mon Oct 26, 2009 7:57 pm

So, this really seems to be a hardware issue. Try to contact Ursa Minor for a product replacement.
Frédéric

Next

Who is online

Users browsing this forum: No registered users and 1 guest