Wired connection to Merlin/Orion  

Everything you need to motorize your head
no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Sat Apr 25, 2009 2:35 pm

Hi Claude, the adapter i bought (twice now as i am dumb :-)) is not expensive and is nearly without soldering.
You have (if you want it that way) solder the 6 connection pins to be able to disconnect it from the cable - otherwise you could also just solder the necessary 3 connections directly on the board. (Ground and 2x 220 Ohm).
That´s all - if you know where to find the settings for the serial adapter of course! We know that now.

Peter
(Images later - if wanted?)
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Wed Apr 29, 2009 8:05 pm

Hi,
this does not really fit this thread - but maybe i will just continue here as the setup is the same as before...?
I am just trying to connect to the same head i sucessfully connected wired before but now via Bluetooth on Mac:

- did set up a new connection to a new Bluetooth adaptor on the Macbook.
- connected to this adapter (i can see him in the System Profiler and in the System Preferences/Bluetooth with Status "connected").
- did the same "ls /dev" as before with the wired connection and got the name of the adaptor as "/dev/tty.SerialAdaptor-DevB-1" and pasted that into the SERIAL connection in Papywizard.

When i try to "connect to hardware" in Papywizard the adaptor status changes from "unconnected" to "connected". But: Papywizard does not get the connection going and times out...

2009-04-29 20:54:40,008::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 20:54:40,009::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...


Any idea what to try next?

Cheers - Peter
Last edited by macbenutzer on Wed Apr 29, 2009 8:43 pm, edited 1 time in total.
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Wed Apr 29, 2009 10:03 pm

What Papywizard version are you using? 1.6.1? This is strange, as Papywizard got the first char of the Merlin answer, and failed for the end... Could you post the entire log, please?
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Wed Apr 29, 2009 10:11 pm

Hi Frederic, no it is Papywizard v2.0.0-1.

Here is the log:

2009-04-29 21:39:18,959::MainThread::INFO::Starting Papywizard...
2009-04-29 21:39:19,057::MainThread::INFO::Importing modules...
2009-04-29 21:39:19,317::MainThread::DEBUG::Shooting.start(): loading user external shooting scriptTraceback (most recent call last): File "papywizard/model/shooting.pyc", line 70, in <module>ImportError: No module named shoot
2009-04-29 21:39:19,317::MainThread::WARNING::No user external shooting script found
2009-04-29 21:39:19,426::MainThread::INFO::Loading i18n files...
2009-04-29 21:39:19,434::MainThread::DEBUG::Papywizard.i18n(): locale=de_DE
2009-04-29 21:39:19,435::MainThread::WARNING::Can't find qt translation file
2009-04-29 21:39:19,435::MainThread::INFO::Loading Style Sheets...
2009-04-29 21:39:19,452::MainThread::WARNING::No user Style Sheet found
2009-04-29 21:39:19,452::MainThread::INFO::Loading configuration...
2009-04-29 21:39:19,458::MainThread::DEBUG::ConfigManager.__init__(): versions: dist=['2', '0', '0'], user=[u'2', u'0', u'0']
2009-04-29 21:39:19,459::MainThread::DEBUG::ConfigManager.__init__(): user config. is up-to-date
2009-04-29 21:39:19,459::MainThread::INFO::Creating model...
2009-04-29 21:39:19,474::MainThread::INFO::Loading default presets
2009-04-29 21:39:19,490::MainThread::DEBUG::Preset.__init__(): loading name='4@0 + Z + N'
2009-04-29 21:39:19,491::MainThread::DEBUG::Preset.__init__(): loading name='4@-15 + Z'
2009-04-29 21:39:19,491::MainThread::DEBUG::Preset.__init__(): loading name='6@30 + 6@-15 + N'
2009-04-29 21:39:19,493::MainThread::DEBUG::Preset.__init__(): loading name='4@30 + 4@-30'
2009-04-29 21:39:19,493::MainThread::DEBUG::Preset.__init__(): loading name='3 + 6 + 12 + 6 + 3 (28mm)'
2009-04-29 21:39:19,495::MainThread::DEBUG::Preset.__init__(): loading name='4 + 12 + 12 + 12 + 8 (32mm)'
2009-04-29 21:39:19,496::MainThread::INFO::Loading user presets
2009-04-29 21:39:19,496::MainThread::WARNING::No user presets found
2009-04-29 21:39:19,497::MainThread::INFO::Starting Spy...
2009-04-29 21:39:19,497::MainThread::DEBUG::Spy.__init__(): yaw=0.0, pitch=0.0
2009-04-29 21:39:19,498::MainThread::INFO::Creating GUI...
2009-04-29 21:39:19,498::Spy::INFO::Starting Spy...


2009-04-29 21:39:35,530::MainThread::INFO::Connecting to real hardware...

2009-04-29 21:39:38,926::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:38,927::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:39,230::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:39,230::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:39,515::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:39,516::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:39,516::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 378, in switchToRealHardware File "papywizard/hardware/head.pyc", line 90, in init File "papywizard/hardware/axis.pyc", line 252, in init File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command
2009-04-29 21:39:39,613::MainThread::ERROR::Can't connect to hardwareAxis 1 can't send command
2009-04-29 21:39:41,403::MainThread::INFO::Go to simulation mode
2009-04-29 21:39:41,673::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:41,674::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:41,954::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:41,955::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:42,243::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:39:42,243::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:39:42,244::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 391, in switchToSimulatedHardware File "papywizard/hardware/head.pyc", line 106, in shutdown File "papywizard/hardware/axis.pyc", line 372, in stop File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command



2009-04-29 21:44:12,241::MainThread::INFO::Connecting to real hardware...
2009-04-29 21:44:12,601::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:12,602::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:12,882::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:12,883::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:13,146::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:13,147::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:13,147::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 378, in switchToRealHardware File "papywizard/hardware/head.pyc", line 90, in init File "papywizard/hardware/axis.pyc", line 252, in init File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command
2009-04-29 21:44:13,215::MainThread::ERROR::Can't connect to hardwareAxis 1 can't send command
2009-04-29 21:44:15,219::MainThread::INFO::Go to simulation mode
2009-04-29 21:44:15,505::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:15,506::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:15,780::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:15,781::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:16,058::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:44:16,059::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:44:16,060::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 391, in switchToSimulatedHardware File "papywizard/hardware/head.pyc", line 106, in shutdown File "papywizard/hardware/axis.pyc", line 372, in stop File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command


2009-04-29 21:44:20,549::MainThread::INFO::Set hardware reference


2009-04-29 21:45:39,123::MainThread::INFO::Connecting to real hardware...
2009-04-29 21:45:39,326::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:39,326::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:39,596::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:39,597::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:39,872::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:39,873::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:39,873::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 378, in switchToRealHardware File "papywizard/hardware/head.pyc", line 90, in init File "papywizard/hardware/axis.pyc", line 252, in init File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command
2009-04-29 21:45:39,945::MainThread::ERROR::Can't connect to hardwareAxis 1 can't send command
2009-04-29 21:45:41,635::MainThread::INFO::Go to simulation mode
2009-04-29 21:45:41,908::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:41,909::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:42,194::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:42,195::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:42,468::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-29 21:45:42,469::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-29 21:45:42,470::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 391, in switchToSimulatedHardware File "papywizard/hardware/head.pyc", line 106, in shutdown File "papywizard/hardware/axis.pyc", line 372, in stop File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command


Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Wed Apr 29, 2009 10:17 pm

Ok. So, Papywizard never received the answer from the Merlin. Could you try to use a terminal emulator, and connect to the serial port, after established the connection with the bluetooth device, and with the Merlin connected?

Then, you should see any char entered in the termnial echoed back, *even with the echo mode turned off*. And if the echo mode is turned on, you should see you chars twice...
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Wed Apr 29, 2009 10:30 pm

Hmmm??? too fast :-) for me.

Could you try to use a terminal emulator,

I have iTerm running logged in as user now.

and connect to the serial port,

How do i do that?

after established the connection with the bluetooth device, and with the Merlin connected?

If you mean the Merlin connected with the BT adaptor - it is, yes.
If you mean the connection between BT adaptor and the Mac - it is also connected, yes.

Peter

PS: another thing to add maybe: to establish a connection between the adaptor and the Mac i have to click "connect to hardware" in Papywizard which tells me after a short time that it could not connect to the hardware and goes into simulation mode. My Mac is nevertheless telling me that it is STILL connected to the BT adaptor (which also has the LED status "ON"). When i quit Papywizard the connection is dropped and the LED on the BT adaptor is blinking again.
Last edited by macbenutzer on Wed Apr 29, 2009 10:45 pm, edited 1 time in total.
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Thu Apr 30, 2009 6:58 am

You need a program like hyperterminal, (windows), or minicom (unix) to be able to connect to a serial port.

About the connection, Papywizard says that it is connected with the Merlin, once he can speak with it. But when you close it, it shuts down all open ports (serial port for it, which is in fact a bluetooth connection). I presume it is normal that the BT link is dropped...
Frédéric

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Thu Apr 30, 2009 9:49 am

Hi Peter,

Could-you explain shortly the connections from your Mac and the Merlin ?
Mac -> Bluetooth (internal or external, if external Model ?)-> Bluetooth (Model ?) -> Merlin ....

Those are important info's for helping you !

Thanks
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Thu Apr 30, 2009 10:03 am

Hi Claude,
i am at work right now so i can not try anything before tonight.

Setup:
1. Mac (MacPro or MacBook, both Intel 10.5.6), internal Bluetooth (as Serial Port / RS232)
2. Air :-)
3. External Bluetooth Module (http://tinyurl.com/ddp587) i have the technical data as PDF at home
4. RJ11 cable
5. Merlin

Hope that helps? Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Thu Apr 30, 2009 1:28 pm

Hi Peter, .... (Frederic and Andrew)

This will help of course !

This BT adaptor from Andreas Bà¶hme is excellent, I have one in test at this moment and , "big secret", it will probably become "the reference" for PapyMerlin in Europe after some modifications that Andreas and myself are discussing at this moment !

But, as such, without configuration, it could not work for Papywizard !!! :/ AND THIS IS PROBABLY THE REASON OF NOT WORKING ( to Frederic !)

Some of the reasons are:
- Baud rate at 19500, PapyMerlin need 9600 !
- Should be connected to a 5V power supply, and Papywizard deliver 12 Volts ... YOU COULD BURN THE MODULE IF CONNECTED DIRECTLY !!!

Other reasons exist but are not so important !

What I suggest to you, if you don't have yet done the configuration (or burned the module ! :lol:) , is to wait that I come with the results and recommandations of my study ... Next week ,this will be posted in the forum ! And in principle, without major issues, Andreas will produce a first serie of 10 "preserie" pieces strictly adapted to PapyMerlin... let us say that those modules will be availlable within approximatively 3 weeks, but I want send one "pre-serie" to Frederic and one to Andrew for "green light" !

:cool:
Last edited by claudevh on Thu Apr 30, 2009 4:30 pm, edited 1 time in total.
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Thu Apr 30, 2009 1:32 pm

That's good news! Excellent work, Claude (and Andreas).

BTW, the Merlin needs a 9600 baudrate, not 8500 ;)
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Thu Apr 30, 2009 1:43 pm

Don´t panic :-)

I ordered this little device for some extra Euros with the following modifications:

- set to slave
- set to 9600 Baud
- directly connectable to 12V

So - that should not be the problem.

Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Thu Apr 30, 2009 2:08 pm

That's fine Peter ...

I don't panic !

You have asked the "right" things ...

Yes Frederic, If have made a typing fault (8500 in place of 9600 !) Sorry !
(I will correct the post !)

:cool:
Last edited by claudevh on Thu Apr 30, 2009 4:29 pm, edited 1 time in total.
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Thu Apr 30, 2009 2:15 pm

No - i know i did not "panic" - just kidding...

Do you have any idea where to look why this is not working correctly?
I assume you are just busy with that - maybe i could help with a "Real world test" somehow?

Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri May 01, 2009 5:16 pm

claudevh wrote:Hi Peter, .... (Frederic and Andrew)

This will help of course !

This BT adaptor from Andreas Bà¶hme is excellent, I have one in test at this moment and , "big secret", it will probably become "the reference" for PapyMerlin in Europe after some modifications that Andreas and myself are discussing at this moment !

Claude,

Sounds good and the price seems to be attractive too.

I will be happy to give it a 'workout'.
Last edited by mediavets on Fri May 01, 2009 5:16 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
jriley
Member
 
Topic author
Posts: 147
Likes: 0 post
Liked in: 0 post
Joined: Tue Apr 08, 2008 2:51 pm
Location: Spartanburg, SC USA
Info

by jriley » Fri May 01, 2009 8:53 pm

claudevh wrote:This BT adaptor from Andreas Bà¶hme is excellent, I have one in test at this moment and , "big secret", it will probably become "the reference" for PapyMerlin in Europe after some modifications that Andreas and myself are discussing at this moment !

I can't seem to find any reference to this Bluetooth adapter. Is there any place to find out more about it?

John

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Fri May 01, 2009 11:18 pm

Hi John,

This is to early to communicate about this BT module, this has not been yet "fully" tested!
This module is based on the RAYSON BTM 222 (Class 1) ... the same that you find inside the Tronisoft BT module (BTL-478)
Technical datas are herafter:
http://www.rayson.com/product/wireless/BTM-22x.htm

:cool:
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

Previous

Who is online

Users browsing this forum: No registered users and 1 guest