Page 3 of 8

PostPosted: Wed Mar 04, 2009 7:11 pm
by bigwade
10.5.6 MacBook
Runs great ! and FAST !
This is FUN !

PostPosted: Wed Mar 04, 2009 7:31 pm
by jriley
klausesser wrote:
fma38 wrote:Good! Could someone running MacOS 10.4 can make a test, to see if it works?

Hi Frédéric!

At least on my system it doen´t run - 10.4 on a G5 DP. Says: fatal error.

best to you, Klaus

Same here on 10.4.11. How difficult would it be to build it so that it is compatible with 10.4? Do you have to use a machine with 10.4?

PostPosted: Wed Mar 04, 2009 9:16 pm
by fma38
Yes, compilation must be done on 10.4 to work on both systems. I have access to such machine, at work, but unfortunally, Qt/PyQt compilation fails, and I don't understand why. This machine might not be correctly installed, but as it is not mine, I can't do anything :(

Jeremy, who packaged Papywizard for MacOS, only has a 10.5 system...

PostPosted: Wed Mar 04, 2009 9:29 pm
by bigwade
Hi Frederic,
just playing with the Macversion.
When I enter a FoV 90/90 I get a start at -29,6/-22,5 and an end of 29,6/22,5
When I want to run a gigapan simulation this goes wrong because it starts left under (of course).
Why isn't start just at -29,6/22,5 ?
Is there a reason for it ?
When I define start and stop with the arrow keys there is no problem.
grtz
Frank

PostPosted: Wed Mar 04, 2009 11:04 pm
by jeremyp
Tim.Lewis wrote:(Needs an (pretty)application icon)

Sorry I forgot to add the icon, will add it for the next build.

PostPosted: Wed Mar 04, 2009 11:08 pm
by fma38
Jeremy, wait for the final 2.0.0, which should come soon...

Frank, this is an arbitrary choice. But I plan, in a future release, to allow the user choose the corner from where to start, whatever start/end values are...

PostPosted: Wed Mar 04, 2009 11:55 pm
by bigwade
fma38 wrote:Frank, this is an arbitrary choice. But I plan, in a future release, to allow the user choose the corner from where to start, whatever start/end values are...

Oké, fine to me but it was a question from a good friend of mine using the gigapanstitcher some times..

Is a BT connection Mac>>Merlin via PW confirmed allready ?

PostPosted: Thu Mar 05, 2009 12:08 am
by bigwade
jriley wrote:
klausesser wrote:
fma38 wrote:Good! Could someone running MacOS 10.4 can make a test, to see if it works?

Hi Frédéric!

At least on my system it doen´t run - 10.4 on a G5 DP. Says: fatal error.

best to you, Klaus

Same here on 10.4.11. How difficult would it be to build it so that it is compatible with 10.4? Do you have to use a machine with 10.4?

Same here on 10.4.11
console log:
"2009-03-05 00:05:00.482 Papywizard[405] A Python runtime could be located. You may need to install a framework build of Python, or edit the PyRuntimeLocations array in this application's Info.plist file."

No idea what it means.

PostPosted: Thu Mar 05, 2009 1:00 am
by numz
Hi !
a great news for mac user !
i'have try the papywizard.app on an imac 24'' with moa osx 10.5.6

but i can't choose a bluetooth peripheric in the config menu :

Impossible de scruter le bluetooth

and the traceback :
"Traceback (most recent call last):
File "papywizard/scripts/main.pyc", line 140, in main
IOError: [Errno 2] No such file or directory: '/Users/emury/.config/papywizard2/papywizard.css'"

and the bluetooth is activated :)

PostPosted: Thu Mar 05, 2009 7:38 am
by fma38
Strange error... Can you send the complete log?

About BT, It does not work as Jeremy didn't installed any python compatible bluetooth stack, as the usual one is not available on MacOS... We have to investigate.

PostPosted: Fri Mar 06, 2009 12:14 pm
by numz
Ok it's normal.

Here is the log :
Code: Select all
2009-03-06 12:12:07,099::MainThread::INFO::Starting Papywizard...
2009-03-06 12:12:07,414::MainThread::INFO::Importing modules...
2009-03-06 12:12:08,395::MainThread::INFO::Loading i18n files...
2009-03-06 12:12:08,413::MainThread::DEBUG::Papywizard.i18n(): locale=fr_FR
2009-03-06 12:12:08,417::MainThread::WARNING::Can't find qt translation file
2009-03-06 12:12:08,419::MainThread::INFO::Loading Style Sheets...
2009-03-06 12:12:08,427::MainThread::WARNING::No user Style Sheet found
2009-03-06 12:12:08,427::MainThread::INFO::Loading configuration...
2009-03-06 12:12:08,440::MainThread::DEBUG::ConfigManager.__init__(): versions: dist=['1', '9', '6'], user=['1', '9', '6']
2009-03-06 12:12:08,440::MainThread::DEBUG::ConfigManager.__init__(): user config. is up-to-date
2009-03-06 12:12:08,440::MainThread::INFO::Creating model...
2009-03-06 12:12:08,449::MainThread::INFO::Loading default presets
2009-03-06 12:12:08,480::MainThread::DEBUG::Preset.__init__(): loading name='4@0 + Z + N'
2009-03-06 12:12:08,481::MainThread::DEBUG::Preset.__init__(): loading name='3@-15 + Z'
2009-03-06 12:12:08,481::MainThread::DEBUG::Preset.__init__(): loading name='6@30 + 6@-15 + N'
2009-03-06 12:12:08,481::MainThread::DEBUG::Preset.__init__(): loading name='4@30 + 4@-30'
2009-03-06 12:12:08,481::MainThread::DEBUG::Preset.__init__(): loading name='3 + 6 + 12 + 6 + 3 (28mm)'
2009-03-06 12:12:08,482::MainThread::DEBUG::Preset.__init__(): loading name='4 + 12 + 12 + 12 + 8 (32mm)'
2009-03-06 12:12:08,482::MainThread::INFO::Loading user presets
2009-03-06 12:12:08,483::MainThread::WARNING::No user presets found
2009-03-06 12:12:08,483::MainThread::INFO::Starting Spy...
2009-03-06 12:12:08,483::MainThread::DEBUG::Spy.__init__(): yaw=0.0, pitch=0.0
2009-03-06 12:12:08,483::MainThread::INFO::Creating GUI...
2009-03-06 12:12:08,483::Spy::INFO::Starting Spy...
2009-03-06 12:12:23,349::MainThread::INFO::Scanning available bluetooth devices...
2009-03-06 12:12:23,368::Dummy-4::EXCEPTION::refreshBluetoothList() Traceback (most recent call last): File "papywizard/controller/bluetoothChooserController.pyc", line 109, in refreshBluetoothList File "bluetooth/__init__.pyc", line 36, in <module> File "bluetooth/osx.pyc", line 3, in <module> NotImplementedError
2009-03-06 12:12:23,416::MainThread::ERROR::Can't scan bluetooth
2009-03-06 12:12:29,857::MainThread::INFO::Configuration saved
2009-03-06 12:12:47,552::MainThread::INFO::Scanning available bluetooth devices...
2009-03-06 12:12:47,553::Dummy-4::EXCEPTION::refreshBluetoothList() Traceback (most recent call last): File "papywizard/controller/bluetoothChooserController.pyc", line 109, in refreshBluetoothList File "bluetooth/__init__.pyc", line 36, in <module> File "bluetooth/osx.pyc", line 3, in <module> NotImplementedError
2009-03-06 12:12:47,620::MainThread::ERROR::Can't scan bluetooth
2009-03-06 12:13:06,753::MainThread::INFO::Configuration saved

PostPosted: Thu Mar 12, 2009 3:08 am
by loddie
So several users have reported the software running under OS 10.5. However, has anyone been able to communicate with the hardware via the tethered connection? If so, what were you're "Hardware" settings in the "Configuration" window?

PostPosted: Thu Mar 12, 2009 3:41 am
by jeremyp
loddie wrote:So several users have reported the software running under OS 10.5. However, has anyone been able to communicate with the hardware via the tethered connection? If so, what were you're "Hardware" settings in the "Configuration" window?

Yes I set to "serial" and point to the installed device (FTDI TTL 232),

/dev/tty.usbserial-FTE0WXEI

it may be different on your machine have a look in /dev

PostPosted: Thu Mar 12, 2009 8:59 pm
by bigwade
Now I am confused...
How do you connect the Mac to the Merlin , tethered ?
Cable/drivers/set-up/screenshots ?

PostPosted: Thu Mar 12, 2009 9:15 pm
by fma38
I think Jeremy uses a USB-TTL cable, through the Papywizard serial driver... The BT does not work (yet) on MacOS, but it is always possible to create a pseudo-serial driver to connect to the BT device, and use teh serial driver in Papywizard.

PostPosted: Thu Mar 12, 2009 10:09 pm
by loddie
bigwade wrote:Now I am confused...
How do you connect the Mac to the Merlin , tethered ?
Cable/drivers/set-up/screenshots ?

Wade, that is what I am trying to figure out. I am not sure if I have a driver issue, a Papywizard configuration issue, of if I simply did not solder the connections correctly.

BTW, how does one post a picture? Does it have to be hosted on a website? I selected "img" but when I preview the post, it simply shows the location on my hard drive, not the image itself.

PostPosted: Thu Mar 12, 2009 10:16 pm
by bigwade
loddie wrote:BTW, how does one post a picture? Does it have to be hosted on a website? I selected "img" but when I preview the post, it simply shows the location on my hard drive, not the image itself.

Use post reply

PostPosted: Thu Mar 12, 2009 10:21 pm
by GURL
To use IMG the image must be on a web site and refered to using "http://etc" but if you don't use the Quick Post button but instead Post Reply or Quote then an Image Upload option is displayed and you can upload one ore more images from you hard disk...

PostPosted: Thu Mar 12, 2009 11:35 pm
by jeremyp
bigwade wrote:Now I am confused...
How do you connect the Mac to the Merlin , tethered ?
Cable/drivers/set-up/screenshots ?

I use tethered setup USB->TTL cable as described earlier. You need to install a driver just like on windoze. The only difference is the device is a /dev like Linux. Once I installed the driver I took a look in /dev and saw /dev/tty.usbserial-FTE0WXEI. I entered this in the serial port field (just like Linux).

If you are using the FTDI type converter the virtual comm port drivers can be found here,
http://www.ftdichip.com/Drivers/VCP.htm

PostPosted: Thu Mar 12, 2009 11:42 pm
by bigwade
Can you make a step by step tutorial for dummies ?
and please with (Mac) screenshots.....

Can't find the cable in this thread

PostPosted: Fri Mar 13, 2009 9:54 am
by 120to120
Guten Tag, bin NEU hier.
Ihr Forum finde ich sehr interessant.

suche Pin-Belegung von USB-Kabel/Canon S5is zu Merlin-Orion

Danke für die Hilfe!

PostPosted: Fri Mar 13, 2009 12:15 pm
by 120to120
Merlin/Orion,Papywizard an Mac 10.3.9 mà¶glich??????

Welche SW-Version von PW 1.6 _____ PW 2.0???

PostPosted: Fri Mar 13, 2009 12:17 pm
by fma38
Do you speak english? I would like to help you, but I don't understand your questions...

PostPosted: Fri Mar 13, 2009 12:25 pm
by SpeedyPan
He likes to know if Papywizard would run on a Mac with OSX 10.3.9.

And he is asking for an cable to connect a Canon S5is to the Merlin.

PostPosted: Fri Mar 13, 2009 12:54 pm
by 120to120
Good day!
Is there Papywizard for Mac 10.3.9?
What version number. will be needed?
Is there a link, where step to step?

Gordon used to S5is Canon Merlin / Head, which cable has he?
Thanks for your help.