N800 users wanted for testing Papywizard 1.5.6-1.  

Everything you need to motorize your head
no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 7:38 pm

Just for 'fun' I went back to 1.4.0-1 on the N800.

Everything seems to work EXCEPT the Licence and Credits buttons don't work merely closing the pop-up when selected.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 8:02 pm

My fault; I forgot the xml file in the package... Could you download it again (same name)?
Frédéric

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 8:05 pm

mediavets wrote:Just for 'fun' I went back to 1.4.0-1 on the N800.

Everything seems to work EXCEPT the Licence and Credits buttons don't work merely closing the pop-up when selected.

I hate that! Did you make an updated recently? After you started to use 1.5.x branch?
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:12 pm

fma38 wrote:My fault; I forgot the xml file in the package... Could you download it again (same name)?

1.5.6d-1 on N800.

Everything works fine except the Credits and Licence buttons (as before).
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:17 pm

fma38 wrote:
mediavets wrote:Just for 'fun' I went back to 1.4.0-1 on the N800.

Everything seems to work EXCEPT the Licence and Credits buttons don't work merely closing the pop-up when selected.

I hate that! Did you make an updated recently? After you started to use 1.5.x branch?

Yes, I went back to 1.4.0-1 on the N800 - just to see whether it still worked - after having installed and uninstalled many versions of 1.5.x.

I always uninstall before installing a different version.

Would it make any difference if I was to reboot after unistalling and before installing a different version - I can't see why it should, but ...
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 8:17 pm

Ok, so this is definitly a problem with libglade :( So there is a solution for OS2008, but I don't know how to solve that in OS2007. Previously, saving again the glade file fixed it; but here, I re-generated 4 times without success. And as I can't test it myself, this is not very easy...

And I don't understand why the Credits and License buttons don't work anymore... Do you see something in the logs (in trace mode), when clicking on that buttons?
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:28 pm

fma38 wrote:Ok, so this is definitely a problem with libglade :( So there is a solution for OS2008, but I don't know how to solve that in OS2007. Previously, saving again the glade file fixed it; but here, I re-generated 4 times without success. And as I can't test it myself, this is not very easy...

Hmmm.......we didn't need a solution for OS2008 - Menu/File worked anyway on that OS.

Perhaps now is the time to accept that 770 with OS2007HE just isn't quite 'robust enough' a platform for later versions of Papywizard, and that these later versions will not be avilable for the 770, before we get any more 770 users. Current 770 users can continue to use versions that run OK on their systems, or choose to upgrade to the N800 and run later versions.

How many 770 users are there now?

fma38 wrote:And I don't understand why the Credits and License buttons don't work anymore... Do you see something in the logs (in trace mode), when clicking on that buttons?

I'll check.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 8:34 pm

mediavets wrote:Hmmm.......we didn't need a solution for OS2008 - Menu/File worked anyway on that OS.

I thought it was crashing on all OS...

Perhaps now is the time to accept that 770 with OS2007HE just isn't quite 'robust enough' a platform for later versions of Papywizard, and that these later versions will not be avilable for the 770, before we get any more 770 users. Current 770 users can continue to use versions that run OK on their systems, or choose to upgrade to the N800 and run later versions.

How many 770 users are there now?

Well, I don't like that. Some guys just bought a 770 a few days/weeks ago, so telling them that Papywizard won't work on it anymore is not very nice...
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:35 pm

fma38 wrote:And I don't understand why the Credits and License buttons don't work anymore... Do you see something in the logs (in trace mode), when clicking on that buttons?

Yes, there's something in the logs - here's the x-term log using 1.5.6d-1 on n800:

Code: Select all
~ $ papywizard.sh
2009-01-09 19:28:30,433::MainThread::DEBUG::Papywizard.l10n(): default locale=en_GB
2009-01-09 19:28:30,504::MainThread::DEBUG::Papywizard.l10n(): LANGUAGE=None
2009-01-09 19:28:30,512::MainThread::DEBUG::Papywizard.l10n(): langs=['en_GB', 'en_US', 'fr_FR', 'pl_PL', 'de_DE', 'es_ES', 'nl_NL', 'it_IT']
2009-01-09 19:28:30,615::MainThread::DEBUG::Papywizard.l10n(): localeDir=/usr/share/locale/en/LC_MESSAGES/../..
2009-01-09 19:28:31,014::MainThread::INFO::Starting Papywizard...
2009-01-09 19:28:31,098::MainThread::INFO::Loading default presets
2009-01-09 19:28:31,465::MainThread::DEBUG::Preset.__init__(): loading name='4@0 + Z + N'
2009-01-09 19:28:31,535::MainThread::DEBUG::Preset.__init__(): loading name='3@-15 + Z'
2009-01-09 19:28:31,549::MainThread::DEBUG::Preset.__init__(): loading name='6@30 + 6@-15 + N'
2009-01-09 19:28:31,672::MainThread::DEBUG::Preset.__init__(): loading name='4@30 + 4@-30'
2009-01-09 19:28:31,688::MainThread::DEBUG::Preset.__init__(): loading name='3 + 6 + 12 + 6 + 3 (28mm)'
2009-01-09 19:28:31,821::MainThread::DEBUG::Preset.__init__(): loading name='4 + 12 + 12 + 12 + 8 (32mm)'
2009-01-09 19:28:31,914::MainThread::INFO::Loading user presets
2009-01-09 19:28:31,924::MainThread::WARNING::No user presets found
2009-01-09 19:28:31,983::MainThread::DEBUG::Spy.__init__(): yaw=0.0, pitch=0.0
2009-01-09 19:28:34,902::MainThread::DEBUG::ConfigManager.__init__(): versions: dist=['1', '5', '6d'], user=['1', '5', '6d']
2009-01-09 19:28:34,910::MainThread::DEBUG::ConfigManager.__init__(): user config. is up-to-date
2009-01-09 19:28:35,147::Publisher::INFO::Starting Publisher...
2009-01-09 19:28:35,157::Spy::INFO::Starting Spy...
2009-01-09 19:28:38,789::MainThread::TRACE::MainController.__onFileMenuitemActivate()
2009-01-09 19:28:43,289::MainThread::TRACE::MainController.__onHelpAboutMenuitemActivate()
python[1469]: GLIB WARNING ** libglade - unknown property `program_name' for class `GtkAboutDialog'
python[1469]: GLIB WARNING ** libglade - could not convert string to type `GStrv' for property `authors'
python[1469]: GLIB WARNING ** libglade - could not convert string to type `GStrv' for property `artists'
2009-01-09 19:28:48,398::MainThread::TRACE::MainController.__onFileMenuitemActivate()
2009-01-09 19:28:50,645::MainThread::TRACE::MainController.__onHelpAboutMenuitemActivate()
python[1469]: GLIB WARNING ** libglade - unknown property `program_name' for class `GtkAboutDialog'
python[1469]: GLIB WARNING ** libglade - could not convert string to type `GStrv' for property `authors'
python[1469]: GLIB WARNING ** libglade - could not convert string to type `GStrv' for property `artists'
Last edited by mediavets on Fri Jan 09, 2009 8:37 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:41 pm

fma38 wrote:
mediavets wrote:Hmmm.......we didn't need a solution for OS2008 - Menu/File worked anyway on that OS.

I thought it was crashing on all OS...

No, here's some of my earlier posts on differences between 1.5.6x-1 on 770 and N800 - which reported that Menu/File was OK on N800.
http://www.autopano.net/forum/p36283-2009-01-07-20-02-46#p36283
http://www.autopano.net/forum/p36414-yesterday-23-32-11#p36414
http://www.autopano.net/forum/p36449-today-10-09-17#p36449
Last edited by mediavets on Fri Jan 09, 2009 8:46 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 8:42 pm

Can you try the 1.5.6e version? I switched all dialogs to GtkBuilder...
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 8:49 pm

fma38 wrote:Can you try the 1.5.6e version? I switched all dialogs to GtkBuilder...

Where is this version - it doesn't appear to be linked from the Wiki? I can only find 1.5.6d-1 there.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 9:29 pm

I changed the link...
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 9:30 pm

OK, found 1.5.6e-1.

Running on N800.

Observations:

1. Licence and Credits buttons now work.

2. Problems in Configure tabbed dialogue.
- attempting to enable a checkbox in any tab causes Configure dialogue to close.
- selecting Choose in Configure/Hardware causes Configure dialogue to close - so unable to test with BT connection.

3. Drop down on Preset tab doesn't work/is empty.

4. Preset mode shoot dilaogue doesn't open - system stuck with 'Opening shoot dialogue. Please wait..' displayed.

5. Mosiac mode shoot dilaogue doesn't open - system stuck with 'Opening shoot dialogue. Please wait..' displayed.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Fri Jan 09, 2009 9:35 pm

Ok, enough for today ;) I have to rethink all this...

Thank's for your patience, Andrew!
Frédéric

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 9:39 pm

fma38 wrote:Ok, enough for today ;) I have to rethink all this...

Thank's for your patience, Andrew!

That's OK. Good night.
Last edited by mediavets on Fri Jan 09, 2009 9:40 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Fri Jan 09, 2009 10:58 pm

N770 1.5.6e log:

Code: Select all
~ $ papywizard.sh
2009-01-09 22:52:39,625::MainThread::DEBUG::Papywizard.l10n(): default locale=de_DE
2009-01-09 22:52:39,655::MainThread::DEBUG::Papywizard.l10n(): LANGUAGE=None
2009-01-09 22:52:39,684::MainThread::DEBUG::Papywizard.l10n(): langs=['de_DE', 'en_US', 'fr_FR', 'pl_PL', 'es_ES', 'nl_NL', 'it_IT']
2009-01-09 22:52:39,851::MainThread::DEBUG::Papywizard.l10n(): localeDir=/usr/share/locale/de/LC_MESSAGES/../..
2009-01-09 22:52:40,479::MainThread::INFO::Starting Papywizard...
2009-01-09 22:52:40,608::MainThread::INFO::Loading default presets
2009-01-09 22:52:41,091::MainThread::DEBUG::Preset.__init__(): loading name='4@0 + Z + N'
2009-01-09 22:52:41,201::MainThread::DEBUG::Preset.__init__(): loading name='3@-15 + Z'
2009-01-09 22:52:41,308::MainThread::DEBUG::Preset.__init__(): loading name='6@30 + 6@-15 + N'
2009-01-09 22:52:41,436::MainThread::DEBUG::Preset.__init__(): loading name='4@30 + 4@-30'
2009-01-09 22:52:41,549::MainThread::DEBUG::Preset.__init__(): loading name='3 + 6 + 12 + 6 + 3 (28mm)'
2009-01-09 22:52:41,688::MainThread::DEBUG::Preset.__init__(): loading name='4 + 12 + 12 + 12 + 8 (32mm)'
2009-01-09 22:52:41,848::MainThread::INFO::Loading user presets
2009-01-09 22:52:41,860::MainThread::WARNING::No user presets found
2009-01-09 22:52:42,059::MainThread::DEBUG::Spy.__init__(): yaw=0.0, pitch=0.0
2009-01-09 22:52:42,259::MainThread::EXCEPTION::main()
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/papywizard/scripts/main.py", line 250, in main
    app.init()
  File "/usr/lib/python2.5/site-packages/papywizard/scripts/main.py", line 129, in init
    controller = MainController(self.__model, self.__serializer, self.gtkLogStream)
  File "/usr/lib/python2.5/site-packages/papywizard/controller/mainController.py", line 91, in __init__
    super(MainController, self).__init__(None, model, serializer)
  File "/usr/lib/python2.5/site-packages/papywizard/controller/abstractController.py", line 198, in __init__
    self.builder = gtk.Builder()
  File "debian/python2.5-gtk2/usr/lib/python2.5/site-packages/gtk-2.0/gtk/_lazyutils.py", line 68, in __getattribute__
AttributeError: Builder
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/papywizard/scripts/main.py", line 260, in main
    controller = LoggerController(None, None, None)
  File "/usr/lib/python2.5/site-packages/papywizard/controller/abstractController.py", line 198, in __init__
    self.builder = gtk.Builder()
  File "debian/python2.5-gtk2/usr/lib/python2.5/site-packages/gtk-2.0/gtk/_lazyutils.py", line 68, in __getattribute__
AttributeError: Builder
Exception in thread Axis #1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
Exception in thread Axis #2 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
  File "/usr/lib/python2.5/site-packages/papywizard/hardware/axis.py", line 486, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sleep'
  File "/usr/lib/python2.5/site-packages/papywizard/hardware/axis.py", line 486, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'sleep'
~ $
Paul

close, but no cigar ... ... ...

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 11:42 pm

Paul wrote:N770 1.5.6e log:

Paul,

1.5.6c-1 is the most recent dev. version that will run on the 770.

Frederic is experimenting with some code in dev. versions 1.5.6d and 1.5.6e that will not run on the 770, but only on the N800.

We would be interested to know if you too have the File menu crash with 1.5.6c on the 770 as this is the only real issue now with the 1.5.x dev. branch, and it is only a problem on the 770, not on the N800.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Fri Jan 09, 2009 11:53 pm

mediavets wrote:Perhaps now is the time to accept that 770 with OS2007HE just isn't quite 'robust enough' a platform for later versions of Papywizard, and that these later versions will not be avilable for the 770, before we get any more 770 users. Current 770 users can continue to use versions that run OK on their systems, or choose to upgrade to the N800 and run later versions.

How many 770 users are there now?

fma38 wrote:Well, I don't like that. Some guys just bought a 770 a few days/weeks ago, so telling them that Papywizard won't work on it anymore is not very nice...

I don't like it either. But we would not be saying that Papywizard doesn't work on 770 anymore - we would be saying that beyond version 1.x.x you will need to have an N800/N810.

This is often the case with software developments - newer versions of software often demand more hardware capability - for example the realtime editor feature of APPV2/APG requires a particular spec. of graphics card.

But maybe you will be able to find a way to resolve the File menu crash with the 1.5.x branch on the 770.
Last edited by mediavets on Sat Jan 10, 2009 5:26 am, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Jan 10, 2009 12:20 am

mediavets wrote:I don't like it either. But we would not be saying that Papywizard doesn't work on 770 anymore - we would be saying that beyond version 1.x.x you will need to have an N800.

This is often the case with software developments - newer versions of software often demand more hardware capability - for example the realtime editor feature of APPV2/APG requires a particular spec. of graphics card.

Yes, that's true, and a 770 can be resell on ebay.

But maybe you will be able to find a way to resolve the File menu crash with the 1.5.x branch on the 770.

I will try to, as the 1.6 was planned to be the latest stable release of the 1.x branch, and I would like to have it running on the 770. If we drop 770 support, let's do it for the v2, using Qt ;)
Frédéric

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sat Jan 10, 2009 1:05 am

Hi Frederic and Andrew ....

The actual problems with versions 1.5... is very disappointing for the owners of N770 ! :(

At the end, what is the last version who run on N770 without any problems ?

Is that the "papywizard_1.4.0-1_all.deb" ? :/

Is that your intention to produce a stable version 1.5... for N770 before the 1.6... for N800-810 ?


Frederic, I thing that you should be more explicit in your information about the differents versions availlable

- Version XYZ run on Nokia XYZ etc ...

Thanks

:|
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
bigwade
Member
 
Posts: 282
Likes: 0 post
Liked in: 0 post
Joined: Tue Nov 18, 2008 12:34 am
Location: NL
Info

by bigwade » Sat Jan 10, 2009 1:08 am

If a newer Nokia is needed for better performance, I don't think that's a problem.
But a final/stable PPW version working on such device is the target I guess.
I have no problems to put my "new" and hacked N770 on eBay (again) and get a N800 instead.

no avatar
bigwade
Member
 
Posts: 282
Likes: 0 post
Liked in: 0 post
Joined: Tue Nov 18, 2008 12:34 am
Location: NL
Info

by bigwade » Sat Jan 10, 2009 1:20 am

Another option.
Let's stick the N770 users to 1.4, it works, no problems at all.
and the newer versions to N800/N810
BTW i would like to see what inprovements the >>1.4/1.5/2.0 versions can do in screenshots.
Andrew, you are master in making screenhots from the Nokia, Share it... :-)

no avatar
mediavets
Moderator
 
Topic author
Posts: 16413
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Sat Jan 10, 2009 5:24 am

Having been quite involved in testing recent development versions, this is the situation as I understand it.

The current stable release is 1.4.0-1.

Versions 1.5.x are all development versions working towards the next stable release, to be named 1.6.0-1.

Frederic's goal has always been to have 1.6.0-1 as the last stable release before a radically redeveloped V2.x which would use different internal 'stuff'. And his goal has always been to have that stable 1.6.0-1 release run on all current platforms - Nokia 770 and N800/N810, Linux and Windows 2000/XP/Vista.

The 1.5.x branch has one significant problem - on the 770 only - which remains to be fixed before a stable version 1.6.0-1 can be released for all currently supported platforms.

On the 770 (only) 1.5.x development versions appear to crash when the File menu is selected. This has been an intermittent problem with earlier versions too. Some people reported it on the 770 but others appear not to have had the problem with the same version on their 770s. The cause of the problem has been elusive but Frederic has previously managed to resolve the problem, however it is proving to be resistant to the same 'empirical fix' in the 1.5.x branch of development.

The File menu allows the temporary/session-based loading of custom Preset files (for Preset Mode shooting) and Gtkrc files (these allow customisation of the UI); and also offers a program Quit function.

After a lot of testing, and comparing of trace logs from the 700 and N800, Frederic now believes he understands in what part of the code the problem lies. It is not in his code but in part of the third-party graphics toolkit ('middleware') that his code uses. This toolkit has been ported to OS2007HE (for the 770) and to OS2008 (for N800 and N810). The two ports are different and there appears to be a bug in the version for OS2007HE and that's what he believes is causing the problem on the 770.

Frederic hopes to find a workaround for this problem so that a final stable version 1.6.0-1 will work on all current platforms.
Last edited by mediavets on Sat Jan 10, 2009 9:42 am, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Jan 10, 2009 10:01 am

Andrew, you made a very good summary of the current situation.

There is something strange, however. The 1.4.0 stable release worked fine for you on both 770 and N800. But now, it seems not to work anymore on your 770 (File crash menu). Do you remember if you made some upgrade or so? I will regenerate a version working on the 770, to see if other users have the same problem as you have...
Frédéric

PreviousNext

Who is online

Users browsing this forum: No registered users and 4 guests