Image-stitching and virtual tour solutions My account Updates
It is currently Tue Jul 29, 2014 7:52 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed May 09, 2012 6:15 pm 
Offline
New member

Joined: Tue May 08, 2012 4:51 am
Posts: 4
Hi guys!
What a great forum you have here! Sorry for my first post starting with question, but I know no one who can help except you.
So, I have a merlin head with simple hand control. Image
And also PL-2303 TTL controller, which is good, as I used it for other applications before. It's set to 5V.
I assembled the cable as stated here : http://www.kolor.com/forum/p57035-2010-01-07-12-19-19?pid=57035#p57035

The problem is the head is not responding, when I try to connect. No program works. No test programs, no terminal. No firmware updater. Of course I try to connect with 9600N81.
Led blinks on PL-2303. Hand controller works.

Any ideas what can be wrong?
I ordered FTDI Basic FT232RL FT232R Arduino (http://item.taobao.com/item.htm?id=13745087406), that's the closes one I can find here. But while waiting it would be nice to fix my current setup.
Thank you!!!

_________________
ILya Terentyev
iStophoto portfolio
Getty portfolio


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 09, 2012 6:37 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13604
Location: Isleham, Cambridgeshire, UK.
A suggestion.

Make sure you don't connect the hand controller and your cable at the same time.

Use papywizard. Set the COM port bearing in mind that Papywizard enumerates serial ports from zero, so you can enter '0' or 'COM1', '1' or 'COM2' etc.

Attempt to connect and post the log file here.
...........

A second suggestion.

Buy the Deltawave Papymerlin Bluetooth adapter and use a Bluetooth connection rather than a wired connection.

http://www.papymerlin.com/interface-%C3%A9lectronique/

http://www.kolor.com/buy/photo-hardware/accessories/recepteur-bluetooth.html

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 09, 2012 6:50 pm 
Offline
New member

Joined: Tue May 08, 2012 4:51 am
Posts: 4
Yes, only wired interface in HC port.
Com3=Serial2 in Papywizard (Led blinks on PL2303)
I will buy the BT connection, but will take time to get here and I want to use head NOW :D And anyway I need a notebook to drive my camera with GBTimelapse....

Log:

2012-05-10 01:42:29,650::MainThread::DEBUG::Papywizard.l10n(): default locale=en_US
2012-05-10 01:42:29,650::MainThread::DEBUG::Papywizard.l10n(): LANGUAGE=None
2012-05-10 01:42:29,650::MainThread::DEBUG::Papywizard.l10n(): langs=['en_US', 'fr_FR', 'pl_PL', 'de_DE', 'es_ES', 'it_IT']
2012-05-10 01:42:29,650::MainThread::DEBUG::Papywizard.l10n(): localeDir=C:\Program Files\Papywizard\share\locale
2012-05-10 01:42:29,727::MainThread::INFO::Starting Papywizard...
2012-05-10 01:42:29,743::MainThread::INFO::Loading default presets
2012-05-10 01:42:29,789::MainThread::DEBUG::Preset.__init__(): loading name='4@0 + Z + N'
2012-05-10 01:42:29,789::MainThread::DEBUG::Preset.__init__(): loading name='3@-15 + Z'
2012-05-10 01:42:29,789::MainThread::DEBUG::Preset.__init__(): loading name='6@30 + 6@-15 + N'
2012-05-10 01:42:29,805::MainThread::DEBUG::Preset.__init__(): loading name='4@30 + 4@-30'
2012-05-10 01:42:29,805::MainThread::DEBUG::Preset.__init__(): loading name='3 + 6 + 12 + 6 + 3 (28mm)'
2012-05-10 01:42:29,805::MainThread::DEBUG::Preset.__init__(): loading name='4 + 12 + 12 + 12 + 8 (32mm)'
2012-05-10 01:42:29,805::MainThread::INFO::Loading user presets
2012-05-10 01:42:29,805::MainThread::WARNING::No user presets found
2012-05-10 01:42:29,805::MainThread::DEBUG::Spy.__init__(): yaw=0.0, pitch=0.0
2012-05-10 01:42:30,444::MainThread::DEBUG::ConfigManager.__init__(): versions: dist=['1', '6', '1'], user=['1', '6', '1']
2012-05-10 01:42:30,444::MainThread::DEBUG::ConfigManager.__init__(): user config. is up-to-date
2012-05-10 01:42:30,444::MainThread::TRACE::MainController.__onNoteBookSwitchPage()
2012-05-10 01:42:30,444::MainThread::DEBUG::MainController.__onNoteBookSwitchPage(): shooting mode set to 'preset'
2012-05-10 01:42:30,523::Publisher::INFO::Starting Publisher...
2012-05-10 01:42:30,539::Spy::INFO::Starting Spy...
2012-05-10 01:43:02,924::MainThread::INFO::Configuration saved
2012-05-10 01:43:09,023::MainThread::INFO::Connecting to real hardware...
2012-05-10 01:43:09,756::Dummy-5::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:09,756::Dummy-5::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:09,960::Dummy-5::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:09,960::Dummy-5::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:10,163::Dummy-5::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:10,163::Dummy-5::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:10,163::Dummy-5::EXCEPTION::Shooting.switchToRealHardware()
Traceback (most recent call last):
File "papywizard\model\shooting.pyo", line 284, in switchToRealHardware
File "papywizard\hardware\head.pyo", line 93, in init
File "papywizard\hardware\axis.pyo", line 251, in init
File "papywizard\hardware\axis.pyo", line 242, in _sendCmd
HardwareError: Axis 1 can't send command
2012-05-10 01:43:10,224::MainThread::ERROR::Can't connect to hardware
Axis 1 can't send command
2012-05-10 01:43:11,957::MainThread::INFO::Go to simulation mode
2012-05-10 01:43:12,174::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:12,174::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:12,378::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:12,378::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:12,581::MainThread::EXCEPTION::Axis._sendCmd
Traceback (most recent call last):
File "papywizard\hardware\axis.pyo", line 235, in _sendCmd
File "papywizard\hardware\serialDriver.pyo", line 111, in sendCmd
IOError: Timeout while reading on serial bus
2012-05-10 01:43:12,581::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2012-05-10 01:43:12,581::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()
Traceback (most recent call last):
File "papywizard\model\shooting.pyo", line 297, in switchToSimulatedHardware
File "papywizard\hardware\head.pyo", line 109, in shutdown
File "papywizard\hardware\axis.pyo", line 371, in stop
File "papywizard\hardware\axis.pyo", line 242, in _sendCmd
HardwareError: Axis 1 can't send command

_________________
ILya Terentyev
iStophoto portfolio
Getty portfolio


Last edited by itsskin on Wed May 09, 2012 6:59 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Sun May 13, 2012 5:13 pm 
Offline
New member

Joined: Tue May 08, 2012 4:51 am
Posts: 4
Okay! Problem solved with new interface posted above. Thx for help!

Another question. I checked Controller firmware and got 02.0A.84
Didn't find anything about it here. Is it more recent then 020681? Can I dump it to share?

_________________
ILya Terentyev
iStophoto portfolio
Getty portfolio


Top
 Profile  
 
 Post subject:
PostPosted: Sun May 13, 2012 5:31 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13604
Location: Isleham, Cambridgeshire, UK.
itsskin wrote:
Okay! Problem solved with new interface posted above. Thx for help!?

So what was the problem?

How have you solved it?

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Sun May 13, 2012 5:34 pm 
Offline
New member

Joined: Tue May 08, 2012 4:51 am
Posts: 4
Connected with new chip. FTDI Basic 232R. PL-2303 didn't work.

_________________
ILya Terentyev
iStophoto portfolio
Getty portfolio


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group