Page 1 of 1

Papywizard does not start on N800

PostPosted: Mon Jul 25, 2011 5:34 pm
by ludek
I have just installed Papywizard on a N800 according to the instructions on this forum The install seems to have gone OK and there is a Papywizard icon in Extras, but when I click it nothing at all happens.
To summarize, I updated to OS2008 V:5.2008.43-7 from the Nokia Europe web site. I then added the maemo extras and maemo extras dev catalogues. Next I installed rootsh and maemo-python-device-env and went through the x-terminal commands which seemed to complete correctly. I finally connected to the Papywizard.org site and selected the Development Version papywizard_2.1.21-2-all-deb -- Maemo package. When requested I chose open and it seemed to download and install. A Papywizard icon exists in Extras, but clicking it does nothing at all. Please advise where I probably went wrong. Thanks in advance.

PostPosted: Mon Jul 25, 2011 5:47 pm
by mediavets
It sounds as if you have done everything correctly.

On my N800 it takes about 15-20 seconds from clicking the Papywizard icon in Extras before the Papywizard initial 'splash' screen is displayed.

PostPosted: Mon Jul 25, 2011 6:39 pm
by ludek
Waiting even a minute has no result. I've just reinstalled everything from the beginning, ie OS2008 all the way to Papywizard and unfortunately clicking on the icon in Extras shows nothing. I definitely need some help as I don't even know where to start. The N800 seems to work OK, browses the net etc.

PostPosted: Mon Jul 25, 2011 6:54 pm
by fma38
Try to start Papywizard from a shell (x-terminal):

$ papywizard.sh

and post the errors...

PostPosted: Mon Jul 25, 2011 7:03 pm
by ludek
Output as follows:
Traceback (most recent call last) ;
File "<string>", line 1, in <module>
File "/usr/lib/python2.5/site-packages/papywizard/scripts/main.py", line 53, in <module>
from PyQt4 import QtCore, QtGui
RuntimeError: the sip module implements API v8.0 but the PyQt4.QtCore module requires API v7.0

PostPosted: Mon Jul 25, 2011 11:23 pm
by mediavets
ludek wrote:I have just installed Papywizard on a N800 according to the instructions on this forum The install seems to have gone OK and there is a Papywizard icon in Extras, but when I click it nothing at all happens.
To summarize, I updated to OS2008 V:5.2008.43-7 from the Nokia Europe web site. I then added the maemo extras and maemo extras dev catalogues. Next I installed rootsh and maemo-python-device-env and went through the x-terminal commands which seemed to complete correctly. I finally connected to the Papywizard.org site and selected the Development Version papywizard_2.1.21-2-all-deb -- Maemo package. When requested I chose open and it seemed to download and install. A Papywizard icon exists in Extras, but clicking it does nothing at all. Please advise where I probably went wrong. Thanks in advance.

I've just done an install myself to check that the install instructions are still correct and it worked just fine.

You must have not followed the instructions properly.

I note you say you added the mameo-extras-dev catalogue.

Nowhere in the instructions does it tell you to do this:
http://www.autopano.net/wiki-en/action/view/Install_Papywizard_v2_on_Nokia_N8x0

Also make sure you select the correct version of Papywizard for the N800 - that is the Maemo version

I know it's probably a pain but I suggest you start over, re-flashing the OS, and have another go at installing.

PostPosted: Tue Jul 26, 2011 1:09 am
by ludek
Thanks. It works now. I must have had finger trouble in the first installs.