Page 1 of 1

[APG 2.6.2 win 7 x64] abnormally enlarged gigapixel

PostPosted: Thu Apr 05, 2012 9:40 am
by Hellkeeper
Hi there,

latest APG abnormally enlarges my Gigapixels ... ?!?
Just imported (Gigapan importer) a 4.000 Image Gigapixel shot from my D300 (12,4MP) Photos - stitchting / optimizing all went well - but now it wants to output it at 320 Gigapixel ... well ... that's a "little" bit more than I shot ... ;-)

Any ideas what could cause this?!?

Andreas

PostPosted: Thu Apr 05, 2012 11:07 am
by [bo]
Are you using planar projection? Or maybe mixing different focal length images?

PostPosted: Thu Apr 05, 2012 11:08 am
by Hellkeeper
it's cylindrical projection and all images are shot with 750mm

PostPosted: Thu Apr 05, 2012 12:58 pm
by AlexandreJ
The calculation hasn't changed, so the size should not change. Nevertheless, take car of some facts :
- We don't base final size calculation on the input focal length, but on the calculated focal length but there might be no exif so no information about focal length
- Autopano does try to find the longest focal length image, and for this one, we suppose a 1:1 ratio between input and output.
This is how it works.
So, the first fact to check what is the calculated range of focal. If you found one image with 1500mm for example, then it explains why the rest is enlarged.

PostPosted: Thu Apr 05, 2012 1:16 pm
by Hellkeeper
just checked the image properties of the imported images - all show 750 focal length (and EXIF on all images)
491,80mm x 1.525 (Nikon D300) x 1,00 => 750mm standard Lens

So this doesn't seem to be the cause! :-(

I shot 3936 images with 12,4MP ... so with (no overlap) the maximum would be 48806,4MP
APG outputs 319241,94MP

That's 6,54 times larger than my source images are ... :-/

Any other ideas what could cause this?

PostPosted: Thu Apr 05, 2012 1:20 pm
by AlexandreJ
Did you really check at the right location ?
Tip of the day : click on the calculated column header to sort by focal up or down

PostPosted: Thu Apr 05, 2012 2:33 pm
by Hellkeeper
ok - my fault ... was looking at the imported image properties :-)

got pretty weird computed focals on this pic :-/
How can that happen and how to avoid this?

Image
http://temp.in.futureweb.at/autopano/ibk.jpg

PostPosted: Thu Apr 05, 2012 4:39 pm
by AlexandreJ
Definitively a wrong image. So the question is why ?

Most probably because of some wrong control point there. Several options are then possible :
- look at the cp, correct them, reoptimize. I won't go this path though, as this image is totally blurred ( out of focus ).
- I would click on "sichtfeld" zone of this image, and edit the value to something around 1.6° ( would change the focal length to 1400 mm ).
It won't change the image location, just it's size. It's pure white, it won't affect anything around it because everything is just blur and it will fix the final panorama size.

PostPosted: Thu Apr 05, 2012 4:52 pm
by Hellkeeper
alright - changed "sichtfeld" to 1,6
the image is already shrinking - but it's still about 100 Gigapixel ...
it shows me computed focal from 601,94 to 1.290,55 while the actual focal length was 750mm
about 1/5 of all pictures are over 750mm computed focal ... ?!? :-(

PostPosted: Tue Nov 06, 2012 1:37 pm
by Hellkeeper
Hi,

again on this Topic. I rendered this Picture - and it's about 4x the size it should be: http://www.gpix.at/Gpix.at-Gigapixel_gpath,innsbruck1,pid,9112,type,gpix.html?devpreview=true
Changing all "sichtfeld" to correct values would take ages - as some thousand Pictures are affected.
Is there any possibility to tell APG to "NOT ENLARGE" the COMPUTED FOCAL over a given value? let's say I know that my focal is 750mm - tell APG it should not enlarge it more than say 850mm or something like that ... ?

Andreas

PostPosted: Tue Nov 06, 2012 2:52 pm
by ThomasV
Hello Andreas,

If all the pictures were done with the same focal, you might try to change the optimisation settings to force the same focal value for all pictures (Group Parameters > Optimisation).

Regards,
Thomas

PostPosted: Tue Nov 06, 2012 3:02 pm
by Hellkeeper
Hi Thomas,

they were done with same focal - I will try it and report back!

thx
Andreas

PostPosted: Tue Nov 06, 2012 3:34 pm
by Hellkeeper
Hi again,

I can't find any option where I can configure this? I'm in the Group Parameters -> Optimization right now ...
Using 3.0.0 Beta 2 now

thx
andreas

PostPosted: Tue Nov 06, 2012 3:41 pm
by ThomasV
In the 'Lens distortion correction' box, check 'Enabled' if not already selected,
and select 'Force identic' for 'Focal calculation'.

Hope it helps,
Thomas

PostPosted: Tue Nov 06, 2012 3:43 pm
by Hellkeeper
Well - the problem is that you cannot render a large Gigapixel with activated Lens disortion correction. APG will crash that moment you start the stitching ...

PostPosted: Tue Nov 06, 2012 3:54 pm
by klausesser
Hellkeeper wrote:Hi,

again on this Topic. I rendered this Picture - and it's about 4x the size it should be: http://www.gpix.at/Gpix.at-Gigapixel_gpath,innsbruck1,pid,9112,type,gpix.html?devpreview=true
Changing all "sichtfeld" to correct values would take ages - as some thousand Pictures are affected.
Is there any possibility to tell APG to "NOT ENLARGE" the COMPUTED FOCAL over a given value? let's say I know that my focal is 750mm - tell APG it should not enlarge it more than say 850mm or something like that ... ?

Andreas

Hey Andreas!

When you set "100%" as rendering value the image can´t be more than 100% which means the correct amount in terms of the sum of your images - UNLESS you blew it up by geometrical "correction" for example. Some geometrical correction scale up the whole image to match the correction. This sometimes happens when you plan-project a mosaic and use vertical or/and horizontal straightening tools. In that case you should lower the render-size to a percentage which equals the amount of resolution of all your images.

Also check whether you set 8bit or 16bit. 16bit raises the amount of data remarkably - and most of it is redundant.

best, Klaus

PostPosted: Tue Nov 06, 2012 3:58 pm
by ThomasV
Ok Andreas, we will give a look at it.

Regards,
Thomas

PostPosted: Tue Nov 06, 2012 4:01 pm
by klausesser
Hellkeeper wrote:Well - the problem is that you cannot render a large Gigapixel with activated Lens disortion correction. APG will crash that moment you start the stitching ...

I looked at you image: it´s definitely up-scaled. You can realize that when you look at it with full zoom.
So it MUST be bigger than expected in relation to the input images ;):cool:

best, Klaus

PS: i guess a more realistic resolution is around 20-25GPx - that´s the amount it starts to blur when you zoom in.

I found this a common issue with many Super-Mega-Gigapixels: they´re fake - sorry.

P.S.2: the counter is irritating. Zooming in @100% doesn´t show the resolution of the whole image but of the crop which is displayed.
As said: zooming in definitely exceeds 100%. So it´s hardly possible to judge the real resolution of the pano.

PostPosted: Tue Nov 06, 2012 4:12 pm
by Hellkeeper
@Klaus: yea - the rendered pixeldata is about 4x the expected Output size ... without the usage of any straightening tools. APG blows some Images up to computed focal of 2200mm and more (when doing the stitching) ... even the picture was shot with 750mm ...
@Thomas: ok - thx!

Andreas

PostPosted: Tue Nov 06, 2012 4:17 pm
by klausesser
Hellkeeper wrote:@Klaus: yea - the rendered pixeldata is about 4x the expected Output size ... without the usage of any straightening tools. APG blows some Images up to computed focal of 2200mm and more (when doing the stitching) ... even the picture was shot with 750mm ...
@Thomas: ok - thx!

Andreas

Did you try 2.6?

best, Klaus

PostPosted: Tue Nov 06, 2012 5:21 pm
by ThomasV
Hello Andreas,

From what I understand, it seems that there are very bad links in your pano, otherwise autopano does not find such huge focals. Therefore, I suggest you to change the settings in the gigapan importer to 'skip optimisation'.
Doing that, you can follow the tutorial http://www.autopano.net/wiki-en/Troubleshooting_Papywizard_Cases to detect and remove such links (who have bad control points).
Once those links are removed, you might be able to optimize your pano with less trouble.

It is almost equivalent to remove the links for images having huge computed focal value.

Hope it helps,
Thomas

PostPosted: Tue Nov 06, 2012 7:12 pm
by Hellkeeper
@Klaus: with APG 2.5.* everything worked fine, starting with APG 2.6.x (can't remember the exact version where the troubles started) things got worse ... :-/

@Thomas: I tried it with "skip optimization" now ... but got some weird result ... ?!? --> http://temp.in.futureweb.at/apg/ibk1.JPG <-- as you can see in the overview it shows me 304715 x 103300 Pixels which would be about the Size I expected for this Picture. (In contrast when I activate optimization it's: 673633 x 227193)
But when I open the Editor Window --> it's only 800 x 271 Pixels ... nothing I can work with ... (look at the Zoom-percentage) ... what's wrong here?!?

PostPosted: Wed Nov 07, 2012 8:45 am
by ThomasV
Hello Andreas,

The total size of the picture depends on the computed focals. As the pano is still not optimized, it is possible that the size is wrong (and it is, here). Could you please continue the links cleaning I suggest in my previous message, and run optimization. The focals will get optimized, and the image size might become more realistic.

Regards,
Thomas

PostPosted: Wed Nov 07, 2012 10:19 am
by Hellkeeper
Hi Thomas,

I think the computed Focals of ALL pictures would be correct (749.75mm) as you can see here: http://temp.in.futureweb.at/apg/ibk2.JPG
I followed the HowTo - deleted all Control Points having RMS bigger than 20 and did an optimization - result: http://temp.in.futureweb.at/apg/ibk3.JPG

As you can see the Image is still shown as 800 x 270 Pixels ...something is a bit weird here? :/

Andreas

PostPosted: Wed Nov 07, 2012 1:54 pm
by ThomasV
Hi Andreas,

It seems that there is a bug on the displayed size when autopano is in CPU mode. Can you please try to render the pano ? The size should be ok here.
Or, just try the GPU mode if you can.

Regards,
Thomas