Page 1 of 1

CUDA on Windows 10

PostPosted: Fri Aug 04, 2017 6:15 pm
by DJW
On my desktop PC I'm not able to see a 'Realtime Preview' when set to GPGPU in the Settings>General tab 'Rendering Engine':


And any attempt to render outputs black frames. Input files are from an OMNI rig with the GoPros at 2.7k. (2704x2032 pixels)

When I change to GLSL (OpenGL) I get the 'Realtime Preview' and can render.

Here's the CUDA Driver details:


Is this a know limitation / issue right now..? Or is there another possible reason that I'm not getting any results from RC2 using CUDA on this machine at the moment..?

This is a screengrab showing blank 'Realtime Preview':


I'm running AVP 3.0.0 RC2 on a fully patched Windows 10 64bit PC:

i7 5930k
64Gb RAM
Samsung 960 EVO M.2s and WD Black HDs in RAID.
EVGA GTX 980ti Hybrid (Driver version 384.94)

My reason for asking is that when I open the same project on my Alienware 15R2 laptop, set to GPGPU the 'Realtime Preview' is fine, and I can render.... This was true on RC1 and on RC2.

Specs are similar:

i7 6700HQ
32Gb RAM
2 x M2s
GTX 980M

Windows 10 fully patched, Nvidia Driver was 378.49 and is now updated to 384.94 to test same as the desktop machine. I've checked Video Codecs, both machines have same codecs installed.

This is a screengrab of same project on the Laptop:


Any pointers what to check..?

Re: CUDA on Windows 10

PostPosted: Tue Aug 08, 2017 4:09 pm
by ColKurtz
Hi David,

I just finished updating our VR/360 editing rig and installing AV3.
Just purchased the Omni last week.
I'm running almost the same rig as you but my driver has not been updated in a while and still on 378.92.
It's really late here but I plan to do some testing tomorrow. I will make a note to come back here and let you know if I have similar problems with the preview.
That way you will at least be able to eliminate the latest NVIDIA driver update being the issue.

Windows 10 64-bit
GeForce GTX 980 Ti
Driver version 378.92 (been away most of the summer)
Intel(R) Core(TM) i7-4790 CPU 3.60GHz
Autopano Video 64 bit 3.0.0 RC 2

Re: CUDA on Windows 10

PostPosted: Tue Aug 08, 2017 4:43 pm
by DJW

Thanks and yes, it will be interesting to hear how you get on with the 980ti and that older driver.

Best of luck.

Re: CUDA on Windows 10

PostPosted: Wed Aug 09, 2017 4:29 pm
by ColKurtz
Hi David,

Tonight I had time to drag some Omni footage into AV3 and the Realtime Preview worked.
I have not had a chance to try this with the Omni importer.
Again, if I were in your situation, and all else being equal, I might suspect the latest NVIDIA driver update.

I turned off auto-update a while back as I found it wanted updates every single power up and my guess was that was for very specific VR gaming issues, not video editing.
I've attached images to illustrate.

I hope this helps with deduction. I've sent the "Graphics properties" data from inside AV3 Settings / Check GLSL Engine to Kolor. Best of luck with your issue.



Shows Preview.PNG
Here you can see the Realtime Preview working

Here is GPU version info, my rig info is in my signature

Settings 2.PNG
GPGPU is selected with preview working

Re: CUDA on Windows 10

PostPosted: Thu Aug 10, 2017 10:45 am
by DJW
Hi Ryan

Thanks for sharing this. I thought your suggestion was reasonable, its been concerning me that all the Nvidia updates seem to be games related, and the odds high that something else gets broken while they're doing it... So I downgraded to 378.92 and did a 'clean install', rebooted, and no luck, same issue.

Just wanted to check something with you, your screengrab of APV 3RC2 shows 'OpenGL' in the preview window.

opengl.PNG (103.88 KiB) Viewed 3514 times

And this works fine with me too on both machines. But it should show 'CUDA' when the 'Rendering Engine' is set to GPGPU in settings. (Thats my understanding..)

So my laptop shows this in the preview window when set to GPGPU:

cuda laptop.PNG
cuda laptop.PNG (56.22 KiB) Viewed 3514 times

So the preview is displaying fine, and its realtime, faster than OpenGL on my laptop by a factor of two I think. Same when rendering out.

But my desktop with the 980ti when set to GPGPU shows this in the preview window:

cuda.PNG (8.21 KiB) Viewed 3514 times

No preview is displayed. And I've noticed another symptom, when 'playing' the sequence back the rotating dots under the preview screen are active, as if there's a file playing. But the playhead does not move along the timeline.

Anyone from Kolor like to comment..? Would be good to know if its a real issue or whether I should continue to troubleshoot my machine / installation.

Best regards

Re: CUDA on Windows 10

PostPosted: Wed Aug 30, 2017 5:52 pm
by DJW
An update of sorts... Issue is the same on v3.0 RC3, and with latest Nvidia driver 385.41.

Re: CUDA on Windows 10

PostPosted: Thu Aug 31, 2017 3:07 pm
by DJW
Another update...

I shot a range of OMNI clips to test, various frame sizes and frame rates. Initially same problem, no Preview displayed.

So I pressed the 'Display Camera Numbers' button, they appeared, but no Preview, then I tried ' Display Grid', the grid displayed, but no preview.

CUDA Preview.JPG
Realtime Preview - CUDA

Finally I tried 'Display Stitching Lines'. After a few seconds the stitching lines, and the preview (!!!!) appeared.

CUDA Preview 2.JPG
Realtime Preview - OpenGL

So I was quite excited, I thought that was a result... Briefly.

Then I realised, it seems that selecting 'Display Stitching Lines' just switches the preview into OpenGL mode. (See the image above).

Deselecting the 'Display Stitching Lines' button switches back to 'Realtime Preview - CUDA', and although the preview image stays on screen, its stalled.

I do get a result when using CUDA to render.

Rendering with CUDA

So, I'm a bit confused really. Desktop PC with a 980ti will not preview with CUDA, laptop with 980M has no problems with same project both machines on RC3. Selecting 'Display Stitching Lines' makes the desktop usable, but just by kicking it into OpenGL.

Can I ask whether anyone else is seeing this behaviour..? Equally if anyone at Kolor knows this is a bug to be dealt with, it would be good to know.


Re: CUDA on Windows 10

PostPosted: Tue Sep 12, 2017 10:28 am
by DJW
And one more comment... Just tried the approved OMNI sample from here: ... ow#Samples

And its same result, no Preview when using CUDA.

I'd really appreciate a comment from Kolor.