[APG2 Win XP Pro] Crashes during detection (SIFT)  

This forum is dedicated to Autopano Pro / Giga bug reports and features discussion.
Please read the posting rules before starting a topic!
User avatar
Aeriscera
Member
 
Posts: 513
Joined: Tue Mar 11, 2008 10:49 pm
Location: Bath, UK

[APG2 Win XP Pro] Crashes during detection (SIFT)

by Aeriscera » Sun May 10, 2009 10:45 pm

Hello Everyone,

SIFTBug.zip causes a SPLAT during SIFT. Tried importing as gigapan and loading in the usual way, with and without GPU on both my one- and four-core machines (same OS).

ETA 10am BST

Aeris

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Thu May 14, 2009 10:38 am

2 images are slightly corrupted ( some pixels missing at the end of the file ) :
DSC04767.jpg
DSC04818.jpg
We'll probably change the way to handle such file in a future version but not in next one.

User avatar
Aeriscera
Member
 
Posts: 513
Joined: Tue Mar 11, 2008 10:49 pm
Location: Bath, UK

by Aeriscera » Thu May 14, 2009 12:51 pm

Yes, discovered this myself after your post on another topic. Thanks. Fortunately I always bracket (except when I don't) so it wasn't a big problem in this case.

Somewhat off-topic, but can you recommend a tool for repairing broken JPEGs? Most image viewers make an attempt at recovering something, but they tend not to make a good job of it.

A

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Thu May 14, 2009 1:05 pm

Photoshop is good at that in fact. It handles well corrupted images.
BTW : do you know the cause of that ? I wonder how to corrupt just some lines in a jpeg ...

User avatar
Aeriscera
Member
 
Posts: 513
Joined: Tue Mar 11, 2008 10:49 pm
Location: Bath, UK

by Aeriscera » Thu May 14, 2009 1:28 pm

I suspect it is a dying USB 1TB drive (with all my photos on it)

:(

A

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Thu May 14, 2009 3:27 pm

Hurry go out and get a new one ...


Return to Autopano bug & discussion

Who is online

Users browsing this forum: No registered users and 2 guests