APG on Ubuntu Wily 15.10, wants libicui18n.so.52  

This forum is dedicated to Autopano Pro / Giga bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
bradtem
Member
 
Topic author
Posts: 219
Likes: 0 post
Liked in: 0 post
Joined: Tue Nov 18, 2008 11:42 pm
Info

APG on Ubuntu Wily 15.10, wants libicui18n.so.52

by bradtem » Sun Dec 06, 2015 6:16 pm

I just upgraded to the latest Ubuntu (15.10 wily werewolf) on AMD64 and also upgraded my APG to 4.23. Unfortunately it fails to start, saying:

Code: Select all
AutopanoGiga: error while loading shared libraries: libicui18n.so.52: cannot open shared object file: No such file or directory


On the system there is libicui18n.so.55 (and 55.1) but 52 is an old version no longer supported, it seems. It is no longer in the apt repository either.

User avatar
ClaireM
Moderator
 
Posts: 479
Likes: 6 posts
Liked in: 36 posts
Joined: Fri Nov 14, 2014 9:17 am
Info

Re: APG on Ubuntu Wily 15.10, wants libicui18n.so.52

by ClaireM » Mon Dec 07, 2015 9:10 am

Hi,

You can try this workaround :
-> In a terminal enter the following commands :

wget http://security.ubuntu.com/ubuntu/pool/ ... _amd64.deb

dpkg -i libicu52_52.1-8ubuntu0.2_amd64.deb

Let us know about the result,

Best,

Claire

(NOTE : this is a workaround for 15.10, however it is clearly indicated that APG was only tested on Ubuntu 14.04 LTS)

no avatar
bradtem
Member
 
Topic author
Posts: 219
Likes: 0 post
Liked in: 0 post
Joined: Tue Nov 18, 2008 11:42 pm
Info

Re: APG on Ubuntu Wily 15.10, wants libicui18n.so.52

by bradtem » Mon Dec 07, 2015 6:21 pm

Understood. Though generally it looks like APG may be doing its bindings too tightly, since most programs are capable of running on newer releases if they are designed and tested on an older release.

I would strongly suggest to Kolor that the most common and probably best way to support Ubuntu is with a "PPA" which will make it install, calculate the dependencies, and also allow us to automatically upgrade as compatible new versions come out. It is the official way -- a hand downloaded deb is the kludge approach.

no avatar
bradtem
Member
 
Topic author
Posts: 219
Likes: 0 post
Liked in: 0 post
Joined: Tue Nov 18, 2008 11:42 pm
Info

Re: APG on Ubuntu Wily 15.10, wants libicui18n.so.52

by bradtem » Mon Dec 07, 2015 6:25 pm

Also, while this worked, once again it forgot all my settings. I know it does this on major version upgrades but it should not, an definitely not on minor version upgrades. Or perhaps you can work out a more portable format to store settings in.


Who is online

Users browsing this forum: No registered users and 1 guest