3.5 XML plus optimization  

This forum is dedicated to Autopano Pro / Giga bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
klausesser
Member
 
Posts: 7859
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

3.5 XML plus optimization

by klausesser » Tue Feb 04, 2014 6:13 pm

Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

Re: 3.5 XML plus optimization

by gkaefer » Tue Feb 04, 2014 10:16 pm

klausesser wrote:Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.


Hi Klaus,

can you make some low res Images and send a private download link (Images and XML)
I currently do test my new panoneed ;-))) excessivley and using the xmls with the 3.5 I today did no Encounter any Problem so far....

Liebe Grüße,
Georg

User avatar
AntoineM
Kolor Team
 
Posts: 70
Joined: Sun Apr 21, 2013 6:43 pm

Re: 3.5 XML plus optimization

by AntoineM » Wed Feb 05, 2014 10:42 am

Hi Klaus,
Please send me the download link if you upload your images and XML.
Best regards,
Antoine.

no avatar
klausesser
Member
 
Posts: 7859
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

Re: 3.5 XML plus optimization

by klausesser » Wed Feb 05, 2014 4:00 pm

Hi Antoine, hi Georg!

In the evening i´ll put it on my server and send you the link as PM!

thanks in advance, Klaus

no avatar
klausesser
Member
 
Posts: 7859
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

Re: 3.5 XML plus optimization

by klausesser » Wed Feb 05, 2014 5:35 pm

Hi Antoine, hi Georg!

here it is:

www.klausesser-interaktiv.de/3_5.zip

best, Klaus

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

Re: 3.5 XML plus optimization

by gkaefer » Wed Feb 05, 2014 11:43 pm

klausesser wrote:Hi Antoine, hi Georg!

here it is:

http://www.klausesser-interaktiv.de/3_5.zip

best, Klaus


thanks for the link.
first try: loading XML with papy imprt + ignoring the hint that lens type in XML is not equal to lens type of the Image (what is normal, the jpgs have no exif)
detection hit... I saved the Project file and attached it.... you maybe have to adopt the Image paths...

I played a bit with colorcorrection and optimized CPs thats it...
Attachments
klaus.zip
the .apw Project file and the detected .pano file
(186.12 KiB) Downloaded 34 times
2014-02-05 23_38_41-[Group 0]-_MG_6452_3_4__MG_6467_8_9-6 images.pano_.png

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

Re: 3.5 XML plus optimization

by gkaefer » Wed Feb 05, 2014 11:51 pm

editing CPs:
all links in upper row I added new cps automatically and did globally optimize. than I deleted all CPs higher than 3.99.
all links in lower row I deleted all CPs higher than 3.99.
result 2.40 RMS...

and my Settings used:
Attachments
2014-02-05 23_53_11-Autopano Giga 64bits 3.5.0 Beta 1.png
2014-02-05 23_53_16-Program Manager.png
2014-02-05 23_48_47-[Group 0]-_MG_6452_3_4__MG_6467_8_9-6 images.pano_.png

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

Re: 3.5 XML plus optimization

by gkaefer » Wed Feb 05, 2014 11:55 pm

Settings part 2:
Attachments
2014-02-05 23_52_56-Autopano Giga 64bits 3.5.0 Beta 1.png
2014-02-05 23_53_01-Autopano Giga 64bits 3.5.0 Beta 1.png
2014-02-05 23_53_06-Autopano Giga 64bits 3.5.0 Beta 1.png

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

Re: 3.5 XML plus optimization

by gkaefer » Wed Feb 05, 2014 11:56 pm

Settings used part 3
and a render limited to 3200xY Pixels (1.00mb)
except a not burning tealight I cant see any anomalies :cool:

Liebe Grüße,
Georg
Attachments
[Group 0]-_MG_6452_3_4__MG_6467_8_9-6 images_0001.jpg
2014-02-05 23_52_49-Program Manager.png
Last edited by gkaefer on Thu Feb 06, 2014 12:05 am, edited 1 time in total.

no avatar
mediavets
Moderator
 
Posts: 14178
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: 3.5 XML plus optimization

by mediavets » Thu Feb 06, 2014 12:04 am

klausesser wrote:Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.


Is there any need to use XML when shooting with a fisheye lens?

You say yourself it stitches perfectly without so what's the problem here?

no avatar
klausesser
Member
 
Posts: 7859
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

Re: 3.5 XML plus optimization

by klausesser » Thu Feb 06, 2014 1:06 am

mediavets wrote:
klausesser wrote:Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.


Is there any need to use XML when shooting with a fisheye lens?

You say yourself it stitches perfectly without so what's the problem here?


The problem is that the XML doesn´t work perfectly as usual. Aside from that it´s not needed here.
Shooting indoors in small rooms and/or low ceilings the XML often is very well needed!
Whether it´s needed or not: it needs to work properly.

But i played a bit with the settings - it works well now!

Thanks for evaluating, Georg!

best, Klaus

no avatar
mediavets
Moderator
 
Posts: 14178
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: 3.5 XML plus optimization

by mediavets » Thu Feb 06, 2014 1:16 am

klausesser wrote:Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.


I had no trouble with it.

Screenshot 1 - demonstrates that it detected focal length discrepancy (between what is recorded in the XML and the defauklt value should there be no EXIF).

Screenshot 2 - choose to use XML focal.

Screenshot 3 - end result.

Looks OK to me.
Attachments
1-apg35b1-klaus-xml.jpg
2-apg35b1-klaus-xml.jpg
3-apg35b1-klaus-xml.jpg

no avatar
klausesser
Member
 
Posts: 7859
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

Re: 3.5 XML plus optimization

by klausesser » Thu Feb 06, 2014 1:46 am

mediavets wrote:
klausesser wrote:Hi!

Without PW-XML the pano - 6 shots fisheye - stitches perfectly in 3.5.
With PW-XML it´s producing a mess. I tried "skip optim." and unchecked it (optimization) - makes no difference.

The XML is correct and works perfectly in PTGui.

Klaus

Using XML doesn´t provide usable results so far.


I had no trouble with it.

Screenshot 1 - demonstrates that it detected focal length discrepancy (between what is recorded in the XML and the defauklt value should there be no EXIF).

Screenshot 2 - choose to use XML focal.

Screenshot 3 - end result.

Looks OK to me.


Hi Andrew!

The RMS means at least minor errors. I also had RMS around 3 first - produced small but visible errors.
After checking the settings and set them to values i found stitching and optimizing in the end
lead to RMS around 1 and showed no errors anymore.

best and thank you too, Klaus

Result (heavy compression and a sRGB profile lead to some posterizing):
Attachments
_MG_6452_3_4 PanoramaARb_sphere.jpg

User avatar
AntoineM
Kolor Team
 
Posts: 70
Joined: Sun Apr 21, 2013 6:43 pm

Re: 3.5 XML plus optimization

by AntoineM » Thu Feb 06, 2014 6:15 pm

Hi,
We have worked a lot on the use of XML files this week, you should see a great improvement in beta2 (to be released next week in principle).
Best regards,
Antoine.


Return to Autopano bug & discussion

Who is online

Users browsing this forum: No registered users and 3 guests