[300A1 Linux] problem with %C in filename template  

This forum is dedicated to Autopano Pro / Giga bug reports and features discussion.
Please read the posting rules before starting a topic!
User avatar
DrSlony
Moderator
 
Topic author
Posts: 1893
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 03, 2007 6:30 pm
Location: Sweden
Info

[300A1 Linux] problem with %C in filename template

by DrSlony » Sun Jul 01, 2012 7:35 pm

Problem: The %C variable is correctly expanded in the Render panel preview and in the Batch Renderer, but APG doesn't always save the file under that name.

Reproduce:
I created a panorama, used HDR color correction, in the Render panel I selected "HDR Output" and saved as EXR:
ball %P %T %B %C hdrout
The Batch Renderer shows that the file was saved as:
/media/usb_data/photos_purgatory/panoramas/ball Spherical Spline 64 Multiband(-2) HDR hdrout.exr
True, the file exists.

Now I set color correction to None, the rest of the settings remain identical.
The Batch Renderer shows that the file was saved as:
/media/usb_data/photos_purgatory/panoramas/ball Spherical Spline 64 Multiband(-2) None hdrout.exr
There is no such file, there is only the "HDR hdrout.exr" file.

I removed that file, and clicked render again.
It was saved as:
/media/usb_data/photos_purgatory/panoramas/ball Spherical Spline 64 Multiband(-2) HDR hdrout.exr
Bad! Should have been saved as "ball Spherical Spline 64 Multiband(-2) None hdrout.exr"

Who is online

Users browsing this forum: No registered users and 2 guests

cron