Page 1 of 1

[300A1 Linux] switching projections happens in two steps

PostPosted: Fri Jun 15, 2012 8:50 pm
by DrSlony
Not sure if bug or a feature request.
When switching projections, the preview responds in two steps. It should jump from the current projection to the clicked correct one, without the incorrect intermediate step.

1- Start off with the pano in the "Spherical" projection and "fit projection on screen".
2- Click on "Pannini".
What first happens is that the pano is stretched horizontally and after a second the proper pannini projection kicks in.
The attached screenshots show this. It should jump from what screenshot 1 shows to what screenshot 3 shows, but instead I see what screenshot 2 shows for a second.

It happens with the other projection modes too, I just used these two as an example.

PostPosted: Sat Jun 16, 2012 11:15 am
by Nanard
Agreed, it's difficult to juge the difference between 2 projection types. Same problem with APG 2.6.3
Bernard

PostPosted: Wed Jun 20, 2012 8:44 am
by AlexandreJ
Issue 1398 opened

PostPosted: Sun Jul 01, 2012 7:11 pm
by DrSlony
Thank you.

The Exposure Fusion settings preview has the same problem - after every slider change, the preview resets back to some default view and after a few seconds exposure fusion with the new settings kicks into effect. I would like to see the difference between level -2 and 0 without it switching back to the default view for a few seconds.

PostPosted: Wed Oct 31, 2012 11:20 pm
by DrSlony
Switching projections fixed in 3.0-beta2, thank you!