Page 1 of 1

[APP 2.6 RC1 Mac] - preview not shown

PostPosted: Sat Nov 12, 2011 8:39 pm
by bouscram
Another problem on OS X 10.7.2 : the preview isn't shown when a panorama is loaded ; it is true for new panoramas or when loading an old one.

PostPosted: Mon Nov 14, 2011 9:20 am
by AlexandreJ
Issue 998 opened

PostPosted: Mon Dec 12, 2011 6:07 pm
by bouscram
Also still present in RC2

PostPosted: Tue Dec 13, 2011 6:57 am
by kzaugg
I am running Windows Vista and have tried RC1 & RC2 and have had the same issue.

PostPosted: Tue Dec 13, 2011 9:48 am
by Lionel Laissus
Have you checked the GPU preview in the global setting ?
Menu /Edit/Settings/Gpu processing/Check/OpenGL/Render

PostPosted: Tue Dec 13, 2011 7:30 pm
by bouscram
Good point : it is also blank. But otherwise GPU rendering works fine !...

edit : it is most of the times blank... and when it is, something seems to flicker very very quickly when you switch to the "Render" tab.

Here is the OpenGL info :

Code: Select all
OGL Version: 2.1 ATI-7.0.52
Render: ATI Radeon X1600 OpenGL Engine
Vendor: ATI Technologies Inc.
Shader Version: 1.20
MaxTextureSize: 4096
MaxTextureUnits: 8
MaxColorAttachement: 4
MaxRenderBufferSize: 4096
Extentions:
    GL_APPLE_aux_depth_stencil
    GL_APPLE_client_storage
    GL_APPLE_element_array
    GL_APPLE_fence
    GL_APPLE_float_pixels
    GL_APPLE_flush_buffer_range
    GL_APPLE_flush_render
    GL_APPLE_object_purgeable
    GL_APPLE_packed_pixels
    GL_APPLE_pixel_buffer
    GL_APPLE_rgb_422
    GL_APPLE_row_bytes
    GL_APPLE_specular_vector
    GL_APPLE_texture_range
    GL_APPLE_transform_hint
    GL_APPLE_vertex_array_object
    GL_APPLE_vertex_array_range
    GL_APPLE_vertex_program_evaluators
    GL_APPLE_ycbcr_422
    GL_ARB_depth_texture
    GL_ARB_draw_buffers
    GL_ARB_draw_elements_base_vertex
    GL_ARB_fragment_program
    GL_ARB_fragment_program_shadow
    GL_ARB_fragment_shader
    GL_ARB_half_float_pixel
    GL_ARB_half_float_vertex
    GL_ARB_imaging
    GL_ARB_instanced_arrays
    GL_ARB_multisample
    GL_ARB_multitexture
    GL_ARB_occlusion_query
    GL_ARB_pixel_buffer_object
    GL_ARB_point_parameters
    GL_ARB_point_sprite
    GL_ARB_provoking_vertex
    GL_ARB_shader_objects
    GL_ARB_shader_texture_lod
    GL_ARB_shading_language_100
    GL_ARB_shadow
    GL_ARB_shadow_ambient
    GL_ARB_sync
    GL_ARB_texture_border_clamp
    GL_ARB_texture_compression
    GL_ARB_texture_cube_map
    GL_ARB_texture_env_add
    GL_ARB_texture_env_combine
    GL_ARB_texture_env_crossbar
    GL_ARB_texture_env_dot3
    GL_ARB_texture_float
    GL_ARB_texture_mirrored_repeat
    GL_ARB_texture_non_power_of_two
    GL_ARB_texture_rectangle
    GL_ARB_texture_rg
    GL_ARB_transpose_matrix
    GL_ARB_vertex_array_bgra
    GL_ARB_vertex_blend
    GL_ARB_vertex_buffer_object
    GL_ARB_vertex_program
    GL_ARB_vertex_shader
    GL_ARB_window_pos
    GL_ATI_blend_equation_separate
    GL_ATI_blend_weighted_minmax
    GL_ATI_separate_stencil
    GL_ATI_texture_compression_3dc
    GL_ATI_texture_env_combine3
    GL_ATI_texture_float
    GL_ATI_texture_mirror_once
    GL_EXT_abgr
    GL_EXT_bgra
    GL_EXT_blend_color
    GL_EXT_blend_equation_separate
    GL_EXT_blend_func_separate
    GL_EXT_blend_minmax
    GL_EXT_blend_subtract
    GL_EXT_clip_volume_hint
    GL_EXT_compiled_vertex_array
    GL_EXT_draw_range_elements
    GL_EXT_fog_coord
    GL_EXT_framebuffer_blit
    GL_EXT_framebuffer_multisample
    GL_EXT_framebuffer_object
    GL_EXT_geometry_shader4
    GL_EXT_gpu_program_parameters
    GL_EXT_multi_draw_arrays
    GL_EXT_packed_depth_stencil
    GL_EXT_provoking_vertex
    GL_EXT_rescale_normal
    GL_EXT_secondary_color
    GL_EXT_separate_specular_color
    GL_EXT_shadow_funcs
    GL_EXT_stencil_two_side
    GL_EXT_stencil_wrap
    GL_EXT_texture_compression_dxt1
    GL_EXT_texture_compression_s3tc
    GL_EXT_texture_env_add
    GL_EXT_texture_filter_anisotropic
    GL_EXT_texture_lod_bias
    GL_EXT_texture_mirror_clamp
    GL_EXT_texture_rectangle
    GL_EXT_texture_sRGB
    GL_EXT_transform_feedback
    GL_EXT_vertex_array_bgra
    GL_IBM_rasterpos_clip
    GL_NV_blend_square
    GL_NV_fog_distance
    GL_NV_light_max_exponent
    GL_NV_texgen_reflection
    GL_SGIS_generate_mipmap
    GL_SGIS_texture_edge_clamp
    GL_SGIS_texture_lod
    GL_SGI_color_matrix

PostPosted: Wed Dec 14, 2011 8:46 am
by Lionel Laissus
bouscram wrote:Good point : it is also blank. But otherwise GPU rendering works fine !...

edit : it is most of the times blank... and when it is, something seems to flicker very very quickly when you switch to the "Render" tab.

if I'm right the GPU check was ok in 2.6.0 beta 2 ?

PostPosted: Wed Dec 14, 2011 10:02 am
by bouscram
I have just verified and you are right... GPU check OK in beta2

PostPosted: Wed Dec 14, 2011 10:41 am
by Lionel Laissus
Actually we fixed some OGL GPU issues in the 2.6.0 RC1/RC2 unfortunately it broke yours :-(

It looks like the "old" cards with old OGL Driver are not very compliance...
So we must figure out a "general workaround" to fix OGL buggy drivers.

Have you installed the latest combo update for your IMAC ?

PostPosted: Wed Dec 14, 2011 5:34 pm
by bouscram
I'm running 10.7.2, so I did a full upgrade (from 10.6) quite recently...

PostPosted: Fri Jan 27, 2012 11:43 am
by Lionel Laissus
Did it work better with APG 2.6.2 RC1 ?

PostPosted: Sun Jan 29, 2012 8:55 pm
by bouscram
Alas, still the same problems (also those from http://www.kolor.com/forum/viewtopic.php?pid=93879#p93879)

I don't see any change.