Page 1 of 1

[APG-2.6-b4] Cannot mix incompatible Qt library (version 0x40702)

PostPosted: Thu Oct 13, 2011 11:21 pm
by DrSlony
I get this error when trying to start APG-2.6-beta4:
Code: Select all
drslony@overkill ~ $ cd AutopanoGiga/
drslony@overkill ~/AutopanoGiga $ sh AutopanoGiga.sh
drslony@overkill ~/AutopanoGiga $ Cannot mix incompatible Qt library (version 0x40702) with this library (version 0x40704)

Obviously this is a bug, but I would like to work around it to use APG in the meantime. What QT version do I need? I have 4.7.2 installed on my system.

PostPosted: Thu Oct 13, 2011 11:26 pm
by gkaefer
DrSlony wrote:I get this error when trying to start APG-2.6-beta4:
Code: Select all
drslony@overkill ~ $ cd AutopanoGiga/
drslony@overkill ~/AutopanoGiga $ sh AutopanoGiga.sh
drslony@overkill ~/AutopanoGiga $ Cannot mix incompatible Qt library (version 0x40702) with this library (version 0x40704)

Obviously this is a bug, but I would like to work around it to use APG in the meantime. What QT version do I need? I have 4.7.2 installed on my system.

studying your error line ;-))

"(version 0x40702)" = "I have 4.7.2 installed"
"(version 0x40704)" = "I should install 4.7.x"

;-))

Georg

PostPosted: Thu Oct 13, 2011 11:29 pm
by DrSlony
I solved it.
Code: Select all
drslony@overkill ~ $ cd AutopanoGiga/
drslony@overkill ~/AutopanoGiga $ export QT_PLUGIN_PATH=""
drslony@overkill ~/AutopanoGiga $ ./AutopanoGiga.sh

This is what QT_PLUGIN_PATH was before I blanked it:
Code: Select all
drslony@overkill ~ $ echo $QT_PLUGIN_PATH
/usr/lib64/kde4/plugins:/home/drslony/.kde4/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/

PostPosted: Thu Oct 13, 2011 11:31 pm
by DrSlony
gkaefer the problem was that APG ships with the required QT libs, so it shouldn't really make a difference what I have installed, I just didn't expect I'd find the fault so quickly ;]

PostPosted: Thu Oct 13, 2011 11:36 pm
by gkaefer
DrSlony wrote:gkaefer the problem was that APG ships with the required QT libs, so it shouldn't really make a difference what I have installed, I just didn't expect I'd find the fault so quickly ;]

yes... but your solution to blank the system wide qt library path may help running autopano... but other software on your system is not aware of autopanos qt library coming with the package... so you now can expect that those packages do no longer find your qt library 4.7.2 ...
Georg

PostPosted: Thu Oct 13, 2011 11:36 pm
by DrSlony
So the fix for everyone is to add this line to AutopanoGiga.sh:
export QT_PLUGIN_PATH="$dirname"

PostPosted: Fri Oct 14, 2011 8:07 am
by AlexandreJ
Confirmed : Issue 932 opened

PostPosted: Wed Nov 09, 2011 6:26 pm
by l_archi
Same problem with

ii autopanogiga 260RC1 Meta package for Kolor Autopano image stitching software.

$ AutopanoGiga
Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40704)
/usr/bin/AutopanoGiga: line 4: 25392 Abandon /usr/lib/AutopanoGiga/AutopanoGiga


With tar.gz package :

$ sh AutopanoGiga.sh
Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40704)


Ubuntu is version 4.7.4

http://packages.ubuntu.com/fr/oneiric/libqt4-core

And debian unstable version 4.7.3

http://packages.debian.org/sid/libqt4-core

I still can not run the software ..

PostPosted: Thu Dec 22, 2011 4:51 am
by DrSlony
Works out of the box now (and iirc in RC2).

PostPosted: Sat Dec 31, 2011 4:45 pm
by l_archi
J'ai toujours le problème..


$ AutopanoGiga
Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40704)
/usr/bin/AutopanoGiga : ligne 4 : 20082 Abandon /usr/lib/AutopanoGiga/AutopanoGiga


$ dpkg -l |grep Auto
ii autopanogiga 260 Meta package for Kolor Autopano image stitching software.

Mes libs qt :

$ dpkg -l |grep libqt
ii libqt3-compat-headers 3:3.3.8b-8 Qt 1.x and 2.x compatibility includes
ii libqt3-headers 3:3.3.8b-8 Qt3 header files
ii libqt3-mt 3:3.3.8b-8 Qt GUI Library (Threaded runtime version), Version 3
ii libqt3-mt-dev 3:3.3.8b-8 Qt development files (Threaded)
ii libqt4-dbus 4:4.7.3-8 Qt 4 D-Bus module
ii libqt4-declarative 4:4.7.3-8 Qt 4 Declarative module
ii libqt4-designer 4:4.7.3-8 Qt 4 designer module
ii libqt4-help 4:4.7.3-8 Qt 4 help module
ii libqt4-network 4:4.7.3-8 Qt 4 network module
ii libqt4-opengl 4:4.7.3-8 Qt 4 OpenGL module
ii libqt4-qt3support 4:4.7.3-8 Qt 3 compatibility library for Qt 4
ii libqt4-ruby1.8 4:4.4.5-7 Qt 4 bindings for Ruby
ii libqt4-script 4:4.7.3-8 Qt 4 script module
ii libqt4-scripttools 4:4.7.3-8 Qt 4 script tools module
ii libqt4-sql 4:4.7.3-8 Qt 4 SQL module
ii libqt4-sql-mysql 4:4.7.3-8 Qt 4 MySQL database driver
ii libqt4-sql-sqlite 4:4.7.3-8 Qt 4 SQLite 3 database driver
ii libqt4-svg 4:4.7.3-8 Qt 4 SVG module
ii libqt4-test 4:4.7.3-8 Qt 4 test module
ii libqt4-webkit 4:4.7.4-1 transitional package for Qt 4 WebKit module
ii libqt4-xml 4:4.7.3-8 Qt 4 XML module
ii libqt4-xmlpatterns 4:4.7.3-8 Qt 4 XML patterns module
ii libqtassistantclient4 4.6.3-3 Qt Assistant client library (runtime)
ii libqtcore4 4:4.7.3-8 Qt 4 core module
ii libqtgui4 4:4.7.3-8 Qt 4 GUI module
rc libqtlocation1 1.2.0-1 Qt Mobility Location module
rc libqtmultimediakit1 1.2.0-1 Qt Mobility MultimediaKit module
ii libqtruby4shared2 4:4.4.5-7 internal library for Qt Ruby bindings
ii libqtwebkit4 2.2.0-3 Web content engine library for Qt

PostPosted: Sat Dec 31, 2011 6:08 pm
by fma38
Même problème chez moi (debian sid 64bits, APG 2.6.0)

PostPosted: Sat Jan 07, 2012 10:59 am
by l_archi
debian sid amd64 aussi

PostPosted: Sat Jan 21, 2012 2:44 pm
by l_archi
J'ai toujours le problème

une idée ?

PostPosted: Mon Jan 23, 2012 6:44 pm
by dcc
Même problème sur debian testing 64 bits mais fontionne sur Fedora 16.
Workaround possible sur debian:
lancer Autopano en étant root, oui je sais c'est mal mais ça marche.