Page 1 of 1

[APG 2.5.1/0 Vista 64 bit] Crash with Bug Splat

PostPosted: Fri Apr 15, 2011 2:04 am
by MGleason
About 2 weeks ago when I pressed detect 2.5.1 crashed with Bug Splat. Reloaded tried photos used successfully to generate a pano previously same result, rebooted tried again same result. Sent Bug Splat report. Since 2.5.1 was unusable (tried several times over a period of days), deleted and reinstalled 2.5.0. Registered program, which was reported as successful, successfully generated panos, when exiting program Bug Splat came up again. I now have to reenter registration information every time I run the program (2.5.0), always successfully, and get the Bug Splat when I exit, even if I simply open and close the program. 2.5.1 did work correctly for several days before the first crash.

PostPosted: Fri Apr 15, 2011 10:16 am
by AlexandreJ
Hi,

This seems to be related to saving of autopano settings. The only report we got that looks like your was due to wrong settings read back from registry and making the software crash. So to clean everything, uninstall the software ( with the provided installer => this will clean every registry entry related with the software ) and reinstall it again. Just launch the software and quit to see if it crash again.

PostPosted: Fri Apr 15, 2011 11:16 pm
by MGleason
Uninstalled 2.5.0 with uninstaller, installed 2.5.1 could generate pano but still bug splat every time on exit and does not keep registration key, ran program three times. Sent last bug splat report

PostPosted: Mon Apr 18, 2011 11:59 am
by AlexandreJ
Issue 669. You will be contacted to see what can be tested for this case.

PostPosted: Wed Apr 27, 2011 8:23 am
by Lionel Laissus
Could you do the GPU check ? menu/edit/settings/General tab/check button

http://www.autopano.net/wiki-en/action/view/Autopano_Pro_2.5_-_Preferences..._-_General

PostPosted: Wed Apr 27, 2011 11:58 pm
by MGleason
When I open the menu GPU processing is not enabled, I had reinstalled and not reset anything, so it displays:

OGL Version:
Render:
Vendor:
Shader Version:
MaxTextureSize: 0
MaxTextureUnits: 0
MaxColorAttachement: 0
MaxRenderBufferSize: 0
Extentions:

When I try to enable and press Ok it says not supported with string of OpenGL extensions not present.

My computer system info lists the following for the GPU:

GeForce GTX 280
Driver version: 180.44
Stream processors: 240
Graphics clock: 602 MHz
Processor clock: 1296 MHz
Memory clock: 1107 MHz (2214 MHz data rate)
Memory interface: 512-bit
Total available graphics memory: 2816 MB
Dedicated video memory: 1024 MB
System video memory: 0 MB
Shared system memory: 1792 MB
Video BIOS version: 62.00.0E.00.01
IRQ: 24
Bus: PCI Express x 16 Gen2

Program had been working fine until April 3rd, I made no changes in the system other than any Microsoft autoupdates.

PostPosted: Thu Apr 28, 2011 9:02 am
by Lionel Laissus
Try to install the latest driver for your graphic card


You should get something like this :

OGL Version: 3.3.0
Render: GeForce 8700M GT/PCI/SSE2
Vendor: NVIDIA Corporation
Shader Version: 3.30 NVIDIA via Cg compiler
MaxTextureSize: 8192
MaxTextureUnits: 4
MaxColorAttachement: 8
MaxRenderBufferSize: 8192
Extentions:
GL_ARB_blend_func_extended
GL_ARB_color_buffer_float
GL_ARB_compatibility
GL_ARB_copy_buffer
GL_ARB_depth_buffer_float
GL_ARB_depth_clamp
GL_ARB_depth_texture
GL_ARB_draw_buffers
GL_ARB_draw_elements_base_vertex
GL_ARB_draw_instanced

PostPosted: Fri Apr 29, 2011 2:00 am
by MGleason
Updated video drivers worked. Registration sticks and no Bug Splat when closing.

Thanks