Page 1 of 1

USB hard drives and NTFS

PostPosted: Sat Jun 13, 2009 1:20 am
by tarnis
Well I finally think I have my first and potentially my final pano from my orion head aligned right. Having some problems, and thought I'd ask...

I rendered the file out from ubuntu 64-bit autopano pro(not giga) onto an NTFS formatted seagate usb 2.0 drive as my ubuntu install was done with wubi and it doesn't really have room to store the file. Here 's the weirdness.

The file when I rebooted to XP and tried loading into photoshop gave me a Photoshop can't load this file error. Looking at its properties it said the 8gig file was only taking 4gigs on the disk. I moved the file to my main internal drive...also NTFS and it's an 8 gig file taking 8gigs on the disk. When loading with photoshop I now get an unexpected end of file error message. Is there a 4gig limit going over USB? I know fat32 had a 4gig limit but the drive is NTFS. Planning on a raid at some point soon but don't have the cash right now. Will prob try to render it in XP next but have a feeling it'll crash on me. will see, just wondering about the weird 4gig limmit for now.

Thanks
Matt

PostPosted: Sat Jun 13, 2009 1:55 am
by DrSlony
You rendered a PSB?

PostPosted: Sat Jun 13, 2009 2:27 am
by tarnis
sorry, yes

PostPosted: Sat Jun 13, 2009 3:58 pm
by wjh31
i used to have a 500GB USD HDD and never had any problems moving around files of 4+GB. From the info i see, my best guess is this:
NTFS supports file compression on the drive, and so that is likely why the file appears smaller, i.e it has been compressed.
So the the file doesnt open just beacuse it has somehow otherwise become corrupted, did the rendering finish cleanly?

PostPosted: Sun Jun 14, 2009 12:39 pm
by John_Sauter
I also have a 1/2 TB USB hard drive formatted NTFS, and I have never had any trouble with large files on it. I have, however, had trouble with large files being output by Autopano Pro. It is possible that the 4 GB limit you are seeing is in Autopano Pro. I don't have Adobe Photoshop so I can't reproduce your bug, but I have been unable to read large psb files with psdparse.

PostPosted: Sun Jun 14, 2009 1:00 pm
by wjh31
ive never had any problems with 4GB+ files from APP, recenlty had a ~5.5GB .psb that worked fine, using 64bit vista, 64bit app2 and 64bit cs4

PostPosted: Sun Jun 14, 2009 1:55 pm
by tarnis
maybe something with ubuntu writing to ntfs?

PostPosted: Sun Jun 14, 2009 6:37 pm
by DrSlony
Instead of maybe'ing you should try testing it :] Use dd to create a 8GB file, then copy it to your USB drive and back to your PC, and then diff the before and after to see if theres a difference.
http://en.wikipedia.org/wiki/Dd_(Unix)

PostPosted: Tue Jun 16, 2009 11:29 am
by tarnis
I guess we're moving into a bug... 8gig non-working files out of linux 64-bit, 22gig file out of windows 32bit that works. Slooooow but works.

Thanks all