Page 1 of 1

After pressing VR Mode button I see only a white screen

PostPosted: Sat Jul 18, 2015 7:34 am
by panoguy
I have downloaded the 2.5 beta version and wanted to build a tour using VR mode.
The tour works and I can see the WebVR icon on the screen as I have enabled VR mode on desktop, but when I click the VR button I get a white blank screen and not the expected menu to select the HMD options.
The same happens even on the mobile (note 4) using the chrome beta browser!
Any idea what I'm doing wrong?
Here a link to the tour I want to build

Re: After pressing VR Mode button I see only a white screen

PostPosted: Sat Jul 18, 2015 8:29 am
by panoguy
Just found out if I show the maps and press the VR button after (while maps are still on screen) I don't get the white screen!
Very strange behavior, after hiding the maps the VR button shows again the white screen.
And it works just fine if I remove the maps completely from my tour... But I hope you guys will fix it ;-)

Re: After pressing VR Mode button I see only a white screen

PostPosted: Sat Jul 18, 2015 10:10 am
by Cliquetsy
2.5 beta feedback forum is here > viewforum.php?f=117

This post will be moved... sometime, but post future feedback there.

Re: After pressing VR Mode button I see only a white screen

PostPosted: Sat Jul 18, 2015 10:32 am
by panoguy
Thank you, did not see that there is a dedicated forum for 2.5,
For now I have disabled the maps as a workaround but please check if you can reproduce this behavior and get it fixed.

Re: After pressing VR Mode button I see only a white screen

PostPosted: Sat Jul 18, 2015 10:57 am
by Destiny
I moved your post to the right forum... ;)

Destiny..

Re: After pressing VR Mode button I see only a white screen

PostPosted: Mon Jul 20, 2015 10:06 am
by benji33
Can't see your VR button to test it ?

Re: After pressing VR Mode button I see only a white screen

PostPosted: Mon Jul 20, 2015 5:19 pm
by panoguy
Hi Benjamin,
sorry I had disabled the VR mode to workaround the problem, please try now, you may need to clear browser cache.

Re: After pressing VR Mode button I see only a white screen

PostPosted: Tue Jul 21, 2015 10:41 am
by benji33
Hi code is encrypted so I cannot have a look, but it seems that the viewer return an error when trying to go to the WebVR mode so the player is never loaded into WebVR mode.

Is it possible to try something ? If yes into the online HTML file replace these lines by the second ones :
Code: Select all
function accessWebVr(){
unloadPlayer();
eventUnloadPlugins();
loadPlayer(true);
}

by
Code: Select all
function accessWebVr(){
eventUnloadPlugins();
unloadPlayer();
loadPlayer(true);
}

Re: After pressing VR Mode button I see only a white screen

PostPosted: Tue Jul 21, 2015 11:50 am
by benji33
EDIT : ok it's an issue when the map is hidden. Once the map is displayed the WebVR button works. I report the issue for correction.