After pressing VR Mode button I see only a white screen  

User avatar
panoguy
Member
 
Topic author
Posts: 106
Likes: 1 post
Liked in: 0 post
Joined: Mon Jan 25, 2010 3:55 am
Location: Bavaria
Info

After pressing VR Mode button I see only a white screen

by panoguy » Sat Jul 18, 2015 7:34 am

I have downloaded the 2.5 beta version and wanted to build a tour using VR mode.
The tour works and I can see the WebVR icon on the screen as I have enabled VR mode on desktop, but when I click the VR button I get a white blank screen and not the expected menu to select the HMD options.
The same happens even on the mobile (note 4) using the chrome beta browser!
Any idea what I'm doing wrong?
Here a link to the tour I want to build

User avatar
panoguy
Member
 
Topic author
Posts: 106
Likes: 1 post
Liked in: 0 post
Joined: Mon Jan 25, 2010 3:55 am
Location: Bavaria
Info

Re: After pressing VR Mode button I see only a white screen

by panoguy » Sat Jul 18, 2015 8:29 am

Just found out if I show the maps and press the VR button after (while maps are still on screen) I don't get the white screen!
Very strange behavior, after hiding the maps the VR button shows again the white screen.
And it works just fine if I remove the maps completely from my tour... But I hope you guys will fix it ;-)

User avatar
Cliquetsy
Member
 
Posts: 1312
Likes: 106 posts
Liked in: 119 posts
Joined: Thu May 16, 2013 4:10 pm
Info

Re: After pressing VR Mode button I see only a white screen

by Cliquetsy » Sat Jul 18, 2015 10:10 am

2.5 beta feedback forum is here > viewforum.php?f=117

This post will be moved... sometime, but post future feedback there.

User avatar
panoguy
Member
 
Topic author
Posts: 106
Likes: 1 post
Liked in: 0 post
Joined: Mon Jan 25, 2010 3:55 am
Location: Bavaria
Info

Re: After pressing VR Mode button I see only a white screen

by panoguy » Sat Jul 18, 2015 10:32 am

Thank you, did not see that there is a dedicated forum for 2.5,
For now I have disabled the maps as a workaround but please check if you can reproduce this behavior and get it fixed.

no avatar
Destiny
Moderator
 
Posts: 7886
Likes: 6 posts
Liked in: 228 posts
Joined: Mon Apr 26, 2010 11:55 pm
Info

Re: After pressing VR Mode button I see only a white screen

by Destiny » Sat Jul 18, 2015 10:57 am

I moved your post to the right forum... ;)

Destiny..

Cliquetsy likes this post.

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: After pressing VR Mode button I see only a white screen

by benji33 » Mon Jul 20, 2015 10:06 am

Can't see your VR button to test it ?
Benjamin

User avatar
panoguy
Member
 
Topic author
Posts: 106
Likes: 1 post
Liked in: 0 post
Joined: Mon Jan 25, 2010 3:55 am
Location: Bavaria
Info

Re: After pressing VR Mode button I see only a white screen

by panoguy » Mon Jul 20, 2015 5:19 pm

Hi Benjamin,
sorry I had disabled the VR mode to workaround the problem, please try now, you may need to clear browser cache.

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: After pressing VR Mode button I see only a white screen

by benji33 » Tue Jul 21, 2015 10:41 am

Hi code is encrypted so I cannot have a look, but it seems that the viewer return an error when trying to go to the WebVR mode so the player is never loaded into WebVR mode.

Is it possible to try something ? If yes into the online HTML file replace these lines by the second ones :
Code: Select all
function accessWebVr(){
unloadPlayer();
eventUnloadPlugins();
loadPlayer(true);
}

by
Code: Select all
function accessWebVr(){
eventUnloadPlugins();
unloadPlayer();
loadPlayer(true);
}
Benjamin

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: After pressing VR Mode button I see only a white screen

by benji33 » Tue Jul 21, 2015 11:50 am

EDIT : ok it's an issue when the map is hidden. Once the map is displayed the WebVR button works. I report the issue for correction.
Benjamin


Who is online

Users browsing this forum: No registered users and 1 guest

cron