VR not working on Chrome / Android  

no avatar
urke
Member
 
Topic author
Posts: 83
Likes: 0 post
Liked in: 2 posts
Joined: Tue Nov 06, 2007 1:49 pm
Info

VR not working on Chrome / Android

by urke » Mon Jul 06, 2015 9:22 am

When trying to enter VR mode on Chrome/Android, the screen will flash some other page briefly and then go to a full screen view without VR or flat navigation.

http://bilbao360walk.com/
...and my own test projects.

Chrome is the Android browser recommended by Krpano, so it should be possible to make this work on PTP.

(Samsung S6/Chrome)

no avatar
eredleaf
Member
 
Posts: 16
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 02, 2015 7:35 pm
Info

Re: VR not working on Chrome / Android

by eredleaf » Tue Jul 07, 2015 2:37 am

I am having the same problem. I saw something that said try Chrome beta to fix it (not sure where I saw that). I tried downloading chrome beta, but cannot figure out how to make it the default browser or set panotour viewer to use it. So no success yet.

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: VR not working on Chrome / Android

by bdd » Thu Jul 09, 2015 8:14 am

We checked different tours with Chrome on android, and it worked.
You do not need any beta from chrome, just use the latest version.

Gérald

no avatar
eredleaf
Member
 
Posts: 16
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 02, 2015 7:35 pm
Info

Re: VR not working on Chrome / Android

by eredleaf » Fri Jul 10, 2015 11:08 pm

I thought maybe the problem was that I had the demo version of ptp. So I bought a copy. The watermarks are gone now, but the exact same thing happens when I click the cardboard icon the screen flashes and it changes to a full screen view of the first image in my tour (no matter which image I am on when I click it). It turns gyroscopic control off and all the controls disappear (and there does not appear to be a way to get them back). I am running this on a Samsung Galaxy S6 edge. Android version 5.0.2. The screen does not split into side by side images. If I select to try this on my PC it doesn't work either. The cardboard image appears, but clicking it doesn't do anything. This is true for most of the samples on your website. Clicking the cardboard icon has no impact.

I was thinking perhaps I need some library installed on my PC when it is creating the script. Perhaps some ressource is missing because I haven't developed any cardboard apps. So maybe there is something that is supposed to be in the ptv file that is missing, something the WebVR button adds to the script, but the resource isnt present on my PC?

I really need to get this working, it is part of the proof of concept behind my whole business. Please don't just say it works. It is clearly working for some people, that is why I am asking, what am I doing wrong or what is missing from my system that is making it not work.

no avatar
eredleaf
Member
 
Posts: 16
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 02, 2015 7:35 pm
Info

Re: VR not working on Chrome / Android

by eredleaf » Fri Jul 10, 2015 11:25 pm

could I be running or have the wrong version of krpano embedded? I appear to have krpano 1.18.4-win and krpano 1.19-pr2-win on my system. I see 2 copies of krpanotools32 and krpanotools64 on my system. Also it appears that krpano1.118.4-win was downloaded more recently than version 1.19-pr2. I have almost no knowledge about Javascript, so I am really shooting in the dark regarding trying to figure out way this isn't working. I have tried it with a minimal tour started using the cardboard profile and containing just a single pano with no hotspots. Same result, when I click the cardboard symbol the screen flashes and returns to opening view gyros off and all controls off, a single full screen. I can pan the image by touching the screen, but no other functions are possible.

no avatar
eredleaf
Member
 
Posts: 16
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 02, 2015 7:35 pm
Info

Re: VR not working on Chrome / Android

by eredleaf » Sun Jul 12, 2015 4:31 am

I have more information on the problem. The same tour that locks up the way I previously described on my Samsung Galaxy S6 edge, works differently on my old Samsung Galaxy S4. On the S4 when I press the cardboard button it goes to a new sort of green hued screen with a cardboard button and my presentation is about a 1/4 screen image below it. When I press that cardboard icon my presentation opens with the Web VR settings menu showing. It says device Unknown, and it allow various configurations. However, none of them cause a sde by side image to appear. The gaze function does work for navigating my tour, although it displays a strange phone orientation icon briefly while the next image loads. This was not listed as the loading image. If I gaze while the phone is vertical it shows to transition to horizontal. If the phone is horizontal it shows the transition to vertical. I consider this much closing to operational than it is on my S6, but I still need the side by side display. I tried adding the projections menu thinking that stereoscopic could be needed, but that didn't help.

Now that I see it operating so differently on these two very similar devices, I am more confident that this is an issue with the beta release rather than something I am doing wrong. However, if there is something that I need to load onto my phone that will make it work, I would love to know what it is. I find it troubling that the phone it is working better on is the older model. Can some people who have WebVR working on there devices please post details regarding what android device they are using (and what Android release).

To the Panotour Programmers, do you have any suggestions on what I can do to get this feature operational on my S6 or do I just have to wait for an update to the beta release.

Thanks.

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: VR not working on Chrome / Android

by bdd » Mon Jul 13, 2015 10:13 am

Can you share an URL of a tour you generated ?

We do not have any "Samsung Galaxy S6 edge" but we will try with our "Galaxy Note 4" just to see if we have same issue there.
If we don't we will try to find a Galaxy S6 edge to test your tour.

Gérald

User avatar
klaus/krpano
Moderator
 
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Tue Jun 17, 2008 8:30 pm
Location: Austria
Info

Re: VR not working on Chrome / Android

by klaus/krpano » Mon Jul 13, 2015 10:18 am


no avatar
eredleaf
Member
 
Posts: 16
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 02, 2015 7:35 pm
Info

Re: VR not working on Chrome / Android

by eredleaf » Mon Jul 13, 2015 11:20 pm

For now I have been running the tours out of my local ptv directory on my phone. To share it I made a quick 6 picture tour with each picture having one hotspot linking to sequentially the next picture. I just placed these hotspots to have the function, the links don't really make sense. I made a quick ptv file to share, I put it on my google drive and clicked share to get the link. I have never shared files in google drive before, so hopefully this works. Here is the link:
https://drive.google.com/file/d/0Bxgzid ... sp=sharing

On my S6 when I click the web vr button the image changes to full screen and turns gyroscope and other controls off. Can only pan with finger drag and only function that works is the back key which exits back to the select file point in panotour viewer. On the S4 the vrweb button cause another vr web button to appear with the tour file and a green tint. Clicking that opens the tour with google cardboard crosshairs showing, but not side by side. It is a full screen image. Gyroscopic panning stays on and works fine. The Web VR settings appear, but no matter what I do I cannot get it to have a side by side screen. Also whenever I use gaze to navigate between images while the next image is loading an icon appears that seems to indicate to change my phones orientation. Otherwise I would say it operates as I was expecting on the S4.

I tried the suggesting in the link Klaus provided of enabling the chrome flag to disable blacklisting. That had no impact on the operation of the panotour viewer on either my S4 or my S6.

Note, my phone is a Galaxy 6S edge from verizon. Apparently verizon does not provide the Samsung default internet browser and the sites I have found to get it look pretty scary in turns of downloading stuff from unknown sources and providing root access to the phone.
Can you please list some devices that this definitely works on. Ideally other devices that have a 5 inch screen (approximately). I need to continue development assuming that the issue will be resolved and I need a platform that I can test and demonstrate it on.


Who is online

Users browsing this forum: No registered users and 2 guests