PC- 1.4RC2: Montage etrange avec le sigma 10-20  

Anciennes discussions sur les bug d'autopano
User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

PC- 1.4RC2: Montage etrange avec le sigma 10-20

by yffic » Sun Oct 21, 2007 9:52 am

Bonjour,

J'obtiens un résultat étrange avec la version 1.4 RC2 sur PC (Windows XP).
Voici un assemblage de 15 photos prises avec le Sigma 10-20 à  la focale de 10mm (5 photos brackétées chacune à  3 expositions différentes).
J'obtiens des chevauchements étranges.
Quelqu'un as t'il déjà  observer ce phénomène et as til une idée pour le corriger ?

Merci pour votre aide.

Yves



no avatar
GURL
Member
 
Posts: 2946
Joined: Tue Dec 06, 2005 1:57 pm
Location: Grenoble

by GURL » Mon Oct 22, 2007 9:09 pm

Sur la capture d'écran il est un peu difficile de lire les indications (la focale dans la colonne de gauche, FOV et RMS dans la colonne de droite) et surtout de juger s'il y a suffisamment de détails sur les photos pour qu'APP puisse y placer des points de contrôle. Il est probable qu'APP a eu tellement de difficultés avec certaines photos que le résultat est "un peu n'importe quoi" :) malheureusement il ne sait pas encore dire "c'est trop dur pour moi, j'y arrive pas!"

Autre hypothèse: de grosses erreurs de parallaxe sur le quai si tu n'as pas utilisé une tête panoramique.

Suggestions:
- mettre la qualité au maximum dans l'onglet détection
- faire un essai en enlevant les photos les plus sombres
- en cliquant sur l'icone éditeur de points de contrôle tu devrais pouvoir voir ce qui se passe et repérer les photos qui sèment la panique
Last edited by GURL on Mon Oct 22, 2007 9:25 pm, edited 1 time in total.
Georges

no avatar
beeloba
Member
 
Posts: 1930
Joined: Fri Aug 18, 2006 10:51 pm

by beeloba » Mon Oct 22, 2007 9:56 pm

Bonsoir Yves…
Cette focale de 10 mm, n'est pas prise par défaut pour un fisheye ?
Quels essais précédents as tu déjà  fais avec d'autres versions d'APP et la même optique ?
Last edited by beeloba on Mon Oct 22, 2007 9:56 pm, edited 1 time in total.

User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

by yffic » Mon Oct 22, 2007 9:59 pm

Merci pour vos réponses.

Le 10mm a bien été pris comme une optique standard.
J'ai utilisé ma NN3 donc à  priori pas d'erreur de paralaxe (du moins pas gravissime).
Ce qui m'etonnes le plus c'est que si je sépares les 3 series de 5 photos (pour les 3 expositions différentes) là  APP s'en sors bien....
J'avais déjà  eu ce type de souci sur des versions précedentes mais c'est malgré tout un phénomène assez rare..

Yves

no avatar
beeloba
Member
 
Posts: 1930
Joined: Fri Aug 18, 2006 10:51 pm

by beeloba » Mon Oct 22, 2007 10:04 pm

Attends, l'ami, tu es sur une version bêta, pas finie, déjà  que le fisheye et ses défauts de distorsion soient réglés…
Pour le HDR ou l'exposition multiple, on y est pas encore… Alex est en train de fixer un bug qui ne prends pas les rms au dessous de 2.0…
A mon avis, dès que la version stable de la 1.4 sera sortie, documentée, traduite… Là  il y aura la phase suivante concernant le HDR. IMHO :)

User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

by yffic » Mon Oct 22, 2007 10:12 pm

Ne t'inquiètes pas.. mon message n'est pas pour reclamer quoi que ce soit mais pour faire remonter des comportements etonnants qui pourraient permettre à  Alexandre d'améliorer son produit... ;);)

User avatar
AlexandreJ
Kolor Team
 
Posts: 5920
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Tue Oct 23, 2007 7:14 am

Ce comportement bizarre vient de l'optimisation de la distortion des lentilles. Les causes peuvent être multiples :
- Points de contrôle non répartis uniformément ou bien trop centrée au milieu ( ajouter des points dans un angle d'image peut suffire )
- Gros problème de parallaxe dans un coin : et oui, s'il y a des points là -bas et qu'un problème de parallaxe contredit les points du centre de l'image, ce problème peut arriver.

User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

by yffic » Tue Oct 23, 2007 10:50 am

AlexandreJ wrote:Ce comportement bizarre vient de l'optimisation de la distortion des lentilles. Les causes peuvent être multiples :
- Points de contrôle non répartis uniformément ou bien trop centrée au milieu ( ajouter des points dans un angle d'image peut suffire )
- Gros problème de parallaxe dans un coin : et oui, s'il y a des points là -bas et qu'un problème de parallaxe contredit les points du centre de l'image, ce problème peut arriver.

Dois-je en déduire que si je décoches l'optimisation de la distortion des lentilles cela devrait aller mieux ?
Merci.

Yves

User avatar
AlexandreJ
Kolor Team
 
Posts: 5920
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Tue Oct 23, 2007 11:08 am

Oui, si tu décoches l'optimisation des lentilles, y-aura pas de soucis. Mais souvent il suffit de mettre des points de controle dans un coin ( ou s'assurer qu'il en existe sur toute la hauteur d'une zone de couvrement ) pour que cela marche.

User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

by yffic » Tue Oct 23, 2007 12:48 pm

AlexandreJ wrote:Oui, si tu décoches l'optimisation des lentilles, y-aura pas de soucis. Mais souvent il suffit de mettre des points de controle dans un coin ( ou s'assurer qu'il en existe sur toute la hauteur d'une zone de couvrement ) pour que cela marche.

Merci j'essaierai ce soir et vous tiendrai au courant.

User avatar
yffic
Member
 
Posts: 218
Joined: Tue Apr 25, 2006 8:54 am
Location: Paris

by yffic » Tue Oct 23, 2007 5:30 pm

Bingo.

Cela marches en decochant la correction de la distortion.
Merci pour votre aide.

Yves


Return to Archives fr

Who is online

Users browsing this forum: No registered users and 2 guests