Report de bug de la version linux d'autopano, pour les francophones  

Anciennes discussions sur les bug d'autopano
no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

Report de bug de la version linux d'autopano, pour les francophones

by l_archi » Wed Dec 20, 2006 7:39 pm

* L'enregistrement tiens pas, necessite de remettre le code à  chaque fois (beta1)

* Les crashs :

845 cameras in database
autopanopro32: AutoPanoKernel/Sift/LoweSift.cpp:1248: void LoweSift::PlaceInIndex(float, float, float, float): l'assertion « ri >= -1 && ri < 3 && ci >= -1 && ci < 3 && oval >= 0 && oi <= 4 && rfrac >= 0.0 && rfrac <= 1.0 » a échoué.
/usr/local/bin/autopanopro32: line 5: 15805 Abandon /usr/local/autopanopro32/autopanopro32 $@

* Les sorties de la console :

X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x0
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x0
X Error: BadRequest (invalid request code or no such operation) 1

* Sur une recherche d'images dans un répertoire

Xlib: unexpected async reply (sequence 0x452a)!


* Affichage de la zone de boulot.. perdue.. où qu'elle est ?? !

* Sur une recherche d'images :

/usr/local/bin/autopanopro32: line 5: 16866 Erreur de segmentation /usr/local/autopanopro32/autopanopro32 $@

Sans finir
Last edited by l_archi on Wed Dec 20, 2006 8:16 pm, edited 1 time in total.

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Wed Dec 20, 2006 9:05 pm

Pour aider :

[pid 19936] open("/CHEMINDESPHOTOS/IMG_3751.JPG", O_RDONLY) = 11
[pid 19936] fstat64(11, {st_mode=S_IFREG|0700, st_size=4841152, ...}) = 0
[pid 19936] mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb64d0000
[pid 19936] _llseek(11, 0, [0], SEEK_SET) = 0
[pid 19936] read(11, <unfinished ...>
[pid 19931] <... write resumed> ) = 92
[pid 19931] read(7, "\1\1\325E\0\0\0\0\0\0\0\0\240\0\324\0\314\17\0\0\0\0\0"..., 32) = 32
[pid 19931] ioctl(7, FIONREAD, [7808]) = 0
[pid 19931] read(7, "\0\1\327EY\1\200\1\0\0\0\0\10\0\0\0\270\365\240\17\10\0"..., 2048) = 2048
[pid 19931] open("/usr/share/X11/XErrorDB", O_RDONLY) = 12
[pid 19931] fstat64(12, {st_mode=S_IFREG|0644, st_size=37949, ...}) = 0
[pid 19931] read(12, "! $Xorg: XErrorDB,v 1.3 2000/08/"..., 37949) = 37949
[pid 19931] close(12)

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Wed Dec 20, 2006 9:12 pm

François semble avoir trouvé une piste avec les librairies QT

sous debian unstable, lancer l'appli via :

/usr/local/autopanopro32/autopanopro32

Améliorer la stabilité

User avatar
francois.simond
Member
 
Posts: 122
Joined: Fri Dec 02, 2005 4:32 pm
Location: France, Chambéry

by francois.simond » Wed Dec 20, 2006 9:18 pm

oui, quand on lance directement le binaire, APP charge le qt 4 du système, et sous ta debian unstable ce qt là  semble mieux convenir à  ton serveur X (car il a été compilé avec ses headers?)

Toutefois, n'importe quel lib Qt doit être capable d'afficher sur n'importe quel serveur X.. ça n'explique pas vraiment.
François Simond

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Thu Dec 21, 2006 10:00 am

"Xlib: unexpected async reply (sequence 0x452a)!"

Il me semble qu'on a ce genre d'erreur lorsque 2 évènements surviennent en même temps ; la librairie X11 n'est pas thread-safe ; il faut donc mettre les évènements en queue, et ne les traiter que dans le thread principal (ou du moins, dans un seul thread).
Last edited by fma38 on Thu Dec 21, 2006 10:48 am, edited 1 time in total.
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

no avatar
byrad
Member
 
Posts: 14
Joined: Thu Jan 26, 2006 8:08 pm

by byrad » Thu Dec 21, 2006 7:11 pm

Même Crash avec autopanopro32 ou :
$ /usr/local/autopanopro32/autopanopro32
Object::connect: No such slot AutopanoApp::activateMainWidget()
Object::connect: (sender name: 'autopanopro32')
Object::connect: (receiver name: 'autopanopro32')
845 cameras in database
autopanopro32: AutoPanoKernel/Sift/LoweSift.cpp:1248: void LoweSift::PlaceInIndex(float, float, float, float): l'assertion « ri >= -1 && ri < 3 && ci >= -1 && ci < 3 && oval >= 0 && oi <= 4 && rfrac >= 0.0 && rfrac <= 1.0 » a échoué.
Abandon

no avatar
jpok
New member
 
Posts: 3
Joined: Sun May 07, 2006 12:29 pm

by jpok » Wed Dec 27, 2006 12:08 am

Même crash que byrad... pendant la détection sift :
autopanopro32: AutoPanoKernel/Sift/LoweSift.cpp:1248: void LoweSift::PlaceInIndex(float, float, float, float): l'assertion « ri >= -1 && ri < 3 && ci >= -1 && ci < 3 && oval >= 0 && oi <= 4 && rfrac >= 0.0 && rfrac <= 1.0 » a échoué.
Aborted (core dumped)
Résultat : Autopano a été proprement et immédiatement éjecté du système, sans autre avertissement !
Last edited by jpok on Wed Dec 27, 2006 12:10 am, edited 1 time in total.

no avatar
Gras_du_Bide
New member
 
Posts: 1
Joined: Sun Jan 07, 2007 2:34 pm

by Gras_du_Bide » Sun Jan 07, 2007 2:38 pm

Pas de problème pour l'instant de mon côté (Ubuntu 6.10), malgré ces quelques erreurs:

~$ autopanopro32
X Error: BadDevice, invalid or uninitialized input device 169
Extension: 147 (XInputExtension)
Minor opcode: 3 (X_OpenDevice)
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
Extension: 147 (XInputExtension)
Minor opcode: 3 (X_OpenDevice)
Resource id: 0x0
Failed to open device
QLayout::addChildWidget: QToolButton "" in wrong parent; moved to correct parent
Object::connect: No such slot AutopanoApp::activateMainWidget()
Object::connect: (sender name: 'autopanopro32')
Object::connect: (receiver name: 'autopanopro32')

Je suis en train de calculer le rendu d'un pano de 11 photos... il est fini et parfait!

Je profite de ce premier message pour remercier l'auteur pour ce portage sous linux (la version win par wine est beaucoup plus lente que cette beta 1)

GdB

EDIT: Le bouton "CROP" n'a pas d'icone
Last edited by Gras_du_Bide on Sun Jan 07, 2007 2:42 pm, edited 1 time in total.

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Fri Jan 12, 2007 8:48 pm

AlexandreJ wrote:Let's release a new beta for linux users.

Nothing really fancy, but better overall integration into linux OS :
- stabilization,
- deb package.

http://en.wiki.autopano.net/Lastest_Beta

Je vais rapidement tester cette deuxième mouture, car j'ai des crashs systématiques sur quelques panos...
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Fri Jan 12, 2007 10:44 pm

Mince, je viens de remarquer un truc bizarre...

Comme la beta 2 crash de la même façon, j'ai voulu lancer APP depuis une console, pour voir s'il y avait un message quelconque : et bien dans ce cas, il ne plante pas ! J'ai refais le test sur les 3 séries : ça plante si APP est lancé par KDE via le menu, et ça ne plante pas s'il est lancé depuis une console.

à‡a doit pouvoir guider dans le débuggage...

à€ noter qu'à  chaque fois, ça plante sur les jpeg, mais pas sur les raw (même photos, prises en jpeg+raw).

Par contre, sur ma debian etch, je n'ai aucun message d'erreur au lancement depuis la console (X ou autre).
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Fri Jan 12, 2007 10:52 pm

Pas banal ça : en fait, dans le test ci-dessus, je lançais APP depuis la console en appelant 'autopanopro'. Mais si je fais comme les copains, et que je le lance par 'autopanopro32', là  j'ai aussi le crash. Après vérification, le menu appelle autopanopro32.

Moralité : ça marche nickel en appelant 'autopanopro', et ça plante en appelante 'autopanopro32'. En regardant ces scripts, je m'aperçois qu'ils ne lancent pas le même binaire ; kesako ?

C'est un peu différent de ce qui est décrit ci-dessus, à  propos des librairies Qt, puisqu'ici, je passe par les scripts, donc dans les 2 cas, j'ai un 'export LD_LIBRARY_PATH=/usr/lib/autopanopro'.
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Sat Jan 13, 2007 12:06 am

l'ancien paquet est encore là .. le nouveau paquet ne supprime pas l'ancien. C'est un bug

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Sat Jan 13, 2007 8:22 am

fma38 : C'est super important de lancer autopano de la bonne façon sinon, le soft n'est lié aux bonnes librairies QT et ca crashe. Nous avons patché Qt fourni avec notre soft ce qui n'est pas le cas si tu lances app autrement : il resoud les dépendances en prenant qt existant dans le système ( qt3.3 si t'as pas de chances, qt4.1 si tu as, et presque sure que c'est pas la bonne version ).

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Sat Jan 13, 2007 9:57 am

Oui, j'ai bien compris ça, mais les 2 scripts exportent LD_LIBRARY_PATH de la même façon ; ce n'est pas ça qui conditionne le chargement de tes librairies ? Quelle est la différence entre les binaires /usr/lib/autopanopro/autopanopro et /usr/local/autopanopro32/autopanopro32 ? Le premier fonctionne bien, le second pas (tous deux lancés via leur script respectif).

De plus, le plantage survient dans la détection Sift ; c'est quand même lié aux librairies Qt ?
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Sat Jan 13, 2007 11:31 am

Y-a pas une ancienne version qui reste ? ( Dans la beta 2, on a corrigé ce bug de SIFT qui n'existait que dans la beta 1).

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Sat Jan 13, 2007 1:07 pm

Quelques bug avant crash :

Xlib: sequence lost (0x40202 > 0x3e419) in reply type 0x2!
Xlib: sequence lost (0x41914 > 0x3e419) in reply type 0x14!
Xlib: sequence lost (0x4ff27 > 0x3e419) in reply type 0xa1!
Xlib: sequence lost (0x4ff20 > 0x3e419) in reply type 0x82!
Xlib: sequence lost (0x41b15 > 0x3e419) in reply type 0x15!
Xlib: sequence lost (0x40504 > 0x3e419) in reply type 0x4!
Xlib: sequence lost (0x40202 > 0x3e419) in reply type 0x2!
Xlib: sequence lost (0x40000 > 0x3e419) in reply type 0x0!
X Error: 0 0
Major opcode: 33 (X_GrabKey)
Resource id: 0x7060606
X Error: 0 0
Major opcode: 2 (X_ChangeWindowAttributes)
Resource id: 0x0
X Error: 0 0
Major opcode: 0 ()
Resource id: 0x0
X Error: 0 0
Major opcode: 0 ()
Resource id: 0x0
Xlib: sequence lost (0x40302 > 0x3e419) in reply type 0x2!
/usr/bin/autopanopro: line 4: 19503 Erreur de segmentation /usr/lib/autopanopro/autopanopro $@


Sur un usage "normal"

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Sat Jan 13, 2007 1:12 pm

A l'ouverture d'un dossier sur un bout de NTFS .. lecture en readonly

Je lance la detection et j'ai un :

autopanopro: Fatal IO error: client killed

Comportement aléatoire.. ça ne se produit pas.. sur 10 essais d'affilé


* plus d'affichage dans la fenetre :

Lors d'une detection de quelques photos, elle deviens grise et ne réponds plus.
Problème de priorités ? Qt n'a plus le temps d'écrire l'affichage ?


* feature request :

dans konqueror, je fais "copier" et j'ai le nom du chemin

exemple : file:///mnt/disque/photos

ce serait pas mal.. que APP support ces noms là 


* Lors d'un rendu :

/home/alex/Desktop - /home/alex/Desktop
Xlib: unexpected async reply (sequence 0x1dd72)!
Xlib: unexpected async reply (sequence 0x1dd73)!
Xlib: unexpected async reply (sequence 0x24923)!
Xlib: unexpected async reply (sequence 0x24a90)!
autopanopro: Fatal IO error: client killed
*** glibc detected *** free(): invalid pointer: 0x086e1e80 ***
/usr/bin/autopanopro: line 4: 20616 Abandon /usr/lib/autopanopro/autopanopro $@


Mais je pense avoir consommé toute la mémoire vive dispo sur ma machine.. j'avais une fenetre de konqueror en train de faire du thumbnail de mon répertoire panorama renuds

* Premiere image jointe : un moment ou je perds l'affichage


Last edited by l_archi on Sat Jan 13, 2007 1:29 pm, edited 1 time in total.

User avatar
fma38
Member
 
Posts: 5826
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Sat Jan 13, 2007 6:22 pm

AlexandreJ wrote:Y-a pas une ancienne version qui reste ? ( Dans la beta 2, on a corrigé ce bug de SIFT qui n'existait que dans la beta 1).

Je viens de vérifier : y'avait un gros mic-mac, car le nom du paquet ayant changé, il n'avait pas fait une mise à  jour, mais installé le nouveau. Et comme ce dernier s'installe maintenant dans l'arborescence normale, et non dans /usr/local, ce qui est mieux, ben, oui, il y avait les 2 !

Je n'ai plus les plantages, maintenant :)
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Sun Jan 14, 2007 12:43 pm

J'ai cherché un bout de temps.

Mon pilote proprio NVIDIA.. semblait avoir perdu les extensions glx (accelération tout ça)

Et maintenant tout semble très stable

no avatar
mike
Member
 
Posts: 34
Joined: Wed Oct 25, 2006 11:06 am

by mike » Tue Jan 16, 2007 4:37 pm

Bonjour

Je viens de tester la nouvelle version beta2 et j'ai trouvé deux bugs.
- chez moi il plante systematiquement quand je veux ouvrir un repertoire pour charger des photos, si je clique sur la case avec ... pour parcourir les dossier du disque, il plante:
/usr/bin/autopanopro: line 4: 6927 Erreur de segmentation /usr/lib/autopanopro/autopanopro $@
si j'ecris l'emplacement a la main, ca fonctionne.

- Non spécifique a la beta2, mais il ne sait plus lire les fichiers raw de mon boitier (Minolta 5d) extension .mrw

User avatar
AlexandreJ
Kolor Team
 
Posts: 5911
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Tue Jan 16, 2007 4:49 pm

mike wrote:- Non spécifique a la beta2, mais il ne sait plus lire les fichiers raw de mon boitier (Minolta 5d) extension .mrw

Pourrais-tu nous fournir un exemple de ce type de fichier ?

no avatar
mike
Member
 
Posts: 34
Joined: Wed Oct 25, 2006 11:06 am

by mike » Tue Jan 16, 2007 6:18 pm

AlexandreJ wrote:Pourrais-tu nous fournir un exemple de ce type de fichier ?

aucun soucis. Je viens de mettre deux fichiers sur le ftp:
pict4308.jpg
pict4308.mrw

no avatar
l_archi
Member
 
Posts: 162
Joined: Fri Dec 02, 2005 9:05 pm

by l_archi » Wed Jan 31, 2007 12:06 pm

Pendant un usage normal :

Xlib: sequence lost (0x19ffc5 > 0x189af4) in reply type 0x91!
Xlib: sequence lost (0x19ff17 > 0x189af4) in reply type 0x1b!
Xlib: sequence lost (0x19ff5e > 0x189af4) in reply type 0x96!
Xlib: sequence lost (0x19ff51 > 0x189af4) in reply type 0x13!
Xlib: sequence lost (0x19ff60 > 0x189af4) in reply type 0x16!
Xlib: sequence lost (0x19ff5a > 0x189af4) in reply type 0x13!
Xlib: sequence lost (0x19ff22 > 0x189af4) in reply type 0x1a!
Xlib: sequence lost (0x19ff00 > 0x189af4) in reply type 0x1a!
Xlib: sequence lost (0x19ff0a > 0x189af4) in reply type 0xa!
autopanopro: Fatal IO error: client killed
/usr/bin/autopanopro: line 4: 15350 Erreur de segmentation /usr/lib/autopanopro/autopanopro $@


si ça peut aider :

debian unstable :

$ dpkg -l |grep libqt
ii libqt3-compat-headers 3.3.7-3 Qt 1.x and 2.x compatibility includes
ii libqt3-headers 3.3.7-3 Qt3 header files
ii libqt3-mt 3.3.7-3 Qt GUI Library (Threaded runtime version), V
ii libqt3c102 3.3.4-3 Qt GUI Library, Version 3
ic libqt3c102-mt 3.3.4-3 Qt GUI Library (Threaded runtime version), V
ii libqt4-core 4.2.1-2 Qt 4 core non-GUI functionality runtime libr
ii libqt4-gui 4.2.1-2 Qt 4 core GUI functionality runtime library
ii libqthreads-12 1.6.8-6 QuickThreads library for Guile
Last edited by l_archi on Wed Jan 31, 2007 12:21 pm, edited 1 time in total.

no avatar
byrad
Member
 
Posts: 14
Joined: Thu Jan 26, 2006 8:08 pm

by byrad » Wed Feb 07, 2007 9:37 am

Bonjour,
Sur une debian sid avec la beta1 purgée, beaucoup de plantages de ce genre :
$ autopanopro
845 cameras in database
X Error: BadLength (poly request too large or internal Xlib length error) 16
Major opcode: 82 (X_UninstallColormap)
Resource id: 0x2a03f75
X Error: BadLength (poly request too large or internal Xlib length error) 16
Major opcode: 43 (X_GetInputFocus)
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Extension: 129 (Uknown extension)
Minor opcode: 133 (Unknown request)
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x2a03f75
X Error: BadLength (poly request too large or internal Xlib length error) 16
Major opcode: 32 (X_UngrabKeyboard)
Resource id: 0x2a03f75
X Error: BadLength (poly request too large or internal Xlib length error) 16
Major opcode: 78 (X_CreateColormap)
Resource id: 0x2a03f75
autopanopro: Fatal IO error: client killed
autopanopro: Fatal IO error: client killed
/usr/bin/autopanopro: line 4: 11564 Erreur de segmentation /usr/lib/autopanopro/autopanopro $@

Les killed sont du à  un xkill pour tuer autopano

no avatar
byrad
Member
 
Posts: 14
Joined: Thu Jan 26, 2006 8:08 pm

by byrad » Sat Feb 10, 2007 4:06 pm

Toujours avec la beta2 :

X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x1e3e696
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x1e3e696
X Error: BadRequest (invalid request code or no such operation) 1
Major opcode: 0 ()
Resource id: 0x1e3e696
Xlib: sequence lost (0x180023 > 0x180020) in reply type 0x1!
Xlib: unexpected async reply (sequence 0x1782fd)!
Xlib: unexpected async reply (sequence 0x1782fe)!
Xlib: unexpected async reply (sequence 0x17babb)!
Xlib: unexpected async reply (sequence 0x17babc)!
/home/yvan/Photos/Panorama - /home/yvan/Photos/Panorama
Xlib: unexpected async reply (sequence 0x18e709)!
Xlib: unexpected async reply (sequence 0x18e8bd)!
Xlib: unexpected async reply (sequence 0x1bf569)!
/usr/bin/autopanopro: line 4: 946 Processus arrêté /usr/lib/autopanopro/autopanopro $@

Next

Return to Archives fr

Who is online

Users browsing this forum: No registered users and 1 guest