Livepano issues: video replay and mobile  

Have a problem using Livepano? Have you encountered a bug that needs fixing? Please post it here.
Des difficultés à utiliser Livepano ? Avez-vous découvert un bug qui doit être fixé ? Postez les ici.
no avatar
urke
Member
 
Topic author
Posts: 83
Likes: 0 post
Liked in: 2 posts
Joined: Tue Nov 06, 2007 1:49 pm
Info

Livepano issues: video replay and mobile

by urke » Wed Nov 27, 2013 10:15 am

I am having two issues with Livepano and PTP 2.0 beta 4:

1) After the video has finished playing, there is no active link on the subject - allowing the video to play again. This is done right in the Chadian Tea Shop tour, but I am not able to recreate it. What should I do to fix this?

2) The mobile integration is poor. The masking doesn't exist (guess this is a HTML restriction), but also there is a black line on the edge of the video and a clearly visible mismatch between the video area and the surroundings. This is also present on the Tea tour. Is there anything I can to to minimize the effect of this, and are there new versions of Livepano on its way to fix some of this issues?
Attachments
teatour.png
Black line and mismatch on the Tea Tour. (iPad Mini R.)

no avatar
urke
Member
 
Topic author
Posts: 83
Likes: 0 post
Liked in: 2 posts
Joined: Tue Nov 06, 2007 1:49 pm
Info

Re: Livepano issues: video replay and mobile

by urke » Thu Nov 28, 2013 9:13 am

Another mobile issue with Livepano:

It does play on iOS iPad (mini retina), but not properly on iPhone (5s). On iPhone, it just shows an play-icon, and when pressed it plays the video in a separate player - sideways...

Any ideas on this and the previous issues will be highly appreciated, as I am working on my project right now.

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Livepano issues: video replay and mobile

by bdd » Mon Dec 02, 2013 8:54 am

urke wrote:I am having two issues with Livepano and PTP 2.0 beta 4:

1) After the video has finished playing, there is no active link on the subject - allowing the video to play again. This is done right in the Chadian Tea Shop tour, but I am not able to recreate it. What should I do to fix this?

2) The mobile integration is poor. The masking doesn't exist (guess this is a HTML restriction), but also there is a black line on the edge of the video and a clearly visible mismatch between the video area and the surroundings. This is also present on the Tea tour. Is there anything I can to to minimize the effect of this, and are there new versions of Livepano on its way to fix some of this issues?


You'll find in this other thread, the code that was used in the cha dian tea shop tour :
viewtopic.php?f=65&t=20453&p=130993&hilit=cha+dian#p130993

There is no easy way yet to minimize the black line.
This line appears when the size (width or height) of the video does not have a ratio adapted to the mobile device.
On desktop, the videoplayer accepts any size, on mobile it does not.
So the only way, until we found a better algorithm to build the video, is to re-create a livepano, with a different crop.

Gérald

no avatar
urke
Member
 
Topic author
Posts: 83
Likes: 0 post
Liked in: 2 posts
Joined: Tue Nov 06, 2007 1:49 pm
Info

Re: Livepano issues: video replay and mobile

by urke » Mon Dec 02, 2013 6:30 pm

bdd wrote:
You'll find in this other thread, the code that was used in the cha dian tea shop tour :
viewtopic.php?f=65&t=20453&p=130993&hilit=cha+dian#p130993

There is no easy way yet to minimize the black line.
This line appears when the size (width or height) of the video does not have a ratio adapted to the mobile device.
On desktop, the videoplayer accepts any size, on mobile it does not.
So the only way, until we found a better algorithm to build the video, is to re-create a livepano, with a different crop.

Gérald


Thanks. How do I know which crop to use?

And more importantly:
Is there a solution for the video playing sideways and separate from the tour on iPhone, but working fine on iPad? (post #2 above)

no avatar
studiostefan
Member
 
Posts: 12
Likes: 0 post
Liked in: 0 post
Joined: Mon Jan 09, 2012 12:12 pm
Info

Re: Livepano issues: video replay and mobile

by studiostefan » Mon Dec 02, 2013 8:36 pm

Hi urke and bbd.

I tried to follow the link:
[url]viewtopic.php?f=65&t=20453&p=130993&hilit=cha+dian#p130993[/url]
, but the computer says no. Is there any particular reason that I can't access that part of the forum? I get this message: You are not authorised to read this forum.

Thanks!


Who is online

Users browsing this forum: No registered users and 1 guest

cron