Image-stitching and virtual tour solutions My account Updates
It is currently Sat Aug 23, 2014 8:37 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Mar 14, 2011 9:13 pm 
Offline
Member

Joined: Mon Mar 20, 2006 5:47 pm
Posts: 360
Location: Brest
Bonjour,

Les 2 problèmes cités dans le titre sont très certainement liés :
- Non prise en compte d'une image ajoutée après détection d'un groupe.
- Plantage d'APG. (Utilisation CPU au taquet.)

Utilisation GPU désactivée.
Nb de processeurs : Multicore (2)

Je charge 8 images fisheye (2 zenith + 6 à  0°) dans un projet et règle "Type de lentille" sur "Fish eye".
La détection se passe sans problèmes.
Un petit réglage du point de fuite et horizon automatique.
Image

Dans les calques, ajout d'une image (Nadir) avec le bouton "Ajouter une image"
(Image (9))
Image

La focale est reconnue correctement (16.27mm) mais sans points de contrôle et positionnée comme une image Zenith.
Image

Depuis la fenêtre d'édition des points de contrôles,
- Ajout de points par analyse géométrique- Optimiser le panorama
permet de lier l'image aux autres avec un RMS.
Image

Un retour sur l'éditeur de panorama montre que l'image (9) ajoutée dernièrement :
- n'est plus reconnu dans les calques (focale !!!)
Image

- n'est pas positionnée comme un image nadir dans l'aperçu.
Image

Après fermeture de la fenêtre des points de contrôle,
après sélection du "Mode de déplacement des images" et "Déplacement image"
après appui sur l'image 9 dans la fenêtre d'édition
Image

c'est l'emballement de l'utilisation d'un CPU (100%)
Image

L'utilisation mémoire d'APG reste aux alentours de 30Mo.
APG reste figé et ne réponds plus. (Même après plusieurs dizaines de minutes....)

Le fait de mettre fin au processus AFG libère immédiatement l'utilisation du CPU.
Image


Last edited by kalain on Mon Mar 14, 2011 9:16 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 15, 2011 11:04 am 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5894
Location: Francin, France
Issue 616 opened


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 04, 2011 9:09 am 
Offline
Member

Joined: Mon Mar 20, 2006 5:47 pm
Posts: 360
Location: Brest
La version 2.5.1 a résolu le pb de l'emballement du CPU mais l'image nadir rajoutée après coup n'est toujours pas positionnée correctement.
La focale estimée reste aussi sur inf(ini?)


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 04, 2011 10:51 am 
Offline
Member

Joined: Tue Dec 06, 2005 1:57 pm
Posts: 2946
Location: Grenoble
kalain wrote:
Je charge 8 images fisheye (2 zenith + 6 à  0°) dans un projet et règle "Type de lentille" sur "Fish eye".

l'image nadir rajoutée après coup n'est toujours pas positionnée correctement.
La focale estimée reste aussi sur inf(ini?)

Quand on ajoute une image fisheye dans ces conditions, non seulement elle n'est pas reconnue automatiquement comme étant fisheye (logique) mais en plus "c'est pas facile" de la faire prendre en compte comme fisheye (voir capture d'écran).

Je dis "c'est pas facile" parce qu'hiers j'ai merdé un long moment avant d'y arriver sans pouvoir dire si c'était de ma faute, de celle d'Autopano ou des deux: je viens de ré-essayer et à  mon avis le fait que l'image (elle s'appelle Zenith) s'affiche comme une image fisheye alors que dans les propriétés elle est marquée standard est un bug.

Je suis arrivé à  la positionner correctement mais ça n'a pas été facile non plus, ce qui a marché c'est de créer un seul lien (avec l'image la plus propice) et de n'optimiser que l'image ajoutée (selectionner cette image et seulement celle là  puis clic droit et choix "optimiser une seule image".)

Remarque qui me semble importante:

le fait d'optimiser d'abord les rangés de photos sans zénith et/ou nadir puis d'ajouter seulement après le zénith et/ou le nadir n'est pas une idée farfelue. Si ça marchait bien (ce qui n'a jamais été le cas jusqu'ici) ça permettrait probablement de résoudre plusieurs des problèmes auxquels on se heurte régulièrement quand on assemble des panos 360 x 180 avec Autopano (fisheye ou ultra-grand-angulaire.)



_________________
Georges


Last edited by GURL on Mon Apr 04, 2011 11:09 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 24, 2011 4:11 pm 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5894
Location: Francin, France
fixed in next release


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group