Search found 44 matches

Return to advanced search

Re: Papywizard >>> Image number

your code looks very different from mine - a lot more condensed with attributes stacked instead of explicitly stated separately. Could be that the generator you used DOES work for controlling the head, but isn't actually a supported syntax for APG?
by mattspace
Sat Jul 14, 2018 12:48 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Papywizard >>> Image number
Replies: 5
Views: 1560

Re: Papywizard >>> Image number

I've never controlled a robot pano head with it, but this gets the correct arrangement etc in APG for a 60mm 7 rows of 20, plus nadir & zenith shoot. Edit it to suit your lens, number of images etc. <?xml version="1.0" encoding="utf-8"?> <papywizard version="a"> <he...
by mattspace
Thu Jul 12, 2018 9:00 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Papywizard >>> Image number
Replies: 5
Views: 1560

AP on Mac, Post-OpenGL?

So, an existential question about AP's future and the Mac... what happens when OpenGL is gone in the release after Mojave?

Anyone in development able to comment on *if* there's a plan, and what sort of direction it might be?
by mattspace
Thu Jul 12, 2018 2:26 am
 
Forum: Autopano Future
Topic: AP on Mac, Post-OpenGL?
Replies: 0
Views: 1013

Re: Crazy colour in older files

it's a compatibility issue, insofar as I have to remove all the colour anchors from old files, and reapply them, in order to bring them to the new version of APG - isn't that the very definition of an incompatibility? the new version can't correctly read the data in the old files. It's the same comp...
by mattspace
Fri Mar 09, 2018 4:08 pm
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: Crazy colour in older files

Here's attempting to detect and and create a pano with the same source files in 4.2, & 4.4.1:

Image

And here's opening the 4.2 saved file in 4.4.1

Image
by mattspace
Mon Mar 05, 2018 4:04 pm
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: Crazy colour in older files

remaking the pano afresh in the new version of APG the problem doesn't occur - it seems to be isolated to the colour corrections that are put in with pre-4.2 APG files, when you attempt to bring those files forward to a new version. Makes me think there's something in the .pano file that's not prope...
by mattspace
Fri Mar 02, 2018 2:44 pm
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: Crazy colour in older files

Disabling GPU rendering in APG 4.4.1 doesn't have any effect. Disabling it in 4.2.3 makes matters worse: https://www.mattgodden.com/files/apg_bleh.png If you download this zip file what should happen is opening the file in: 4.0 - everything ok. 4.2.3 - green with GPU on, black with GPU off 4.4.1 - g...
by mattspace
Fri Mar 02, 2018 4:31 am
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: Crazy colour in older files

the problem shouldn't be related to my files, given it effects both RAWs and TIFFs, unless it's related to the dimensions (36mp). the workaround seems to be to edit the APG file, and remove all the colour correction, then reapply it - which takes AAAAAGES (15-20 minutes), even longer when the files ...
by mattspace
Thu Mar 01, 2018 12:10 pm
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: Crazy colour in older files

third screenshot, read aloud what is written in the title bar.
by mattspace
Sat Feb 24, 2018 5:00 am
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Crazy colour in older files

Hi, I'm finding that all my files created in versions upto and including 4.0.2 are unable to be used in subsequent versions. The colours are all over the place in the render preview, although the thumbnails / individual images all look OK. The colour problems show up in the render as well: http://ww...
by mattspace
Thu Feb 22, 2018 4:44 pm
 
Forum: Autopano - Bugs & discussion
Topic: Crazy colour in older files
Replies: 12
Views: 2898

Re: APG 4.4: Mac WIFI Scanning bug still present.

So this problem is still occurring in APG 4.4.1 on macOS Sierra.

I'd appreciate some followup as to why this is happening.
by mattspace
Mon Nov 06, 2017 10:45 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.4: Mac WIFI Scanning bug still present.
Replies: 6
Views: 1448

Re: Papywizard >>> What was wrong

I think you export it from a completed pano. Personally, I think ive only ever done it once, just to get the sample code, and from then on, I've just written the xml by hand.
by mattspace
Mon May 01, 2017 4:00 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Papywizard >>> What was wrong
Replies: 7
Views: 1192

Re: Papywizard >>> What was wrong

Someone feel free to correct me, but the xml file looks like it's showing: Zenith 2 rows down 1 row down 1 row up 2 rows up Nadir I suspect those down and up rows being backwards may be a problem. The structure of papywizard files might have changed, but here's the xml I use for 7 rows with a 60mm l...
by mattspace
Mon May 01, 2017 6:05 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Papywizard >>> What was wrong
Replies: 7
Views: 1192

Measuring APG's OpenGL / GPU utilisation.

Hi, With the release of the new Nvidia Pascal drivers for macOS, and the flurry of interest that's generated regarding which GPU for which app, I've been in conversation with Rob Art Morgan from http://barefeats.com ( @barefeats on twitter) about trying to figure which of the current Nvidia cards ar...
by mattspace
Tue Apr 18, 2017 4:35 am
 
Forum: Autopano - Bugs & discussion
Topic: Measuring APG's OpenGL / GPU utilisation.
Replies: 0
Views: 623

Nvidia just announced native Mac Pascal drivers.

For folks holding on to their 2009-2012 Cheesegrater Mac Pros, here's hoping this provides a significant boost in APG responsiveness with support for the 10xx and new Titan Xp.

https://blogs.nvidia.com/blog/2017/04/06/titan-xp/
by mattspace
Thu Apr 06, 2017 5:59 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Nvidia just announced native Mac Pascal drivers.
Replies: 0
Views: 284

APG with multiple GPUs

Hi, I know APG doesn't support splitting tasks across multiple GPUs, but how does it deal with a situation where you might have multiple GPUs installed, have your displays plugged into one card, but want APG to use a different / more powerful non-display GPU? Do you still get any UI / responsiveness...
by mattspace
Wed Apr 05, 2017 7:55 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: APG with multiple GPUs
Replies: 1
Views: 342

Re: APG 4.4: Mac WIFI Scanning bug still present.

Extended description of the problem as requested by @kolorcompany on twitter, including the full launch to quit cycle of APG, as seen in wifi.log:

Here.
by mattspace
Mon Apr 03, 2017 9:37 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.4: Mac WIFI Scanning bug still present.
Replies: 6
Views: 1448

Re: APG 4.4: Mac WIFI Scanning bug still present.

Hi Oliver, I disabled the anonymous usage statistics in Preferences, if that's what you mean. It has no effect. If there's something else to disable, I haven't found any other references to analytics. I'm additionally curious as to why APG 4.4 is attempting to connect to support.google.com on quit (...
by mattspace
Thu Mar 30, 2017 5:11 pm
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.4: Mac WIFI Scanning bug still present.
Replies: 6
Views: 1448

APG 4.4: Mac WIFI Scanning bug still present.

Problem persistes in APG 4.4 (2017-03-25), running on MacOS X Yosemite 10.10.5. Launch, and then quit as soon as the UI is up and settled. 288 lines of entries in wifi.log in 30 seconds, and that rate continues as long as the app is running. A constant repeating loop of APG polling airportd to condu...
by mattspace
Thu Mar 30, 2017 4:38 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.4: Mac WIFI Scanning bug still present.
Replies: 6
Views: 1448

Re: APG 4.2 constantly activating WIFI scanning

continuing... Wed Mar 29 20:32:02.135 <kernel> IO80211ScanManager::startScan: Broadcast scan request received from 'airportd' (pid 1097) (). Wed Mar 29 20:32:02.135 <kernel> IO80211ScanManager::startScan: Initiating scan. Wed Mar 29 20:32:02.136 Info: <airportd[1097]> QUERY SCAN CACHE request receiv...
by mattspace
Wed Mar 29, 2017 11:39 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.2.3 constantly activating WIFI scanning
Replies: 3
Views: 867

Re: APG 4.2 constantly activating WIFI scanning

Launch APG, get the UI up, and then quit immediately produces more traffic in the wifi.log than this forum can have in a single post... wifi.log output. Wed Mar 29 20:31:40.949 IPC: <airportd[1097]> ADDED XPC CLIENT CONNECTION [AutopanoGiga (pid=1688, euid=502, egid=20)] Wed Mar 29 20:31:40.950 Info...
by mattspace
Wed Mar 29, 2017 11:38 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.2.3 constantly activating WIFI scanning
Replies: 3
Views: 867

Re: APG 4.2 constantly activating WIFI scanning

wifi.log is also full of references to APG interacting with WIFI

Turning off WIFI whenever I want to render with APG is not a tenable situation.
by mattspace
Wed Mar 29, 2017 9:24 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.2.3 constantly activating WIFI scanning
Replies: 3
Views: 867

APG 4.2.3 constantly activating WIFI scanning

Hi, I've noticed whenever I've got a render running with APG 4.2 on MacOSX Yosemite 10.10.5, that system.log in my console is constantly being filled with messages from airportd conducting a scan of local wifi networks. This is something that is only supposed to happen when opening the airport menul...
by mattspace
Wed Mar 29, 2017 8:55 am
 
Forum: Autopano - Bugs & discussion
Topic: APG 4.2.3 constantly activating WIFI scanning
Replies: 3
Views: 867

Re: GPU utilisation in APG [SOLVED]

olivierbo wrote:APG uses OpenGL only.
We recommend a dedicated GPU with 2Gb as a minimum. 4Gb sounds good.


Fantastic - just what I was looking for, thanks.

olivierbo wrote:That said, we are still working to improve general performances.


Any update on getting the RAW decoder to process multiple files in parallel?

Cheers,
by mattspace
Thu Feb 23, 2017 1:40 am
 
Forum: Autopano - Bugs & discussion
Topic: GPU utilisation in APG
Replies: 3
Views: 929

GPU utilisation in APG [SOLVED]

Hi, So, I have 12 physical 3ghz Xeon cores, 48GB of RAM, but a GPU that's only one level above that bird in the Flintstones that lives in a camera and chisels an image on stone when you press the button. What can I do to improve the performance of APG from a user interaction perspective? Does APG ac...
by mattspace
Sun Feb 19, 2017 7:21 am
 
Forum: Autopano - Bugs & discussion
Topic: GPU utilisation in APG
Replies: 3
Views: 929
Next

Return to advanced search



cron