Search found 47 matches

Return to advanced search

Re: AutoPano 4 - RAW decoding on multiple cores ?

Still wondering if the topic will be addressed... once

PS : I tried a 'Detection' on a series of 10 RAW pics (13MB each), 80-85 % of the time was for decoding RAW (1 tread), the rest was done in 15-20 % (8 threads), it was said earlier in this post it would be simple to implement
by atuor
Sun Oct 16, 2016 11:08 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

QT xcb - AP 4.2.3 on OpenSuse

Hi, Since version 4.2.3 (Opensuse 13.2 x64) I get this message: (and it won't start) This application failed to start because it could not find or load the Qt platform plugin "xcb". Available platform plugins are: xcb. Reinstalling the application may fix this problem. Does anyone know whi...
by atuor
Tue Jan 12, 2016 2:00 pm
 
Forum: Autopano - Bugs & discussion
Topic: QT xcb - AP 4.2.3 on OpenSuse
Replies: 0
Views: 477

Re: AutoPano 4 - RAW decoding on multiple cores ?

I'm wondering if this is still atopic for Kolor ?
by atuor
Wed Dec 30, 2015 10:35 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

It finally didn't make it on 4.2, never mind maybe the next release :-)
by atuor
Sun Sep 06, 2015 8:30 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

Yep I think multi threaded RAW decoding definitely makes sense. Hope Kolor team can implement it on upcoming version :p
by atuor
Sun Jul 19, 2015 12:46 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

Wondering, will the feature be in 4.2 which is going beta ?
by atuor
Fri Jul 10, 2015 5:11 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

Great :-D, looking forward to it
by atuor
Fri Mar 20, 2015 1:36 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

@AlexandreJ
Hi,
Finally, as this feature seems interesting and Proposition A found some concencus, how do you see the implementation in the release schedule ? Do you think it may come in a 4.x version or rather version 5 or whatever ?
Thanks
by atuor
Wed Mar 18, 2015 2:05 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

We need to look into that part, as this is clearly not the main purpose of autopano, to provide you raw decoding. We've put that as a commodity, but if you need more in that area, several development have to be done. On the multithreading part: A) We can decode several raws in parallel. This is eas...
by atuor
Wed Feb 18, 2015 3:18 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: AutoPano 4 - RAW decoding on multiple cores ?

Still wondering, is it an issue ? Known but not possible ? Would be nice to have a statement :)
by atuor
Sat Jan 10, 2015 10:33 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

Yep with the Nvidia proprietary drivers it works fine (Beta 1) with GPU enabled
by atuor
Sun Dec 21, 2014 6:20 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

AutoPano 4 - RAW decoding on multiple cores ?

I've ever since wondered why AP only uses 1 core @100% to decode RAW images. Wouldn't there be a way to have 1 thread per image so as all cores could be used to decode it ? RAW decoding is what takes longest when detecting and assembling, As an example, it took 1min 42 on my Laptop to decode the 26 ...
by atuor
Sun Dec 21, 2014 6:16 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano 4 - RAW decoding on multiple cores ?
Replies: 16
Views: 3148

AutoPano Giga 4 beta 2 on OpenSuse Linux 13.2 64bit [SOLVED]

Beta 1 finally worked fine, see post


viewtopic.php?f=109&t=24661

Downloaded Beta 2, and it won't start at all.

If I launch ./AutopanoGiga instead of the .sh, I get a segmentation fault
by atuor
Sun Dec 21, 2014 5:17 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: AutoPano Giga 4 beta 2 on OpenSuse Linux 13.2 64bit
Replies: 1
Views: 379

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

Ooops, now that Beta 1 works, Beta 2 doesn't even launch...
by atuor
Sun Dec 21, 2014 2:11 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

Well yes, disabling GPU works fine now :-)
by atuor
Sun Dec 21, 2014 11:59 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

I'm getting crashes when editing, maybe a graphics driver issue ? (nouveau), what settings do you use for GPU ? and what graphics card/driver do you have ?
by atuor
Sun Dec 21, 2014 11:31 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

Hi Antoine,
Thanks for the files. it starts fine now. I know OpenSuse may not be supported, it has always worked fine though since I own a License of AP. I'll post feedback on it on this thread when tests go on ;-)
by atuor
Thu Dec 18, 2014 12:32 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

Re: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

So it launches on your OpenSuse 13.2 ? do you have libicui18n.so.52 or libicuio.so.53.1 ?
by atuor
Thu Dec 18, 2014 7:05 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit [SOLVED]

Won't start unfortunately, AutopanoGiga> sh AutopanoGiga.sh ./AutopanoGiga: error while loading shared libraries: libicui18n.so.52: cannot open shared object file: No such file or directory Available by default on OpenSuse 13.2 is is ver. 53 of the library -> libicu53_1 Any workaround ? version 4 se...
by atuor
Wed Dec 17, 2014 4:10 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: First Try AutoPano Giga 4 beta 1 on OpenSuse 13.2 64bit
Replies: 14
Views: 1734

Sorry I meant before preview it was not OK, just after pressing preview it went OK, maybe some corrections to make in the pre-preview :)
by atuor
Wed Dec 12, 2012 8:23 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Open 2.6 360 Project with 3.0 results
Replies: 6
Views: 1408

It was the preview, I didn'render it as it was not satisfactory, but yes I tried preview and funnily that worked out fine, weird . Anyway now I get good results :)
by atuor
Wed Dec 12, 2012 8:21 pm
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Open 2.6 360 Project with 3.0 results
Replies: 6
Views: 1408

And I'm astonished by the speed and flexibility improvements over 2.6 (Linux) version :)
by atuor
Sun Dec 09, 2012 11:59 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Open 2.6 360 Project with 3.0 results
Replies: 6
Views: 1408

You're right :) there were some adjustments to make, and where AP2.6 'recognised all picture as Fisheye, AP 3.0 didn't. So I finally tried several settings, and it came out that setting all pict to Standard (I used a 9mm Micro 4/3 ) turns out to give very good results. Thanks for the input ;)
by atuor
Sun Dec 09, 2012 11:48 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Open 2.6 360 Project with 3.0 results
Replies: 6
Views: 1408

Open 2.6 360 Project with 3.0 results

I just upgraded to Giga 3.0, and wanted to have a try on older Panos saved with 2.6, results were quite unexpected. (attached Thumnails) :/ I suppose that with the new version all should be reworked ? Starting all over by just selecting pictures, letting AP automatically stitch didn't give better re...
by atuor
Sun Dec 09, 2012 11:25 am
 
Forum: Using Autopano Pro / Autopano Giga
Topic: Open 2.6 360 Project with 3.0 results
Replies: 6
Views: 1408
Next

Return to advanced search



cron